Announcement

Collapse
No announcement yet.

nvidia 180 driver doesn't work on ubuntu 8.10

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • nvidia 180 driver doesn't work on ubuntu 8.10

    I've just bought a nvidia 6800 AGP and X now won't start anymore. It tells 'failed to load the NVIDIA kernel module' after several X launching attempts.
    When I do 'sudo modprobe nvidia' it tells 'error inserting (blah blah) : no such device'. But lspci reports that I do have a nvidia 6800 on 01:00.0.

    I've seen a lot of recent complains like mine, but still no solution...

    Anyone can help ?

    Thank you

  • #2
    sudo rm /etc/X11/xorg.conf*
    sudo dpkg-reconfigure -phigh xserver-xorg

    then run this script (in text mode ctrl-alt-f1):

    http://kanotix.com/files/install-nvidia-debian.sh

    sudo sh install-nvidia-debian.sh

    Comment


    • #3
      lot of bugs

      First thank you for your help.

      Still, it doesn't work. Here's the output :
      [email protected]:~$ sudo sh install-nvidia-debian.sh
      Error: No KANOTIX found. Do not ask for support!
      grep: /etc/X11/XF86Config-4: Aucun fichier ou dossier de ce type
      Warning: /etc/X11/XF86Config-4 needs some modifications. Trying now.
      grep: /etc/X11/XF86Config-4: Aucun fichier ou dossier de ce type
      Warning: Adding "Configured Video Device" to "Screen" Section.
      Can't open /etc/X11/XF86Config-4: Aucun fichier ou dossier de ce type.
      cp: ne peut ?valuer `/etc/X11/XF86Config-4': Aucun fichier ou dossier de ce type
      patch: **** Can't find file /etc/X11/XF86Config-4 : No such file or directory
      Error: Unable to patch. Please manually fix file!
      mv: ne peut ?valuer `/etc/X11/XF86Config-4.pure': Aucun fichier ou dossier de ce type
      What is this 'kanotix' stuff that I lack ??

      Thanx

      Comment


      • #4
        Why on earth do you have got a XF86Config-4? Delete it.

        Comment


        • #5
          I actually do not have a XF86Config-4... !

          I don't know what this script asks for. Nor what '/etc/kanotix-version' stands for.

          Any idea ?

          Comment


          • #6
            Well first it checks for a xorg.conf. Maybe you did not use the

            sudo dpkg-reconfigure -phigh xserver-xorg

            which creates one.

            Comment


            • #7
              Amazing script... ! Unfortunately, the result is the same :s Here's a sample of my Xorg.0.log :
              (II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
              (II) NVIDIA(0): enabled.
              (EE) NVIDIA(0): Failed to load the NVIDIA kernel module. Please check your
              (EE) NVIDIA(0): system's kernel log for additional error messages.
              (EE) NVIDIA(0): *** Aborting ***
              (II) UnloadModule: "nvidia"
              (II) UnloadModule: "wfb"
              (II) UnloadModule: "fb"
              (EE) Screen(s) found, but none have a usable configuration.

              Comment


              • #8
                Your kernel must be not installed correctly, did you compile it yourself?

                Comment


                • #9
                  No, it is an Ubuntu 8.10, nothing exotic, just updates and security patches. It was still working fine two weeks ago. But it was a Quadro then, not the same graphic card. I've just changed to this card hoping it would solve my display problems.

                  Comment


                  • #10
                    up

                    still no more ideas ?

                    Comment

                    Working...
                    X