Announcement

Collapse
No announcement yet.

NVIDIA Ships Vulkan Driver Beta With Fragment Shading Rate Control

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • NVIDIA Ships Vulkan Driver Beta With Fragment Shading Rate Control

    Phoronix: NVIDIA Ships Vulkan Driver Beta With Fragment Shading Rate Control

    This week's Vulkan 1.2.158 spec release brought the fragment shading rate extension to control the rate at which fragments are shaded on a per-draw, per-primitive, or per-region basis. This can be useful similar to OpenGL and Direct3D support for helping to allow different, less important areas of the screen be shaded less than areas requiring greater detail/focus...

    http://www.phoronix.com/scan.php?pag...2-Linux-Driver

  • #2
    Sometime, I check release version supported in my system by vulkaninfo command where I get three different kind of information:
    1. Instance Version: 1.2.131
    2. apiVersion = 4202629 (1.2.133)
    3. conformanceVersion = 1.2.2.0
    Which are the meanings of these different pieces of vulkan information?

    Comment


    • #3
      Originally posted by Azrael5 View Post
      Sometime, I check release version supported in my system by vulkaninfo command where I get three different kind of information:
      1. Instance Version: 1.2.131
      2. apiVersion = 4202629 (1.2.133)
      3. conformanceVersion = 1.2.2.0
      Which are the meanings of these different pieces of vulkan information?
      Just different things and each have a version number. Not really going to do anything for you. You're main concern for version is to simply be on the latest driver release or not.

      conformanceVersion for example is just the Vulkan Conformance Test suite version number that was used: https://www.khronos.org/conformance/adopters
      Last edited by ix900; 21 October 2020, 11:11 AM. Reason: changed link

      Comment


      • #4
        Originally posted by ix900 View Post

        Just different things and each have a version number. Not really going to do anything for you. You're main concern for version is to simply be on the latest driver release or not.

        conformanceVersion for example is just the Vulkan Conformance Test suite version number that was used: https://www.khronos.org/conformance/adopters
        Ok, thanks. Which information does indicate the vulkan version supported by my graphical card among them?

        Comment


        • #5
          Originally posted by Azrael5 View Post

          Ok, thanks. Which information does indicate the vulkan version supported by my graphical card among them?
          instance version is the version of the vulkan library you have on the system, apiVersion is the highest vulkan version the gfx driver supports.

          Comment


          • #6
            Originally posted by mlau View Post

            instance version is the version of the vulkan library you have on the system, apiVersion is the highest vulkan version the gfx driver supports.
            Many thanks. It seems that my videocard cannot take any benefit from the latest release of Vulkan.
            Last edited by Azrael5; 23 October 2020, 03:01 PM.

            Comment


            • #7
              Originally posted by mlau View Post

              instance version is the version of the vulkan library you have on the system, apiVersion is the highest vulkan version the gfx driver supports.
              What do you mean about 2on the system2 and "gfx driver support"?

              Comment

              Working...
              X