Announcement

Collapse
No announcement yet.

Using G-SYNC Compatible On Linux With NVIDIA's 418.30 Beta Driver

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Using G-SYNC Compatible On Linux With NVIDIA's 418.30 Beta Driver

    Phoronix: Using G-SYNC Compatible On Linux With NVIDIA's 418.30 Beta Driver

    Taking many by surprise less than one month after NVIDIA announced "G-SYNC Compatible" in supporting FreeSync/Adaptive-Sync displays as an alternative to the more expensive dedicated G-SYNC monitors, the newest Linux beta graphics driver has support for this gamer-oriented feature. This comes just a matter of days after NVIDIA began shipping their Windows driver with this dynamic refresh rate feature that aims to eliminate or at least reduce tearing and stuttering.

    http://www.phoronix.com/vr.php?view=27480

  • #2
    Unfortunately, G-SYNC Compatible doesn't appear to work with multi-head setups, at least for the MG28U configuration I rely upon as my main desktop configuration.
    This is a limitation even on regular GSync monitors as well, as it only activates if the game is covering the entire X screen (both monitors). In dual monitor mode, the game only covers the portion screen it is active on, so GSync never activates. There are a couple of work around:
    1) Deactivate the second monitor while gaming.
    2) Run the second monitor on a separate GPU in a separate X server, unifying the input with Synergy.

    Comment


    • #3
      This limitation does not exist under Windows afaik, why would it exist under Linux? no real fix possible? running on a separate X server makes multitasking a issue.. Hmmm...

      I have a 4k compat screen and a 1080p screen to the right side with no compat, seems like a odd issue.

      EDIT: I just remembered that my 1080p is connected via HDMI, so perhaps I won't have dual screen issue since it won't factor that in anyway?.. will see.

      After further testing, going to give it a rating of 0 out of 10. Works flawless on windows but its clearly broken under Linux, even with disabling second screen the indicator shows up %1 of the time, and gsync doesn't work.. crappy. Seems it requires you to stand on your head, touch your nose, and bounce up and down...... LMAO
      Last edited by theriddick; 01-30-2019, 10:44 PM.

      Comment


      • #4
        OK going to double post for this because its of the utmost importance for XFCE users.

        First thing to note, to get gsync to work you need to DISABLE Force Composition Pipeline AND Force Full Composition Pipeline,

        Second thing to note is that XFCE window manager may mess up flipping mode, so if you continue to get issues then consider switching composers to compton or disable XFCE before launching game.

        I have testing this with Warthunder under Vulkan API and it works pretty good. Kinda regretting using XFCE now and then, wondering if like would be better to just go back to Plasma....

        EDIT: Compton doesn't work either with gsync.. damn

        EDIT2: After lots of reading and testing, GSYNC basically doesn't work with MOST compositors out there and you must disable them before launching your game. That's annoying but is current state of GSYNC under Linux. I will test out Plasma5 later tonight and see how Kwin goes,...
        Last edited by theriddick; 01-30-2019, 11:57 PM.

        Comment


        • #5
          EDIT2: After lots of reading and testing, GSYNC basically doesn't work with MOST compositors out there and you must disable them before launching your game. That's annoying but is current state of GSYNC under Linux. I will test out Plasma5 later tonight and see how Kwin goes,..
          Kwin's automatic suspension of compositing when games request it really comes in handy here for the very reasons you mention - when a compositor is active, gsync doesn't usually turn on.

          Comment


          • #6
            This limitation does not exist under Windows afaik, why would it exist under Linux? no real fix possible? running on a separate X server makes multitasking a issue.. Hmmm...
            Windows has the concept of exclusive full screen which allows an app to fully take over a screen and Nvidia uses this to enable gsync while a second monitor is active. This is however when alt-tab gets frequently broken and causes other issues which push folks to pursue borderless fullscreen modes. And with a game in borderles full screen mode, gsync has the same limitations in multi-monitor configurations as Linux.

            Comment


            • #7
              Yes that is true, using xfce without compositor is a option, however for me disabling nvidia's fullcompositorpipeline stuff does result in some screen tearing at times, not sure howto fix since gsync doesn't appear to want to work with them enabled.

              EDIT: Finally got around to installing the kda meta for antergos/arch and I must say it works pretty good, gsync does enable with no need to kill kwin beforehand, nice.
              Does still require disabling of secondary monitor, I do hope NVIDIA ad in support for multi-monitor setup and also window mode.
              Last edited by theriddick; 01-31-2019, 06:52 AM.

              Comment


              • #8
                I wonder which distro was used by Phoronix in this article. Ubuntu?

                I've been trying to get this to work with Fedora 29, but I'm unsuccessful. Vsync indicator shows that output falls back to BLIT instead of flipping, which is required for G-sync to work. I can't get the G-sync indicator to show on screen at all. I'm suspecting this is a gnome/mutter problem.

                Comment

                Working...
                X