Announcement

Collapse
No announcement yet.

Videos Of Unity Running On Mir Via X Server

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • phoronix
    started a topic Videos Of Unity Running On Mir Via X Server

    Videos Of Unity Running On Mir Via X Server

    Phoronix: Videos Of Unity Running On Mir Via X Server

    Canonical has begun posting videos of Mir in action. While Mir itself doesn't do much yet, a video by one of the Mir developers shows Unity running on Mir. But it's running Unity through an X Server via the "XMir" project...

    http://www.phoronix.com/vr.php?view=MTMxODQ

  • chenxiaolong
    replied
    Originally posted by ChrisXY View Post
    HD 4000 from ivy bridge.

    The last crash comes from 3.9rc1 I think, I had similar hangs when just switching from tty to X, so that was unfair as it wasn't wayland/weston's fault.

    In the past I had compiled wayland, weston, xwayland and the xf86-video-intel xwayland driver from git, this time it was wayland from the repositories, the xwayland-1.12 branch from git://anongit.freedesktop.org/xorg/xserver, the xwayland branch from git://anongit.freedesktop.org/xorg/driver/xf86-video-intel and a recompiled weston 1.0.5 with just "--enable-xwayland --with-xserver-path=/opt/xwayland/bin/Xorg" added.

    also, freedesktop.org still unavailable. Really?
    Ah, I'm using the latest stable kernel, 3.8.2. That said, I do experience some XWayland segfaults, but only when I try to run an OpenGL program. With regular usage, I'm not seeing any crashes.

    I've been able to access freedesktop.org git repos all day, but that's on a different server. EDIT: Their main website is loading fine here.

    Leave a comment:


  • ChrisXY
    replied
    HD 4000 from ivy bridge.

    The last crash comes from 3.9rc1 I think, I had similar hangs when just switching from tty to X, so that was unfair as it wasn't wayland/weston's fault.

    In the past I had compiled wayland, weston, xwayland and the xf86-video-intel xwayland driver from git, this time it was wayland from the repositories, the xwayland-1.12 branch from git://anongit.freedesktop.org/xorg/xserver, the xwayland branch from git://anongit.freedesktop.org/xorg/driver/xf86-video-intel and a recompiled weston 1.0.5 with just "--enable-xwayland --with-xserver-path=/opt/xwayland/bin/Xorg" added.

    also, freedesktop.org still unavailable. Really?

    Leave a comment:


  • chenxiaolong
    replied
    Originally posted by ChrisXY View Post
    Except it doesn't work well, at least with the intel driver.

    A few months ago it actually worked for a short time, even with OpenGL, but it was very crashy and X clients would often just lose the connection.

    A few weeks ago it just segfaulted the xserver when starting any X client in weston on a tty and when starting an X client using opengl in weston in X. A few weeks past that it still did the same.

    Now there were a few commits to xwayland and the intel driver so I tested it again. I used the wayland/weston versions from archlinux repos and xwayland/xf86-video-intel from git. First, I had to google a weston 1.0.5 tarball since http://freedesktop.org/ is 503. Again. What's with that website, that it's unavailable so often?

    Positive: xwayland in weston as an X client works well now, even with opengl.
    Negative: In a tty, xwayland still segfaults when starting any x client (I tried xterm):
    Code:
    [  3326.427] (WW) intel(0): drmSetMaster failed: Permission denied
    [  3326.427] 
    [  3326.427] Backtrace:
    [  3326.428] 0: /opt/xwayland/bin/Xorg (xorg_backtrace+0x36) [0x55dbf6]
    [  3326.428] 1: /opt/xwayland/bin/Xorg (0x400000+0x161b19) [0x561b19]
    [  3326.428] 2: /usr/lib/libpthread.so.0 (0x7f6eea488000+0xf1e0) [0x7f6eea4971e0]
    [  3326.428] 3: /opt/xwayland/lib/xorg/modules/drivers/intel_drv.so (0x7f6ee6c21000+0x147b8) [0x7f6ee6c357b8]
    [  3326.428] 4: /opt/xwayland/lib/xorg/modules/drivers/intel_drv.so (0x7f6ee6c21000+0x1575e) [0x7f6ee6c3675e]
    [  3326.428] 5: /opt/xwayland/lib/xorg/modules/drivers/intel_drv.so (0x7f6ee6c21000+0x15cb8) [0x7f6ee6c36cb8]
    [  3326.428] 6: /opt/xwayland/bin/Xorg (AddScreen+0x189) [0x434979]
    [  3326.428] 7: /opt/xwayland/bin/Xorg (InitOutput+0x28e) [0x4726ae]
    [  3326.428] 8: /opt/xwayland/bin/Xorg (0x400000+0x23646) [0x423646]
    [  3326.428] 9: /usr/lib/libc.so.6 (__libc_start_main+0xf5) [0x7f6ee9520a15]
    [  3326.428] 10: /opt/xwayland/bin/Xorg (0x400000+0x23abd) [0x423abd]
    [  3326.428] 
    [  3326.428] Segmentation fault at address (nil))
    I don't see where exactly the permission problem is, so I don't really know how to workaround it. weston-launch at least has +s.

    So if they have an accelerated X client in MIR, they are de facto already better than wayland/weston.

    (Not to forget, it crashed my intel driver, lots of:
    Code:
    [ 3374.657397] [drm:atom_op_jump] *ERROR* atombios stuck in loop for more than 5secs aborting
    [ 3374.657402] [drm:atom_execute_table_locked] *ERROR* atombios stuck executing D46E (len 62, WS 0, PS 0) @ 0xD48A
    [ 3379.665858] [drm:atom_op_jump] *ERROR* atombios stuck in loop for more than 5secs aborting
    )
    That's strange. What Intel chip do you have? My Intel HD3000 works fine on Arch with XWayland (in TTY). I'm not using AUR packages though. I manually compiled wayland, weston, mesa, xorg (xwayland-1.12 branch), and xf86-video-intel (xwayland branch) from git.

    Leave a comment:


  • ChrisXY
    replied
    Originally posted by nerdopolis View Post
    You could run a full rooted x server on Wayland since 2008.
    http://hoegsberg.blogspot.com/2008/1...icrophone.html
    Except it doesn't work well, at least with the intel driver.

    A few months ago it actually worked for a short time, even with OpenGL, but it was very crashy and X clients would often just lose the connection.

    A few weeks ago it just segfaulted the xserver when starting any X client in weston on a tty and when starting an X client using opengl in weston in X. A few weeks past that it still did the same.

    Now there were a few commits to xwayland and the intel driver so I tested it again. I used the wayland/weston versions from archlinux repos and xwayland/xf86-video-intel from git. First, I had to google a weston 1.0.5 tarball since http://freedesktop.org/ is 503. Again. What's with that website, that it's unavailable so often?

    Positive: xwayland in weston as an X client works well now, even with opengl.
    Negative: In a tty, xwayland still segfaults when starting any x client (I tried xterm):
    Code:
    [  3326.427] (WW) intel(0): drmSetMaster failed: Permission denied
    [  3326.427] 
    [  3326.427] Backtrace:
    [  3326.428] 0: /opt/xwayland/bin/Xorg (xorg_backtrace+0x36) [0x55dbf6]
    [  3326.428] 1: /opt/xwayland/bin/Xorg (0x400000+0x161b19) [0x561b19]
    [  3326.428] 2: /usr/lib/libpthread.so.0 (0x7f6eea488000+0xf1e0) [0x7f6eea4971e0]
    [  3326.428] 3: /opt/xwayland/lib/xorg/modules/drivers/intel_drv.so (0x7f6ee6c21000+0x147b8) [0x7f6ee6c357b8]
    [  3326.428] 4: /opt/xwayland/lib/xorg/modules/drivers/intel_drv.so (0x7f6ee6c21000+0x1575e) [0x7f6ee6c3675e]
    [  3326.428] 5: /opt/xwayland/lib/xorg/modules/drivers/intel_drv.so (0x7f6ee6c21000+0x15cb8) [0x7f6ee6c36cb8]
    [  3326.428] 6: /opt/xwayland/bin/Xorg (AddScreen+0x189) [0x434979]
    [  3326.428] 7: /opt/xwayland/bin/Xorg (InitOutput+0x28e) [0x4726ae]
    [  3326.428] 8: /opt/xwayland/bin/Xorg (0x400000+0x23646) [0x423646]
    [  3326.428] 9: /usr/lib/libc.so.6 (__libc_start_main+0xf5) [0x7f6ee9520a15]
    [  3326.428] 10: /opt/xwayland/bin/Xorg (0x400000+0x23abd) [0x423abd]
    [  3326.428] 
    [  3326.428] Segmentation fault at address (nil))
    I don't see where exactly the permission problem is, so I don't really know how to workaround it. weston-launch at least has +s.

    So if they have an accelerated X client in MIR, they are de facto already better than wayland/weston.

    (Not to forget, it crashed my intel driver, lots of:
    Code:
    [ 3374.657397] [drm:atom_op_jump] *ERROR* atombios stuck in loop for more than 5secs aborting
    [ 3374.657402] [drm:atom_execute_table_locked] *ERROR* atombios stuck executing D46E (len 62, WS 0, PS 0) @ 0xD48A
    [ 3379.665858] [drm:atom_op_jump] *ERROR* atombios stuck in loop for more than 5secs aborting
    )
    Last edited by ChrisXY; 03-06-2013, 05:32 AM.

    Leave a comment:


  • phoen1x
    replied
    Originally posted by entropy View Post
    BINGO. That's what i thought it is. Canonical doesn't have man power to create something completely from scratch. Too bad this thread still has brainwashed tards.

    Leave a comment:


  • liam
    replied
    Originally posted by daniels View Post
    OK ... that doesn't actually mean anything.
    ...obviously he means they've finally cracked the problem of creating a generic graphics interface that has no dependencies other than the kernel...you know... a framebuffer

    Leave a comment:


  • entropy
    replied
    Originally posted by chenxiaolong View Post
    Canonical still hasn't opened up the XMir code at lp:~rocket-scientists/xserver/xmir
    It's basically xwayland...

    https://twitter.com/hoegsberg/status/308706022447542272

    Leave a comment:


  • daniels
    replied
    Originally posted by e8hffff View Post
    Their objective is less heavy than Wayland. They only need to deal with rudimentary management and to sideline x11 and Android drivers.
    OK ... that doesn't actually mean anything.

    Leave a comment:


  • pbrgdmkj
    replied
    it will clear things up for some of those folks.

    Leave a comment:

Working...
X