Announcement

Collapse
No announcement yet.

Intel Skylake Multi-Screen Issues On Linux Still Happening

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Intel Skylake Multi-Screen Issues On Linux Still Happening

    Phoronix: Intel Skylake Multi-Screen Issues On Linux Still Happening

    While Intel Skylake hardware has been available for one year now, various issues persist for Linux desktop users wishing to make use of Skylake graphics on Intel's open-source Linux driver...

    http://www.phoronix.com/scan.php?pag...ti-Screen-Woes

  • #2
    Not to mention the psr issue plaguing intel gfx users since kernel 4.6... https://bbs.archlinux.org/viewtopic....47127#p1647127

    Comment


    • #3
      Noob question: What are those watermark calculations mentioned in the article? Do they have anything to do with copy protection?

      Comment


      • #4
        Why would they bother with proper multimonitor support, when they can run OpenGL 4.5 programs at 1 fps? Priorities!

        Comment


        • #5
          Originally posted by halo9en View Post
          Not to mention the psr issue plaguing intel gfx users since kernel 4.6... https://bbs.archlinux.org/viewtopic....47127#p1647127
          I'm using Skylake right now on a laptop on 4.7; no freezing and haven't had to use that psr boot flag. Had no problems on 4.6 either.

          Comment


          • #6
            Originally posted by Espionage724 View Post
            I'm using Skylake right now on a laptop on 4.7; no freezing and haven't had to use that psr boot flag. Had no problems on 4.6 either.
            Sorry, my post was not related to skylake (my cpu is haswell), more to Intel's linux driver in general.

            Comment


            • #7
              Originally posted by jf33 View Post
              Noob question: What are those watermark calculations mentioned in the article? Do they have anything to do with copy protection?
              I suspect it's about keeping memory buffers filled, the origin of the term being this one.

              In a producer-consumer situation you want to keep the amount of data small enough that the buffer doesn't fill up, but large enough that it doesn't end up empty. Low and high water marks are terms for the minimum and maximum encountered or acceptable fill level.

              Comment


              • #8
                Skylake aren't the only chips with multi-monitor support issues. On my Haswell laptop, I have terrible screen flicker issues on my HDMI connected screen! I hope Intel gets its act together soon with such trivial feature support! I like their hardware, but their consistent lack of solid and usable day 1 feature support is definitely making me think hard about my risking my next hardware purchase on an Intel machine.

                Comment


                • #9
                  The Intel Skylake Mobile Graphics support is horrible. I am experiencing a lot of flickering and mouse cursor issues, not to mention the occasional GPU lockups. I think the Intel people are completely out of control of this situation, just look at the freedesktop.org Bugzilla. There are tons of outstanding Skylake issues, many of which are confirmed as reproducible by Intel people, but no fixes are available.

                  Just to give you an example:

                  https://bugs.freedesktop.org/show_bug.cgi?id=96419
                  https://bugs.freedesktop.org/show_bug.cgi?id=97242
                  https://bugs.freedesktop.org/show_bug.cgi?id=94605

                  I can only recommend to keep your fingers off the Intel Skylake platform, if you are using more than one display.

                  And that firmware thing might make Kernel 4.8 a no-go for Skylake laptop owners. There isn't even a fix for this in drm-intel-nightly yet, although the patch would be trivial...

                  Comment


                  • #10
                    Haswell monitor switch trouble continues on my system for months now resulting in a total system freeze when trying to shut down my laptop after disconnecting from the docking station. Filed a bug over a month ago - no one on the inte dev camp seems to pay attention!

                    https://bugs.freedesktop.org/show_bug.cgi?id=96938

                    Comment

                    Working...
                    X