Announcement

Collapse
No announcement yet.

Intel's Unreleased 3.0 X.Org Driver Gets More Fixes For DRI3/Present

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Intel's Unreleased 3.0 X.Org Driver Gets More Fixes For DRI3/Present

    Phoronix: Intel's Unreleased 3.0 X.Org Driver Gets More Fixes For DRI3/Present

    In addition to the X.Org Server still seeing DRI3 and Present extension fixes, the xf86-video-intel and xf86-video-ati DDX drivers for X.Org have also been seeing more DRI3/Present fixes recently...

    http://www.phoronix.com/scan.php?pag...ore-DRI3-Fixes

  • #2
    Recently got rid of xf86-video-intel. No regrets
    This driver is bloated (UXA is fine, SNA is a big codebase barely maintainable by one person), full of...

    Comment


    • #3
      Originally posted by johnp117 View Post
      Recently got rid of xf86-video-intel. No regrets
      OMG. Totem is working again! Thanks!

      Comment


      • #4
        Well, my point in that reddit thread still stands - as long as modesetting does not properly synchronize prime offloading with dri3.

        Incidentally the last 6 commits to xf86-video-intel are because of my problems using prime offloading with dri3 for minetest and it is still not completely fixed.

        Well, using UXA instead of SNA might be a quicker workaround...

        Comment


        • #5
          Not a lot of alternatives... xf86-video-intel is broken for me on Skylake (terminal cursor/highlights don't update properly, in both xterm and aterm), and modesetting is slow-as-molasses (with the wator screensaver demonstrating that quite aptly).

          Comment


          • #6
            maybe they release v3.0 in the year of the Linux desktop - that could be either 2017 or 2018, or if we are unlucky any other year thereafter :-/!

            Comment


            • #7
              i never had problems with sna but i agree they should make some stable snapshots, at least every year

              Comment


              • #8
                Originally posted by imirkin View Post
                Not a lot of alternatives... xf86-video-intel is broken for me on Skylake (terminal cursor/highlights don't update properly, in both xterm and aterm), and modesetting is slow-as-molasses (with the wator screensaver demonstrating that quite aptly).

                try to use the debian/ubuntu version, they have some patchs

                Comment


                • #9
                  Originally posted by andre30correia View Post
                  try to use the debian/ubuntu version, they have some patchs
                  Yeah that's not gonna happen - distribution is not something that you change because it has some patches. I could take the patches they have and apply them to my tree, of course. However I doubt there's anything there that fixes these issues -- Chris (Wilson) was not able to quickly identify the issue, and my bug report has gone dormant... Dave (Airlie) wrote a patch to improve GLAMOR perf for modesetting, which helped but not enough.

                  Comment


                  • #10
                    I noticed that Arch recently removed DRI3 config details from their wiki: https://wiki.archlinux.org/index.php/intel_graphics

                    I think it was just leading to too many stability issues. Shame, because vsync is still broken under Gnome 3 / Intel DRI2...

                    Comment

                    Working...
                    X