Announcement

Collapse
No announcement yet.

Intel's Core i7 5775C Broadwell Is Running Well On Ubuntu 15.10

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Intel's Core i7 5775C Broadwell Is Running Well On Ubuntu 15.10

    Phoronix: Intel's Core i7 5775C Broadwell Is Running Well On Ubuntu 15.10

    This summer I wrote about some issues I had with the Core i7 5775C on Linux where under Ubuntu 15.04 the experience was unstable but this socketed Broadwell was running great on Fedora 22. Fortunately, the Ubuntu experience for the i7-5775C with Iris Graphics is much better under the upcoming Ubuntu 15.10 "Wily Werewolf" release.

    http://www.phoronix.com/vr.php?view=22245

  • #2
    There was also a BIOS update from MSI that may have helped the situation too.
    Not may have, BIOS update is exactly what eliminated kernel panics with broadwell cpus.
    Intel released hardware ridden with bugs, fortunately MSI recieved microcode update from Intel and released BIOS conainting 0x12 microcode.
    However, Intel showed middle finger to users, that bought their buggy hardware, and refused to release microcode update to users, making it available only to motherboard vendors.
    Fortunately, some good guy extracted blobs from MSI BIOS, so that we, non-MSI users, can load it early during boot.

    https://bugzilla.kernel.org/show_bug.cgi?id=103351

    Funny thing, these broadwell cpus have haswell's Hardware Ellision Lock errata and 0x12 microcode update does not fix or workaround that. So expect crashes in libpthread with glibc2.22.
    Last edited by magika; 10-15-2015, 06:39 AM.

    Comment


    • #3
      Originally posted by magika View Post
      Funny thing, these broadwell cpus have Haswell Ellision Lock errata and 0x12 microcode update does not fix or workaround that. So expect crashes in libpthread with glibc2.22.
      Very embarassing for Intel, I wonder if it also affects Haswell-EX (Xeon E7)?

      Comment


      • #4
        It definitely does not seem to be resolved by the Ubuntu 15.10 release. I have an i5-5675C and following advice here on Phoronix have been running Fedora 22 for two months now. The system has been more or less stable. Thing is, I'm not that happy with Fedora and would like to switch back to Kubuntu as soon as I can. Today I tried installing Kubuntu 15.10, but never made it through the installer. The system invariably crashes sooner or later (sometimes even before finishing the boot process). I haven't found a way to look at the logs, since it boots from a live system on USB and the logs are gone after the reboot. But once it crashed while in console mode and printed the error on screen: It is indeed the "Machine check exception" that has been causing so much trouble.

        I have an Asus Z97I-Plus, and the latest firmware is from May 2015, so no help there.

        So for some reason, this processor plays nice with Fedora, but not Ubuntu, and this does not seem to have changed with Wily Werewolf. Any advice on how to proceed to get Kubuntu up and running if I can't even make it through the installer?

        Comment


        • #5
          My apologies to reply to myself here. This is not only embarrassing for Intel. This is also embarrassing for the motherboard manufacturers who should be pressuring Intel to provide them with working microcode updates and should then issue new BIOS revisions. After all, these processors are on their compatibility list. I contacted Asus with this issue. Guess what they replied: Linux is not an officially supported system on this motherboard and the symptoms I encounter are therefore normal.

          Does Linux support in the industry really still suck so bad that Asus can shrug off any issues under Linux just like that? I know the graphics card manufacturers are notorious for more or less ignoring Linux, but I thought that was because Linux gaming was still somewhat of a niche. Na?vely, I imagined Asus would not so easily give the finger to the Linux community.

          Comment


          • #6
            Perhaps there is a solution now! According to https://bugzilla.kernel.org/show_bug.cgi?id=103351 'Intel has issued a new public microcode update datafile, which should address the broadwell MCE errata.'
            Asus has updated the bios for the Z97I-PLUS today and I hope it includes this new microcode and that it will solve the stability issues.

            Comment


            • #7
              Thanks, ErikA, for the info! I had seen the message on bugzilla about the new microcode, but at that time ASUS had nothing new on their website - and I had not checked since. I just installed the new UEFI (v2701), but an attempt at installing Ubuntu will have to wait until tomorrow evening at least. For now I can only confirm that this updated my CPU microcode to 0x13, so hopefully the issue should be resolved.

              phoronix How about a very quick article about this issue and the fact that Intel has addressed it with new CPU microcode? Right now the latest on this issue on Phoronix is the title of this article, which we know now to be wrong. The fix is not related to Ubuntu in any way, but requires motherboard manufacturers to push out updates. I guess Ubuntu could also be providing the updated microcode, but in the current installer images this microcode does not seem to be present, thus preventing installation on affected systems.

              Comment


              • #8
                I have the ASUS Z97I-PLUS board and an i7-5775c cpu. With the bios from May (ver. 2605) it would not run (K)ubuntu or OpenSuse, but worked without problems with Fedora 22. I have updated the bios to latest version that came last Friday (ver. 2701) and now it looks like it can run Kubuntu 15.04. Before I could not even check the dvd for errors before it crashed - usually within a few seconds. I have not installed Kubuntu, but I have tested the live version for about an hour without any problems. I have not tested OpenSuse again but don't expect problems.

                Comment


                • #9
                  Same here. I have successfully installed Ubuntu 15.04 (well, actually Kubuntu) on my ASUS Z97I-PLUS with i5-5675C CPU. I do have a few issues with the install (Plasma is taking its precious time upon login and is generally not very stable), but my impression is that they are not related to the CPU. Before only Fedora 22 would work. The Ubuntu installer would always quit within a few minutes.

                  Comment


                  • #10
                    Sorry, I installed Kubuntu 5.10, not 5.04.

                    Comment

                    Working...
                    X