No announcement yet.

Intel core i3 + HD graphics black screen

  • Filter
  • Time
  • Show
Clear All
new posts

  • Intel core i3 + HD graphics black screen


    I desperately try to have linux working on my new PC

    Whatever the distro, kernel version, intel driver version I get a black screen at boot, and the only way to have a display is to boot with the nomodeset option, the result is a very low resolution.

    I suspect a screen issue, as if the driver doesn't succeed to ged EDID info from the panel, which is an HP 1920x1080 LCD display.

    If someone could help me it would be great because I'm running out of ideas and I'm tired to browse the forums

    Here are some relevant informations :

    PC : HP All in One 200-5130 "WX099EA"

    result of lspci is here :

    CPU : core i3 + HD graphics

    Distro : Opensuse 11.3 but I tried Ubuntu 10.10, Fedora 14, Debian 6 all in X64 version with the same result.

    Kernel : 2.6.36, 2.6.37, 2.6.38

    Graphics package : Intel driver 2.13 and 2.14
    Mesa 7.10
    X server 1.9

    Here is the Xorg log with kernel 2.6.37 and all the latest graphics packages

    As I said, it looks like the driver is unable to detect a screen.
    Yet the VESA driver succeeds in this task :

    But the VESA driver is unable to set a 1920x1080 resolution!

    Of course I tried different tweak as Xorg -configure, tune the xorg.conf.d/50-screen.conf, but without success.

    Thank you to spend some time on my issue that drives me crazy!

  • #2
    Same problem here, but my model is different

    Hi. First post in here. Just registered in the forum because I saw your response.

    My PC is the HP All-in-One Omni 200 PC model 5320br.

    One link with my findings.

    Basically, the problem is that:
    - the VGA-1 (or VGA1) connector is seen as "disconnected" by the drm module. If you force it (via video=VGA-1:e in the kernel boot parameter), won't work, either.
    - xorg.conf hacking won't work, also.

    Any intel driver hacker could please help us???



    • #3
      Same issue -- Omni 5320br -- no resolution changing possible

      Same issue here. If not using 'nomodeset' during boot I do not have video.
      However it's not possible either to change monitor resolution to 1920x1080 -- neither via xorg.conf not xrandr --addmode ...

      I really regret that I bought this HP crap. How is it possible that no one can make this stupid intel driver work properly ?


      • #4
        I think I solved the problem

        Hi, guys.

        I think I found the solution.

        Please, test it.
        For me (I have an HP Omni 200-5320br All-in-one Series) it worked perfectly.
        I describe the solution with more detail at

        Below is a link to debian packages, using the latest kernel tree (3.3.0-rc2):

        Use it at your own risk