Announcement

Collapse
No announcement yet.

KDE4 + Intel 82845G onboard video (Dell 1100 inspiron laptop) = WEIRD GRAPHIC ISSUES?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • KDE4 + Intel 82845G onboard video (Dell 1100 inspiron laptop) = WEIRD GRAPHIC ISSUES?

    /me active reader of this site, first-time poster
    I'm really hoping someone can help me out with this - or just tell me I am fighting a loosing battle I am under the impression I am up against a KDE 4 issue? but I post here in the intel forum as this only seems to be happening specifically with the "Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device" onboard video for the dell inspiron 1100 laptop *which is truly ancient, but I really want to try to get it working, RIGHT with direct rendering/acceleration* I think the issue boils down to the intel xorg video driver, and KDE 4.x. I could be way off, hoping someone may have answers...

    I have multiple machines that run KDE 4.2.4 that comes with slackware 13.0 x86 DVD as my primary OS, but multiboot multiple other distros, and have tried several liveUSB/CD/DVDs bootdisks... I do know what things should look like when it works properly, and I even have another 2x intel onboard 82865G video chipset-based boxes that have KDE4 and direct rendering working fine with intel xorg 2.9.1 driver.

    back to my broken box... I can run the latest KDE 3.5.x just fine on this computer, but KDE 4.x all the way thru KDE 4.3.3 on slackware-current doesn't work - I've tried kunbuntu 9.10 (the latest), archlinux-testing, which has all new everything it seems, and numberous other distros with similar results = upon launching KDE 4 via "startx" the intro/splash screen is displayed with black and white bubbles, and a KDE 4 icon bar flashes up each icon until it gets to the KDE one, then upon a normal startup of KDE4 I would see the splash-screen transition to a desktop background... but on my fubar'd laptop the splash-screen disappears completely to a black-background, and KDE continues to boot up... my harddrive LED flashing, and a couple onscreen indicators that akonadi started, then suspended (for some unknown reason?), all the while the KDE startup music is playing... after all this completes, I am left with a black background. I always thought I was dead in the water here... just stuck, only my mouse arrow is shown, I can move it all around, but clicking on everything, typing on keyboard... nothing works -- OR SO I THOUGHT! I just found out that I can issue some keyboard shortcuts!

    I can run all other window managers perfectly - i.e. xfce, black box, window maker, fluxbox, they all run great, xfce's own composite manager works great... KDE4.x will not work!

    I started to mess around and found that pushing ALT+F1 brings up the start menu! in a really weird location?? but it is navigatable... I am noticing EVERY window I open gets opened all squished up in the top-left-hand corner (this is EXACTLY what I see for every window launched, except for the startmenu - they get stuck in the top-left hand corner of the screen, and I have to strech them out to view and work with any window or application I run)...

    no matter how many windows I bring up I cannot ALT+TAB them, it just doesnt let me. thankfully I can access the KDE4 SYSTEM SETTINGS from the the start menu shortcut ALT+F1. going to DISPLAY section I find something troubling ;


    the SCREEN AND ORIENTATION's VGA and LVDS sections are all grey'd out! I cant select anything, no resolution changes, nothing! I also literally have NO DESKTOP at all, it's just a black background with no ability to interact with it - if I right-click where the "desktop" is nothing happens. ALT+F1 brings up the "start menu" in an exteremly weird location!


    I find though that I can goto the screensavers and run GL screensavers in TEST mode just fine, GLmatrix works great =) desktop effects are OFF in KDE4 control panel.

    I cant for the life of me figure this out, I hope it is fixable! I've tried different combinations of xorg-server, libdrm, mesa, linux kernel versions on up thru each new release (to 2.8.32-rc8) with the zen kernel patches. I can also say that slackware 12.2, backtrack linux, slax 5 all worked on this laptop - which were based off the older xorg and intel drivers.

    does anyone have suggestions on how I can remedy this issue that only is occuring with KDE4?

    I've attached images to this message to help explain what I see on my screen...
    my Xorg.0.log => http://www.pastie.org/695204
    my glxinfo output => http://www.pastie.org/695198

    anything else one may need? I get the same problem with xorg.conf and without btw.
    ...thanks, sorry for the long post...
    agentdcooper
    Junior Member
    Last edited by agentdcooper; 26 November 2009, 03:58 AM.

  • #2
    KDE4 Intel 82845G onboard video Dell 1100 inspiron laptop WEIRD GRAPHIC ISSUES

    So whats the final word on that intel mobo, is it worth the 160 you end up paying with the retailedge program? Im in the same boat.. OP remember you get 64bit vista until windows7 comes out then you get a voucher

    Comment

    Working...
    X