Announcement

Collapse
No announcement yet.

Intel's IWD Linux Wireless Daemon Continues Picking Up New Features

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Intel's IWD Linux Wireless Daemon Continues Picking Up New Features

    Phoronix: Intel's IWD Linux Wireless Daemon Continues Picking Up New Features

    IWD, the Intel open-source wireless daemon for Linux systems that they are positioning to potentially replace WPA Supplicant in the future, is out this week with two new updates...

    http://www.phoronix.com/scan.php?pag...less-0.15-0.16

  • #2
    I've been using iwd since late 2018 on Arch Linux and haven't had any issues that I know about... it just works. At home, in coffee shops, airports, etc. It just works. Looking forward to IWD becoming the default soon.

    Comment


    • #3
      Originally posted by aorth View Post
      I've been using iwd since late 2018 on Arch Linux and haven't had any issues that I know about... it just works. At home, in coffee shops, airports, etc. It just works. Looking forward to IWD becoming the default soon.
      Interesting, have been trying to switch to IWD on arch a few times now but I always have the problem that it is not working with my NetworkManager for some reason. I can see networks but if I try to connect, it does not ask for a password. With wpa_supplicant, it works without a problem. No clue what is going wrong

      Comment


      • #4
        Originally posted by pininety View Post

        Interesting, have been trying to switch to IWD on arch a few times now but I always have the problem that it is not working with my NetworkManager for some reason. I can see networks but if I try to connect, it does not ask for a password. With wpa_supplicant, it works without a problem. No clue what is going wrong
        I'm pretty sure all I did was edit /etc/NetworkManager/NetworkManager.conf like so:

        Code:
        [device]
        match-device=type:wifi
        managed=1
        wifi.backend=iwd
        I found that systemd would sometimes rename my wireless device so I match the type instead of name. After that, just enable iwd.service, restart NetworkManager.service, and I think it should work.

        Comment


        • #5
          Originally posted by aorth View Post

          I'm pretty sure all I did was edit /etc/NetworkManager/NetworkManager.conf like so:

          Code:
          [device]
          match-device=type:wifi
          managed=1
          wifi.backend=iwd
          I found that systemd would sometimes rename my wireless device so I match the type instead of name. After that, just enable iwd.service, restart NetworkManager.service, and I think it should work.
          Thanks, this is good to know. I always tried the same, saw it not function and said "Ahh, try it next release then" but I think now there is just something wrong with the configuration of my system. Need to dig a bit deeper than, thanks a lot for the feedback!

          Comment


          • #6
            Be interesting if iwd + networkd becomes a replacement for NetworkManager + supplicant.

            Comment


            • #7
              Originally posted by aorth View Post
              I've been using iwd since late 2018 on Arch Linux and haven't had any issues that I know about... it just works. At home, in coffee shops, airports, etc. It just works. Looking forward to IWD becoming the default soon.
              Good to hear! How does it compare to the current implementation? I have no issues at all with the current implementation, so what does IWD do better?

              Comment


              • #8
                Originally posted by pininety View Post

                Thanks, this is good to know. I always tried the same, saw it not function and said "Ahh, try it next release then" but I think now there is just something wrong with the configuration of my system. Need to dig a bit deeper than, thanks a lot for the feedback!
                Check the Arch Wiki, might be useful even for a different distro.

                Comment


                • #9
                  I use iwd with systemd-networkd and it's not flawless, but gets the job done. The only reoccurring problem is that WiFi doesn't always connect automatically at boot. A quick restart of iwd followed by networkd usually fixes the problem.

                  I should also mention that I haven't tested any advanced configurations (vlan, VPN, bridging, adhoc, etc.) but I don't suspect there would be any issues since networkd takes care of those and has nothing to do with WiFi (except for adhoc).

                  Comment


                  • #10
                    Originally posted by aorth View Post
                    After that, just enable iwd.service, restart NetworkManager.service, and I think it should work.
                    Oh I guess I didn't do that.. oops

                    Comment

                    Working...
                    X