Announcement

Collapse
No announcement yet.

XBMC garbled fullscreen.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • XBMC garbled fullscreen.

    whenever i try and use XBMC in full screen on a radeon hd3100 gfx card it goes and gets full screen garbage.

    system spec:
    Brand: Toshiba
    Model: Satellite P305d-s8828
    Video card: radeon hd3100
    Ram: 3gb
    OS: Ubuntu 8.04
    Kernel: Linux 2.6.24-21-generic
    FGLRX Version: 8.10
    XBMC Version: 8.10b2svn16006-hardy1 ( via the ubuntu-tweak installer )

    it's also worth noting that blender has the same issue. ( via ubuntu repository )

  • #2
    I have the same problem - no answers, but here's another data point.

    I was running Ubuntu 8.04 on a 780G chipset (HD3200) with Catalyst 8.9 and everything was running fine. I upgraded to Catalyst 8.10 when ATI released it and found that it caused screen corruption whenever anything went fullscreen - XBMC, mplayer, etc. Luckily I was able to easily revert back to 8.9 and things went back to normal.

    Yesterday I upgraded to Ubuntu 8.10. Unfortunately that pulled in Catalyst 8.10, which still shows the fullscreen corruption. Worse, I can't downgrade to Catalyst 8.9 any more.

    If anybody has any ideas on how to fix this it would be great - my HTPC is now next to useless at the moment

    Cheers,

    Scott.

    Comment


    • #3
      I can say that the full screen garble only affects OpenGL programs right now... Xvideo and/or X11 video out works fine in mplayer so you know.

      as a quick note, i also upgraded to ubuntu 8.10 and it shows the same bugs.

      Comment


      • #4
        same issue

        I have the same issue.

        Do you have 32bit or 64bit versions of Ubuntu (or Linux)? I have 64bit version.

        I also had some problems with 8.9 when I have some special optimized settings in mplayer (mostly yuv-settings in opengl). This 8.10 version does not seem to work with any optimization (or no optimization).

        XV works fine, but it still has the tearing problem so it's not good either. I suppose I should not upgrade Ubuntu to 8.10 to make sure that I can use old fglrx 8.8.

        Comment


        • #5
          I use the 32 bit version of Ubuntu... also, try using the X11 video output and see if it works properly.

          Comment


          • #6
            Yes, X11 video output works fine also (but there is tearing and it's too slow for hd material).

            Comment


            • #7
              quick update, it seems to be related to a bug that was introduced with FGLRX 8.10... ubuntu forums has a thread about this.

              i checked the command...
              Code:
              dmesg | grep fglrx
              it outputted...
              Code:
              [   20.979334] [fglrx] Maximum main memory to use for locked dma buffers: 2643 MBytes.
              [   20.979417] [fglrx]   vendor: 1002 device: 9613 count: 1
              [   20.980227] [fglrx] ioport: bar 1, base 0x9000, size: 0x100
              [   20.981269] [fglrx] PAT is enabled successfully!
              [   20.981657] [fglrx] module loaded - fglrx 8.54.3 [Oct 10 2008] with 1 minors
              [   65.759902] [fglrx] GART Table is not in FRAME_BUFFER range 
              [   65.800581] [fglrx] Reserved FB block: Shared offset:0, size:1000000 
              [   65.800596] [fglrx] Reserved FB block: Unshared offset:fffb000, size:5000
              take note of the last 3 entries, this is key to figuring out this bug.

              Comment


              • #8
                garbled full screen

                Confirmed in Wine (32 bit) and Blender (64 bit) with X1250 card and Catalyst 8.10
                Not present same system/config with RadeonHD 4870

                Debian Lenny 64 bit 2.6.26 kernel

                Comment


                • #9
                  It could be an issue with the new Xorg too.
                  One thing that seems to work is to run the programs as root. Yes this is a security issue, but seems to point out that this is caused by a permission problem.

                  Problem exists on my system running ubuntu 8.10 64-bit w/ 4g of ram.

                  Comment


                  • #10
                    If you read more carefully what has been said in this thread you notice that this issue is also with Ubuntu 8.04 and older X.

                    Running mplayer using opengl as root actually crashed X (but points to Firefox that even restored text I had written to this message box).

                    Comment

                    Working...
                    X