Announcement

Collapse
No announcement yet.

ethereum mining on amd-1900X+4*AMD-VEGA-64 pro-17.30 No OpenCL platforms found

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • ethereum mining on amd-1900X+4*AMD-VEGA-64 pro-17.30 No OpenCL platforms found

    Hi my two new mining PCs just do not show any OpenCL devices

    one with a 1920X the other with a 1900X cpu
    both have 4(four) amd vega 64

    I installed the amdgpu-pro-17.30-465504 on the Kubuntu 16.04 LTS release

    error message:
    "[OPENCL]:No OpenCL platforms found
    No GPU device with sufficient memory was found. Can't GPU mine. Remove the -G argument"

    why the ROCm OpenCL in the PRO-17.30 driver just do not give the ethminer any OpenCL device ???
    Phantom circuit Sequence Reducer Dyslexia

  • #2
    Can you run clinfo and see what it says ?

    Also does the AMDGPU-PRO install look OK otherwise, eg by running glxinfo or a Vulkan program ?

    Thanks...

    (btw on my Kaveri box running the radeon all-open stack installing clinfo also dragged in a pile of NVidia code, not sure why yet)

    Comment


    • #3
      Originally posted by bridgman View Post
      Can you run clinfo and see what it says ?
      clinfo
      Number of platforms 0

      Originally posted by bridgman View Post
      Also does the AMDGPU-PRO install look OK otherwise, eg by running glxinfo or a Vulkan program ?
      Yes at first start only very low resolution after the installation of AMDGPU-pro 17.30 the desktop show up in high resolution.

      the glxinfo result is in this pastebin url: https://pastebin.com/Bv9cCxPa

      in my point of view it is a normal glxinfo output...

      but still no OpenCL device...

      i also have the problem that the ethminer is unable to build or confic on ubuntu 16.04+AMDGPU-pro17.30
      mkdir build; cd build cmake .. cmake --build . pastebin url of the error message: https://pastebin.com/iCNc2a6T

      i was able to do the same on my kubuntu 17.04+ all opensource stack


      also some words about amd's reputation and product politics:

      my first build with threadripper 1900X 8core with the MSI X399 gaming pro carbon ac....

      did you know that this mainboard can not run the 1900X cpu because it learns how to drive this cpu after bios update...

      so i endet up in buy a second 5000€ system with a 1920X to be able to perform a bios update on these 2 systems.

      did you know that this mainboard is not able to run a AMD-RX-Vega-64 gpu because it need a bios update to tun any VEGA
      so i needed an old nvidia gpu to perform the bios update to make it possible to tun a vega gpu...

      did you know that this mainboard also do not run many ram it needs bios update to run the RAM i endet up buying 3 different RAM DIMMS
      and only 1 works out of the box and this one makes it possible to run the bios update and after this all the other ram run well to.

      did you know that this system threadripper 1900X 8core with the MSI X399 gaming pro carbon ac is NOT able to run a 64bit windows 10 start DVD and i was even unable to install windows 10 on this system. but linux 16.04 and 17.10 are fine...

      did you know that i only need like 2 minutes to crash the (irony)so high quality(irony) amdgpu-pro driver starting the kde info center and and try to click on openGL graphical information ...

      Error message: kinfocenter PID:2112 signal: segmentation fault (11) date: 01.10.17

      kubuntu 17.10 updating to Linux kernel 4.14 rc3 result into permanent network failure.

      and still no installer to use the closed source openCL (rocm or not rocm whatever) with the open-source graphik driver stack.

      right now i really try hard to make this a success story but right now i do not know how to do this...
      Phantom circuit Sequence Reducer Dyslexia

      Comment


      • #4
        OK, at first glance the build error seems to be related to "hunter" being enabled by default although on a number of systems it appears to need to be disabled:

        https://github.com/ethereum-mining/ethminer/issues/219

        https://github.com/hunter-packages/d...ment-320237849

        Not sure about why you are seeing 0 platforms from clinfo though - will try to hunt down internal folks who have run ethminer tomorrow.

        EDIT - hold on, have you installed the Mesa header files on the system with PRO driver ? That seems to be a requirement in the instructions...

        OpenCL support on Linux

        If you're planning to use OpenCL on Linux you have to install OpenGL libraries. E.g. on Ubuntu run:

        sudo apt-get install mesa-common-dev
        https://github.com/ethereum-mining/ethminer

        The libraries were probably installed automatically on the system with open source graphics stack.
        Last edited by bridgman; 10-03-2017, 10:40 PM.

        Comment


        • #5
          Originally posted by bridgman View Post
          OK, at first glance the build error seems to be related to "hunter" being enabled by default although on a number of systems it appears to need to be disabled:

          https://github.com/ethereum-mining/ethminer/issues/219

          https://github.com/hunter-packages/d...ment-320237849

          Not sure about why you are seeing 0 platforms from clinfo though - will try to hunt down internal folks who have run ethminer tomorrow.

          EDIT - hold on, have you installed the Mesa header files on the system with PRO driver ? That seems to be a requirement in the instructions...

          https://github.com/ethereum-mining/ethminer

          The libraries were probably installed automatically on the system with open source graphics stack.
          ok I installed : "mesa-common-dev" now https://pastebin.com/N7BY6vkM but still clinfo shows this:

          clinfo
          Number of platforms 0

          Also disable hunter is no good idea because copy past from your link forum: chfast commented on Aug 3:

          ""You can disable Hunter with -DHUNTER_ENABLED=OFF. But CMake will not find dependencies because it does not know how.""

          i think it is just a installer bug from the amdgpu-pro driver because if i open muon packet manager and search for rocm then i find 4 packages
          but not a single one of this 4 rocm packages are installed. in my point of view if the installer works good the packages would be installed.
          Phantom circuit Sequence Reducer Dyslexia

          Comment


          • #6
            Originally posted by bridgman View Post
            Not sure about why you are seeing 0 platforms from clinfo though - will try to hunt down internal folks who have run ethminer tomorrow.
            I tried the pre-compiled version ethminer 0.12.0

            now i downloaded it here https://github.com/ethereum-mining/ethminer/releases and the result is:

            22:50:16|ethminer No OpenCL platforms found

            so it is not only the "clinfo" who report 0 platforms but also the ethminer also report 0 openCL platforms ...

            it should find 4-5 platforms because this system has 4 gpus amd rx vega 64 and 1 cpu...
            Phantom circuit Sequence Reducer Dyslexia

            Comment


            • #7
              OK, thanks. On the OpenCL side, I believe there is a separate parameter you need to use (maybe --compute) somewhere in the install process to get OpenCL included. Will try to find the details. It's supposed to be in the install instructions but not sure if it is actually there.

              Originally posted by Qaridarium View Post
              i think it is just a installer bug from the amdgpu-pro driver because if i open muon packet manager and search for rocm then i find 4 packages but not a single one of this 4 rocm packages are installed. in my point of view if the installer works good the packages would be installed.
              EDIT - just checking, did you install the "optional compute components" ?

              Installing the Optional ROCm Component
              This AMDGPU-Pro driver package incorporates the ROCm component that can be optionally installed for running Compute/OpenCL applications. You can install the component by issuing the following command:

              sudo apt install -y rocm-amdgpu-pro

              Configuring the Optional ROCm Component
              The LLVM_BIN environment variable needs to be set prior to running ROCm applications.

              To set it temporarily when running an individual ROCm command, such as clinfo, use:

              env LLVM_BIN=/opt/amdgpu-pro/bin /opt/amdgpu-pro/bin/clinfo

              To set it permanently for all bash and other sh-like shell users, you can use the following command:

              echo 'export LLVM_BIN=/opt/amdgpu-pro/bin' | sudo tee /etc/profile.d/amdgpu-pro.sh

              See the Ubuntu Environment Variables Community Help for more information.
              http://support.amd.com/en-us/kb-arti...O-Install.aspx
              Last edited by bridgman; 10-04-2017, 05:07 PM.

              Comment


              • #8
                Originally posted by Qaridarium View Post
                Also disable hunter is no good idea because copy past from your link forum: chfast commented on Aug 3:

                ""You can disable Hunter with -DHUNTER_ENABLED=OFF. But CMake will not find dependencies because it does not know how.""
                Agreed - if you install the headers then you don't need to disable hunter AFAICS.

                Comment


                • #9
                  Originally posted by bridgman View Post
                  OK, thanks. On the OpenCL side, I believe there is a separate parameter you need to use (maybe --compute) somewhere in the install process to get OpenCL included. Will try to find the details. It's supposed to be in the install instructions but not sure if it is actually there.
                  EDIT - just checking, did you install the "optional compute components" ?
                  http://support.amd.com/en-us/kb-arti...O-Install.aspx
                  ok thank you this works... now it works. but i think a little bit slow... on the internet the vega 64 do have numbers like 40mega hashes... ethminer shows numbers like 20 mega hashes for all 4 cards....

                  (edit) I thought the bad result is the result of overheating but now i only put in 2 cards instead of 4 in the pc and now i have 11,5Mh/s with 4 cards the cards are very overheating but still 19-20Mh/s
                  Last edited by Qaridarium; 10-04-2017, 08:15 PM.
                  Phantom circuit Sequence Reducer Dyslexia

                  Comment


                  • #10
                    OK, we're getting there. I'll find out what driver stack we are recommending for ethminer - IIRC we were seeing performance drops with latest workloads and made a couple of driver changes to address them. One was use of 2MB pages (which is not in 17.30 IIRC) and another was related to memory interleaving between HBM banks... each of them made a noticeable difference. The answer might be "use the ROCm stack in the short term" but will find out.

                    At your convenience can you post clinfo output just in case there is something else wrong with install ?

                    Comment

                    Working...
                    X