Announcement

Collapse
No announcement yet.

AMDGPU-PRO 17.30 Linux Driver doesnt install on Centos 7.4

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • AMDGPU-PRO 17.30 Linux Driver doesnt install on Centos 7.4




    Hello,
    amdgpu-pro (same driver as below) worked on Centos 7.3, but after update to Centos 7.4:
    What could i do ? I dont want to change to other distro right now, but it seems like i have to wait for updated driver for Centos 7.4.
    Any Ideas anybody?
    Which Linux distros are reported to work?




    [[email protected] amdgpu-pro-17.30-465504]# cat /etc/redhat-release
    CentOS Linux release 7.4.1708 (Core)

    Error because
    Requires: xserver-abi(videodrv-19) >= 0

    ...see below:

    HW: HP Z210, intel Xeon, AMD Radeon HD 7870, 16 GB RAM



    [[email protected] amdgpu-pro-17.30-465504]# ./amdgpu-pro-install
    Loaded plugins: fastestmirror
    Cleaning repos: amdgpu-pro-local
    2 metadata files removed
    2 sqlite files removed
    0 metadata files removed
    [amdgpu-pro-local]
    Name=AMD amdgpu Pro local repository
    baseurl=file:///var/opt/amdgpu-pro-local
    enabled=1
    gpgcheck=0


    Loaded plugins: fastestmirror
    amdgpu-pro-local | 2.9 kB 00:00:00
    base | 3.6 kB 00:00:00
    elrepo | 2.9 kB 00:00:00
    epel/x86_64/metalink | 15 kB 00:00:00
    epel | 4.3 kB 00:00:00
    extras | 3.4 kB 00:00:00
    rpmfusion-free-updates | 3.0 kB 00:00:00
    rpmfusion-nonfree-updates | 3.0 kB 00:00:00
    updates | 3.4 kB 00:00:00
    (1/3): amdgpu-pro-local/primary_db | 46 kB 00:00:00
    (2/3): epel/x86_64/updateinfo | 830 kB 00:00:02
    (3/3): epel/x86_64/primary_db | 4.8 MB 00:00:03
    Loading mirror speeds from cached hostfile
    * base: ftp.plusline.de
    * elrepo: muug.ca
    * epel: ftp.cica.es
    * extras: ftp.plusline.de
    * rpmfusion-free-updates: mirror.netsite.dk
    * rpmfusion-nonfree-updates: mirror.netsite.dk
    * updates: ftp.wrz.de
    Resolving Dependencies
    --> Running transaction check
    ---> Package amdgpu-pro.x86_64 0:17.30-465504.el7 will be installed
    --> Processing Dependency: libgl-amdgpu-pro-ext = 17.30-465504.el7 for package: amdgpu-pro-17.30-465504.el7.x86_64
    --> Processing Dependency: libgl-amdgpu-pro = 17.30-465504.el7 for package: amdgpu-pro-17.30-465504.el7.x86_64
    --> Processing Dependency: libopencl-amdgpu-pro-clinfo = 17.30-465504.el7 for package: amdgpu-pro-17.30-465504.el7.x86_64
    --> Processing Dependency: libvdpau-amdgpu-pro = 1.1.1-465504.el7 for package: amdgpu-pro-17.30-465504.el7.x86_64
    --> Processing Dependency: libopencl-amdgpu-pro-icd = 17.30-465504.el7 for package: amdgpu-pro-17.30-465504.el7.x86_64
    --> Processing Dependency: vulkan-amdgpu-pro = 17.30-465504.el7 for package: amdgpu-pro-17.30-465504.el7.x86_64
    --> Processing Dependency: libegl-amdgpu-pro = 17.30-465504.el7 for package: amdgpu-pro-17.30-465504.el7.x86_64
    --> Processing Dependency: libgl-amdgpu-pro-dri = 17.30-465504.el7 for package: amdgpu-pro-17.30-465504.el7.x86_64
    --> Processing Dependency: libgl-amdgpu-pro-appprofiles = 17.30-465504.el7 for package: amdgpu-pro-17.30-465504.el7.x86_64
    --> Processing Dependency: glamor-egl-amdgpu-pro = 1.19.0-465504.el7 for package: amdgpu-pro-17.30-465504.el7.x86_64
    --> Processing Dependency: xorg-x11-drv-amdgpu-pro = 1:1.3.99-465504.el7 for package: amdgpu-pro-17.30-465504.el7.x86_64
    --> Processing Dependency: mesa-amdgpu-pro-vdpau-drivers = 1:17.0.1-465504.el7 for package: amdgpu-pro-17.30-465504.el7.x86_64
    --> Processing Dependency: libgbm-amdgpu-pro-base = 17.30-465504.el7 for package: amdgpu-pro-17.30-465504.el7.x86_64
    --> Processing Dependency: libgbm-amdgpu-pro = 17.30-465504.el7 for package: amdgpu-pro-17.30-465504.el7.x86_64
    --> Processing Dependency: libgles-amdgpu-pro = 17.30-465504.el7 for package: amdgpu-pro-17.30-465504.el7.x86_64
    --> Processing Dependency: amdgpu-pro-dkms = 17.30-465504.el7 for package: amdgpu-pro-17.30-465504.el7.x86_64
    --> Processing Dependency: libdrm-amdgpu-pro = 1:2.4.70-465504.el7 for package: amdgpu-pro-17.30-465504.el7.x86_64
    --> Processing Dependency: libopencl-amdgpu-pro = 17.30-465504.el7 for package: amdgpu-pro-17.30-465504.el7.x86_64
    ---> Package amdgpu-pro-lib32.x86_64 0:17.30-465504.el7 will be installed
    --> Processing Dependency: libdrm-amdgpu-pro(x86-32) = 1:2.4.70-465504.el7 for package: amdgpu-pro-lib32-17.30-465504.el7.x86_64
    --> Processing Dependency: vulkan-amdgpu-pro(x86-32) = 17.30-465504.el7 for package: amdgpu-pro-lib32-17.30-465504.el7.x86_64
    --> Processing Dependency: libgl-amdgpu-pro-dri(x86-32) = 17.30-465504.el7 for package: amdgpu-pro-lib32-17.30-465504.el7.x86_64
    --> Processing Dependency: libopencl-amdgpu-pro-icd(x86-32) = 17.30-465504.el7 for package: amdgpu-pro-lib32-17.30-465504.el7.x86 _64
    --> Processing Dependency: mesa-amdgpu-pro-vdpau-drivers(x86-32) = 1:17.0.1-465504.el7 for package: amdgpu-pro-lib32-17.30-465504 .el7.x86_64
    --> Processing Dependency: libgbm-amdgpu-pro(x86-32) = 17.30-465504.el7 for package: amdgpu-pro-lib32-17.30-465504.el7.x86_64
    --> Processing Dependency: libopencl-amdgpu-pro(x86-32) = 17.30-465504.el7 for package: amdgpu-pro-lib32-17.30-465504.el7.x86_64
    --> Processing Dependency: libegl-amdgpu-pro(x86-32) = 17.30-465504.el7 for package: amdgpu-pro-lib32-17.30-465504.el7.x86_64
    --> Processing Dependency: libgles-amdgpu-pro(x86-32) = 17.30-465504.el7 for package: amdgpu-pro-lib32-17.30-465504.el7.x86_64
    --> Processing Dependency: libgl-amdgpu-pro(x86-32) = 17.30-465504.el7 for package: amdgpu-pro-lib32-17.30-465504.el7.x86_64
    --> Processing Dependency: libvdpau-amdgpu-pro(x86-32) = 1.1.1-465504.el7 for package: amdgpu-pro-lib32-17.30-465504.el7.x86_64
    --> Running transaction check
    ---> Package amdgpu-pro-dkms.noarch 0:17.30-465504.el7 will be installed
    --> Processing Dependency: amdgpu-pro-core for package: amdgpu-pro-dkms-17.30-465504.el7.noarch
    ---> Package glamor-egl-amdgpu-pro.x86_64 0:1.19.0-465504.el7 will be installed
    --> Processing Dependency: xserver-abi(videodrv-19) >= 0 for package: glamor-egl-amdgpu-pro-1.19.0-465504.el7.x86_64
    ---> Package libdrm-amdgpu-pro.i686 1:2.4.70-465504.el7 will be installed
    --> Processing Dependency: ids-amdgpu-pro for package: 1:libdrm-amdgpu-pro-2.4.70-465504.el7.i686
    ---> Package libdrm-amdgpu-pro.x86_64 1:2.4.70-465504.el7 will be installed
    ---> Package libegl-amdgpu-pro.i686 0:17.30-465504.el7 will be installed
    ---> Package libegl-amdgpu-pro.x86_64 0:17.30-465504.el7 will be installed
    ---> Package libgbm-amdgpu-pro.i686 0:17.30-465504.el7 will be installed
    ---> Package libgbm-amdgpu-pro.x86_64 0:17.30-465504.el7 will be installed
    ---> Package libgbm-amdgpu-pro-base.noarch 0:17.30-465504.el7 will be installed
    ---> Package libgl-amdgpu-pro.i686 0:17.30-465504.el7 will be installed
    ---> Package libgl-amdgpu-pro.x86_64 0:17.30-465504.el7 will be installed
    ---> Package libgl-amdgpu-pro-appprofiles.x86_64 0:17.30-465504.el7 will be installed
    ---> Package libgl-amdgpu-pro-dri.i686 0:17.30-465504.el7 will be installed
    ---> Package libgl-amdgpu-pro-dri.x86_64 0:17.30-465504.el7 will be installed
    ---> Package libgl-amdgpu-pro-ext.x86_64 0:17.30-465504.el7 will be installed
    ---> Package libgles-amdgpu-pro.i686 0:17.30-465504.el7 will be installed
    ---> Package libgles-amdgpu-pro.x86_64 0:17.30-465504.el7 will be installed
    ---> Package libopencl-amdgpu-pro.i686 0:17.30-465504.el7 will be installed
    ---> Package libopencl-amdgpu-pro.x86_64 0:17.30-465504.el7 will be installed
    ---> Package libopencl-amdgpu-pro-clinfo.x86_64 0:17.30-465504.el7 will be installed
    ---> Package libopencl-amdgpu-pro-icd.i686 0:17.30-465504.el7 will be installed
    ---> Package libopencl-amdgpu-pro-icd.x86_64 0:17.30-465504.el7 will be installed
    ---> Package libvdpau-amdgpu-pro.i686 0:1.1.1-465504.el7 will be installed
    ---> Package libvdpau-amdgpu-pro.x86_64 0:1.1.1-465504.el7 will be installed
    ---> Package mesa-amdgpu-pro-vdpau-drivers.i686 1:17.0.1-465504.el7 will be installed
    ---> Package mesa-amdgpu-pro-vdpau-drivers.x86_64 1:17.0.1-465504.el7 will be installed
    ---> Package vulkan-amdgpu-pro.i686 0:17.30-465504.el7 will be installed
    ---> Package vulkan-amdgpu-pro.x86_64 0:17.30-465504.el7 will be installed
    ---> Package xorg-x11-drv-amdgpu-pro.x86_64 1:1.3.99-465504.el7 will be installed
    --> Processing Dependency: xserver-abi(videodrv-19) >= 0 for package: 1:xorg-x11-drv-amdgpu-pro-1.3.99-465504.el7.x86_64
    --> Running transaction check
    ---> Package amdgpu-pro-core.noarch 0:17.30-465504.el7 will be installed
    ---> Package glamor-egl-amdgpu-pro.x86_64 0:1.19.0-465504.el7 will be installed
    --> Processing Dependency: xserver-abi(videodrv-19) >= 0 for package: glamor-egl-amdgpu-pro-1.19.0-465504.el7.x86_64
    ---> Package ids-amdgpu-pro.noarch 0:1.0.0-465504.el7 will be installed
    ---> Package xorg-x11-drv-amdgpu-pro.x86_64 1:1.3.99-465504.el7 will be installed
    --> Processing Dependency: xserver-abi(videodrv-19) >= 0 for package: 1:xorg-x11-drv-amdgpu-pro-1.3.99-465504.el7.x86_64
    --> Finished Dependency Resolution
    Error: Package: glamor-egl-amdgpu-pro-1.19.0-465504.el7.x86_64 (amdgpu-pro-local)
    Requires: xserver-abi(videodrv-19) >= 0
    Error: Package: 1:xorg-x11-drv-amdgpu-pro-1.3.99-465504.el7.x86_64 (amdgpu-pro-local)
    Requires: xserver-abi(videodrv-19) >= 0
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest
    [[email protected] amdgpu-pro-17.30-465504]#

  • #2
    When the driver requires xserver 1.19, easiest way is to change the distribution. The amdgpu-pro driver supports ubuntu that is based on Debian testing. So use Debian testing. You need to edit the installer script for Debian and do not install the amdgpu-pro dkms driver.

    Comment

    Working...
    X