Announcement

Collapse
No announcement yet.

Ryzen system with AMD RAID.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Ryzen system with AMD RAID.

    Hi. I see this topic is mostly for graphics card drivers but I want to check is any of you tried to install Linux on Ryzen system that uses AMD RAID?
    In my case I tried to install it on a system with 6 HDD drives configured as RAID 10 but following the instructions on in the driver archive led me to nowhere.

    I tried to bug AMD support for that but after a month of communication still have not found a way to install Linux on my system.

    I want to build dual-boot system with Windows where I will use my SSD as boot drive for both windows and linux and all other work files will be stored on the RAID array. Again it will be shared between windows and Linux.

    If any of you had any luck installing AMD RAID driver on ryzen please share your experience here. thanks.

  • #2
    Forget win virus hoover, wine-staging supports almost all dx9 games and dx11 support is under construction many dx11 already working. There are plenty of native Linux games in Steam too. Raid has nothing to do with cpu, it is a kernel feature with software raid implementation.
    https://raid.wiki.kernel.org/index.php/RAID_setup

    Comment


    • #3
      Thanks for the offer. I already know all about RAID. I don't intend to play games on this machine. It is for work and because of that I need Windows to. There is a driver released from AMD that is intended for use with AM4 and I suppose new Threadripper motherboards in order to run AMD RAID. In my case I already have Windows 10 setup with all proper drivers for the RAID. So in order to avoid switching every time I reboot the mode for SATA I want to make also Linux to work with that "fake" RAID. In my case it complaints that the license for the driver does not support my RAID configuration. It is a proprietary drivers so there is no way to see what exactly is supported but based on RAID documentation that is provided by AMD it should support RAID 0, 1 and 10. But for some reason Linux driver does not work with my RAID 10 configuration.

      So if any of you has any ideas how this could work I'm open to suggestions.

      thanks

      Comment


      • #4
        Google: amd linux raid
        You find:
        https://wiki.archlinux.org/index.php...with_Fake_RAID

        https://forum.manjaro.org/t/amd-ryze...id-issue/20465
        " So I turned the bios back to AHCI and not Raid mode. Manjaro can see the drives now"

        and see other About 615 000 results (0,41 seconds) . Message "it does not work in Linux" does not help much. When doing bug reports, describe the problem precisely and attach dmesg and other possible logs.

        Comment


        • #5
          Hi, I know if I turn in the BIOS my SATA to AHCI linux will see the drives. But in this case Windows will not boot. It will expect SATA to be in RAID mode.

          Regarding messages from the linux boot check this URL: http://downloads.dsoft-bg.com/IMAG1877.jpg

          As you can see the problem is that for some reason proprietary driver does not want to enable my RAID in it's current configuration.

          So I'm looking for somebody who succeeded with this driver and tell me in what configuration he managed to use it. As I said I'm using 6 HDD RAID 10.

          Regarding google I already looked at what is available there but looks like using AMD proprietary driver is not very popular topic there.
          If you want you can check driver at AMD support page: https://support.amd.com/en-us/downlo...s=Linux+x86_64

          Comment


          • #6
            " It is for work and because of that I need Windows too"

            Debian has over free 40 000 virus free software packages. You can find software for your work in Debian repositories.

            You have not tell what distro and kernel you are using. RTFM:
            http://www2.ati.com/relnotes/AMD_RAI..._User_v2.1.pdf
            "
            Red Hat Enterprise 4.8 • Red Hat Enterprise 5.4 • SuSE Linux ES 10 SP3 • SuSE Linux ES 11
            "

            By the way, there is the dmesg command and with xfce4-terminal you can copy-paste whole dmesg output or put it to file: dmesg > dmesg.txt

            Nothing in your dmesg photo show that "proprietary driver does not want to enable my RAID in it's current configuration". The driver probes adapters correctly.
            Last edited by debianxfce; 08-14-2017, 12:26 AM.

            Comment


            • #7
              Don't mind debianxfce, that user posts similar suggestions in other threads too... mixing actually useful information with unhelpful advice.

              For BIOS FakeRAID like the one you are using you do not need any proprietary or non-mainline drivers.
              In order to access such a RAID array, you need a kernel with RAID enabled (CONFIG_BLK_DEV_DM and CONFIG_DM_RAID) and dmraid userspace utility. It is all described in the Arch Linux wiki.
              Originally posted by https://wiki.archlinux.org/index.php/Installing_with_Fake_RAID#Load_dmraid
              Load device-mapper and find RAID sets:
              Code:
              # modprobe dm_mod
              # dmraid -ay
              # ls -la /dev/mapper/
              In order to boot from such an array, you need an initramfs which supports dmraid.

              Comment


              • #8
                Win virus hoover users solving Linux problems:

                Comment


                • #9
                  Hi chithanh,

                  In order to make your suggestion to work I need to put SATA interfaces in AHCI mode in BIOS. When it is in RAID mode Linux kernel can't see SATA interfaces. In this mode you need the proprietary driver from AMD. Or the other option is to switch SATA mode every time I reboot and need to switch the OS.

                  Regarding Linux distribution I try to install CentOS 7.3. Proprietary driver supports Ubuntu 16.04 and RHEL 7.3/CentOS 7.3.

                  Thank you for all your suggestions but I'm really interested to make this work the way I want it.

                  Comment


                  • #10
                    dmraid utility reads RAID metadata from disk. It is independent from AHCI or RAID mode in the BIOS.

                    Comment

                    Working...
                    X