Announcement

Collapse
No announcement yet.

xorg-driver-fglrx uses lib32 and can't upgrade libc6 - broken package problem

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • xorg-driver-fglrx uses lib32 and can't upgrade libc6 - broken package problem

    Hi,
    I have a broken package: libc6-i386.ds1-13etch5

    when I try to fix it with synaptic I get:

    Preparing to replace libc-i386 2.3.6.ds1-13etch5 (using.../libc6-i386_2.3.6.ds1-13etch7_amd64.deb) ...
    unpacking replacement libc6-i386 ...
    dpkg: error processing /var/cache/apt/archives/libc6-i386_2.3.6.ds1-13etch7_amd64.deb (--unpack):
    trying to overwrite `/usr/lib32', which is also in package xorg-driver-fglrx
    Errors were encountered while processing:
    /var/cache/apt/archives/libc6-i386_2.3.6.ds1-13etch7_amd64.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    A package failed to install. Trying to recover:

    I am not sure what does this mean. Can someone please interpret this for me and tell me also the solution? THanks. (It reminds me of nabuchod...)

    THis is the fgrlx version I have:

    $ fglrxinfo
    display: :0.0 screen: 0
    OpenGL vendor string: ATI Technologies Inc.
    OpenGL renderer string: ATI Radeon HD 3200 Graphics
    OpenGL version string: 2.1.7659 Release

    I am currently using debian etch on my 64-bit amd system
Working...
X