Announcement

Collapse
No announcement yet.

Ryzen problem in linux. Ubuntu kylin, ubuntu, ubuntu gnome.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Ryzen problem in linux. Ubuntu kylin, ubuntu, ubuntu gnome.

    https://community.amd.com/servlet/Ji..._13_33_Pro.jpg
    Hello people i have the following problem that you see in the image. There is no way you can use a new version of linux without being linux mint 18.1.
    At the same time in linux mint eh tried to use any kernel greater than 4.4.0-78 or skip to 4.10, 4.11 but without success.

    Amd ryzen 1700, gigabyte ax370 gaming 5.


  • #2
    I'd say you are definitely going to have to get a newer kernel running. And even if you manage to make a 4.4 series one work, it's not likely to work as well as a newer one.

    And it's not really a good idea to become an early adopter in hardware if you insist on running "stable" distros that stick with (somewhat) old kernels - 4.4 isn't even the latest LTS version of the kernel anymore. Otherwise you're going to encounter this type of issue a lot more often.

    What problem did you have trying to run a newer kernel on your Mint install? Your screenshot is for 4.4? Or is the screenshot the problem you have with a newer kernel?

    Comment


    • #3
      I've got a similar problem with a 1700 plugged into a gigabyte GA-AB350M. If you look at this post you will see similar "Unexpected IRQ trap at vector 07" messages:
      https://www.phoronix.com/forums/foru...ryzen-on-linux
      I'm typing this on the Ryzen right now, because I booted Ubuntu 17.04 off a USB with a couple kernel options--I believe "noapic" and "acpi=off".
      These disable a lot of hardware, but it's the first time I've gotten it running without a crash.
      If I boot Ubuntu 17.04 without the options, I hang at the splash screen, and if I hit ESC, I will see tons of those messages.
      I've also tried numerous other distros, including Linux Mint 18.1, but they are all unstable.
      I think I tried various "safe" modes but they didn't work.
      I do think you need at least a 4.10 kernel to get Ryzens working in general, based on articles on Phoronix and ServeTheHome.
      However, there appears to be an additional incompatibility that is particular to Gigabyte mobos.
      BTW--I tried updating BIOS, but no luck.
      The forum link describes how to build a modified kernel which disables a few features which trigger the bad behavior.
      I haven't gotten that far yet--I will probably proceed to install this on the SSD, then build me a new kernel so I can run without "noapic" and "acpi=off".

      I may just return the Gigabyte mobo and get one which is more stable on Linux, because the response from Gigabyte support (from the thread link above) was "it runs fine on Windows, so it's not our problem", so if I want to keep on running on Linux, we won't get any help from them.

      Good luck!

      Comment


      • #4
        Originally posted by bobtins View Post
        I've got a similar problem with a 1700 plugged into a gigabyte GA-AB350M. If you look at this post you will see similar "Unexpected IRQ trap at vector 07" messages:
        https://www.phoronix.com/forums/foru...ryzen-on-linux
        I'm typing this on the Ryzen right now, because I booted Ubuntu 17.04 off a USB with a couple kernel options--I believe "noapic" and "acpi=off".
        These disable a lot of hardware, but it's the first time I've gotten it running without a crash.
        If I boot Ubuntu 17.04 without the options, I hang at the splash screen, and if I hit ESC, I will see tons of those messages.
        I've also tried numerous other distros, including Linux Mint 18.1, but they are all unstable.
        I think I tried various "safe" modes but they didn't work.
        I do think you need at least a 4.10 kernel to get Ryzens working in general, based on articles on Phoronix and ServeTheHome.
        However, there appears to be an additional incompatibility that is particular to Gigabyte mobos.
        BTW--I tried updating BIOS, but no luck.
        The forum link describes how to build a modified kernel which disables a few features which trigger the bad behavior.
        I haven't gotten that far yet--I will probably proceed to install this on the SSD, then build me a new kernel so I can run without "noapic" and "acpi=off".

        I may just return the Gigabyte mobo and get one which is more stable on Linux, because the response from Gigabyte support (from the thread link above) was "it runs fine on Windows, so it's not our problem", so if I want to keep on running on Linux, we won't get any help from them.

        Good luck!
        My experiences with Gigabyte as a manufacturer is that they are Linux hostile on every level. I have learned my lesson and am staying away from them completely. A good tip is to buy Asus or MSI, they have usually great linux support.

        Comment


        • #5
          I don't use Debian on Ryzen but my Gentoo system was freezing when idle until I enabled CONFIG_RCU_NOCB_CPU and CONFIG_RCU_NOCB_CPU_ALL in the kernel. Fedora doesn't enable this by default but Debian doesn't. I have yet to try an actual Debian kernel but bear this in mind, even when trying a very recent kernel.

          Comment


          • #6
            Originally posted by Chewi View Post
            I don't use Debian on Ryzen but my Gentoo system was freezing when idle until I enabled CONFIG_RCU_NOCB_CPU and CONFIG_RCU_NOCB_CPU_ALL in the kernel. Fedora doesn't enable this by default but Debian doesn't. I have yet to try an actual Debian kernel but bear this in mind, even when trying a very recent kernel.
            Debug and 250Hz timer kernels are slow. It is better to use a custom non debug 1000Hz timer kernel in Debian too.

            Comment

            Working...
            X