Announcement

Collapse
No announcement yet.

Fullscreen 3D fglrx problem

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Fullscreen 3D fglrx problem

    I have a problem with my ATI X200M and fglrx (from 8.6 to 8.9), running applications in fullscreen mode. The image is absolutely without sync.
    I have tested without compiz (metacity --replace&, disabling desktop efects, etc.), testing a lot of [device] xorg options..., and it remains the same...

    It seems like it doesnt get the correct modeline, but I dont find any log eroor.


    Application affected are:
    - stellarium. It work fine if running windowed.
    - f-spot in "presentation mode".
    - sinatra. It work fine if running windowed.
    - mupen64plus with rice video plugin. glide64 plugin work fine.
    - All wine 3D games... (even in other resolutions).


    I have seen some post related, but with no solution for me...
    http://ubuntuforums.org/showthread.p...creen+modeline

    This is mine:
    http://ubuntuforums.org/showthread.php?t=874743


    My xorg.conf:
    Section "Monitor"
    Identifier "aticonfig-Monitor[0]-0"
    Option "VendorName" "ATI Proprietary Driver"
    Option "ModelName" "Generic Autodetecting Monitor"
    Option "DPMS" "true"
    EndSection

    Section "Device"
    Identifier "aticonfig-Device[0]-0"
    Driver "fglrx"
    Option "VideoOverlay" "on"
    Option "OpenGLOverlay" "off"
    # Option "Capabilities" "0x00000800"
    Option "TexturedVideo" "off"
    Option "TexturedVideoSync" "off"
    Option "UseFastTLS" "1"
    # Option "Backing Store" "on"
    # Option "XAANoOffscreenPixmaps" "off"
    BusID "PCI:1:5:0"
    EndSection

    Section "Screen"
    Identifier "aticonfig-Screen[0]-0"
    Device "aticonfig-Device[0]-0"
    Monitor "aticonfig-Monitor[0]-0"
    DefaultDepth 24
    SubSection "Display"
    Depth 1
    Modes "1440x900"
    EndSubSection
    SubSection "Display"
    Depth 4
    Modes "1440x900"
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "1440x900"
    EndSubSection
    SubSection "Display"
    Depth 15
    Modes "1440x900"
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "1440x900"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1440x900"
    EndSubSection
    EndSection

    Section "DRI"
    Mode 0666
    EndSection

    Section "Extensions"
    Option "Composite" "1"
    Option "RENDER" "Enable"
    Option "DAMAGE" "Enable"
    EndSection




    Please please help me if I have somethig missconfigured...

  • #2
    I've tried a lot of aticonfig and xorg options and seems that I am the only one that has this problem?
    Please anybady can help me or give an indication?...
    Thanks

    Comment


    • #3
      fglrx does not honour xorg.conf modelines if /etc/ati/amdpcsdb is present. It recreates this file any time X exits.

      Try:
      log out of X
      switch to VT
      log in as root
      shut down X
      /etc/init.d/gdm stop
      or
      /etc/init.d/kdm stop

      rm /etc/ati/amdpcsdb
      reboot

      Comment


      • #4
        Originally posted by spikethehobbitmage View Post
        fglrx does not honour xorg.conf modelines if /etc/ati/amdpcsdb is present. It recreates this file any time X exits.

        Try:
        log out of X
        switch to VT
        log in as root
        shut down X
        /etc/init.d/gdm stop
        or
        /etc/init.d/kdm stop

        rm /etc/ati/amdpcsdb
        reboot

        Thanks a lot. I will try it this night... and report if success or not...

        Comment


        • #5
          NEVER enable render - that emulates composite!

          #Option "RENDER" "Enable"
          ^

          Comment


          • #6
            Originally posted by segalion View Post
            Thanks a lot. I will try it this night... and report if success or not...
            It doesnt work.

            But I have discover that running with sudo (root) or with
            #export LIBGL_ALWAYS_INDIRECT=true
            before running fullscreen applications make it work fine, but maybe a little slow.

            Comment


            • #7
              Originally posted by Kano View Post
              NEVER enable render - that emulates composite!

              #Option "RENDER" "Enable"
              ^
              I dont know what this make. It is recomended for compiz. Moreover I remember to try without this with no good result.

              Comment


              • #8
                Someone has reported that 8.11 ati driver correct this bug...

                http://ubuntuforums.org/showthread.p...35#post6161335

                I will try in some days...

                Comment

                Working...
                X