Announcement

Collapse
No announcement yet.

My results testing AMD Ryzen 1800 with ASUS PRIME B350-PLUS

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • My results testing AMD Ryzen 1800 with ASUS PRIME B350-PLUS

    I ordered 64gb of DDR4 ram in 16gb x 4 format and a Samsung M.2 SSD 500gb to go with the B350Plus motherboard. I tried various Linux distributions with the following results:

    General issues:
    - Using a Nvidia 770 with mini-HDMI port to HDMI I would get nothing on the display or brief text, when I switched to DVI to HDMI cable the video worked for the BIOS and various Linux distributions.
    - Using 64gb in the form of 4 x 16gb DDR4 modules and the BIOS (latest version) only recognizes 32gb, OpenSuSE hangs at loading ram image. When I remove 32gb (leaving just 2 sticks to total 32gb) it boots and installs just fine.
    - Samsung M.2 SSD 500gb appears to use AHCI driver no matter what BIOS settings I choose. Limited options in the bios for choosing NvME

    Ubuntu Zesty - hangs with ACPI errors after the DVD installer loads and you choose install. With option: noapic it would then hang at the opensource nvidia module. With adding another option: nomodeset it would then hang after displaying SATA port info in the dmesg output

    OpenSUSE Tumbleweed - works with no extra options after reducing memory to 32gb

  • #2
    With rolling release operation system and latest custom kernel you have better luck to make new hardware to work. For the nvida gpu, use the driver from nvidia site.

    Comment


    • #3
      Asus tech support was underwhelming to say the least. I talked to them on the 2 issues I had: max memory 32gb and M.2 Samsung 500gb SSD only recognized as AHCI device

      We did discover that I could add 3 sticks of 16gb memory to hit a max of 48gb of ram, but adding the 4th made the bios only state 32gb of ram available. They mumbled something about maybe a problem with a stick and that was it.

      On the M.2 Nvme support they said: We don't support Linux, bye. Typical... anyway it is found as an AHCI device (no nvme device in /dev). I got 250MB/sec reads, and 6.7MB/sec writes to it, very poor.

      Hopefully their BIOS gets better down the road...

      Comment


      • #4
        As for the BIOS, I've had very good experience with Asrock's customer support, who even develop custom BIOS versions to support a feature you need. Could be a tip for in the future. They even developed a BIOS with NVMe support for my 5+ year old motherboard. I needed that to do some Samsung 960 pro testing.

        Why would you also go for the lower chipset type 350 when you have the top CPU? You'd surely get more features out the 370 chipset

        Comment


        • #5
          I went for the 350 since that was all that was available when I ordered, all the 370's were sold out. I could fix that now as more 370's are in stock, but interested for now to see if these issues get fixed on the 350.

          Comment


          • #6
            Originally posted by mlinuxguy View Post
            On the M.2 Nvme support they said: We don't support Linux, bye.
            I don't see the problem. Sounds like you bought unsupported hardware. Plenty of SSD vendors do officially support Linux, and provide Linux software for diagnostics and firmware updates. Intel SSD's are especially good with the Linux support. If you have the expectation of vendor support, you have to play by their rules. Personally, I buy only hardware that has official Linux support from the vendor - it's not worth my time and frustration to go the hobbyist route. Maybe it's worth it to you, and hey that's great, but it seems a bit lame to complain about it after the fact.

            Comment

            Working...
            X