Announcement

Collapse
No announcement yet.

AMD Ryzen on Linux

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • AMD Ryzen on Linux

    Howdy everyone! I apologize for not posting here earlier but - well, embargoes and all.

    I'm working right now on trying to get the AMD Ryzen 7 1800X to boot on Ubuntu.
    Over the past 12 hours I've tried 3 desktop distros (16.04, 16.10, 17.04) and server (17.04) all to no avail.

    All give similar errors regardless of platform.

    1) Spamming "unexpected irq trap at vector 07" in the log.
    2) Journal starting stalls out, times out at 3 mins and tries again. Never get past it.

    If I set acpi=off then I can bypass in desktop but then get monitor "Out of Range" error.
    Server went as far as letting me install to the NVMe drive and then segmentation fault and loop that prevented continuing.

    I know a lot of people here, including Michael, will be testing this so I'll add any notes here that I get as try to get this working.
    H/W was ruled out by doing a quick Win 10 install. Worked like a charm.

    If anyone has ideas/suggestions on how to get past these errors and get going it would be greatly appreciated.
    Thanks!

  • #2
    Did you try updating the BIOS on your board and/or resetting it? I've encountered similar issues in the past with new hardware and were resolved with BIOS/UEFI updates.
    Michael Larabel
    http://www.michaellarabel.com/

    Comment


    • #3
      Michael,

      Yep, tried both. Was shipped with current BIOS - tried defaults, optimized defaults and a whole lot of testing various combinations. Nothing seems to make a change on the BIOS side. 17.04 server finally installed and after acpi=off nomodeset I'm at a prompt. Going to try and install desktop through here and see if that gets me going.

      Also going to be posting relevant information to other readers in the review thread. The issues I'm having here qualify and if no info on a mobo yet I'll try to find if someone can test and report back.

      Comment


      • #4
        Update: acpi=off is a must. Out of Range error is resolved by switching from HDMI to DVI, which produced a desktop.
        So no need to do the very complicated way I did. 17.04 desktop install should work from there. I'll verify shortly via reinstall.

        Comment


        • #5
          What hardware are you actually using? (motherboard, graphics card, etc..)

          Comment


          • #6
            I am experiencing the same problem. I have a Ryzen 1700, Gigabyte GA-AX370 Gaming 5 motherboard, NVIDIA GTX 670 graphics card, and an Asus Xonar DX sound card.

            I suspect it's to do with the integrated Realtek 1220 audio chip on the motherboard, which is only supported in the 4.11 kernel, but for the life of me I can't find anything in the motherboard's BIOS to disable it. I know that Michael used the same Gigabyte motherboard for his benchmarks so I find it strange that I get these errors.

            If anyone has any ideas on how to solve these problems that would be very appreciated!

            Comment


            • #7
              Originally posted by brmather View Post
              I am experiencing the same problem. I have a Ryzen 1700, Gigabyte GA-AX370 Gaming 5 motherboard, NVIDIA GTX 670 graphics card, and an Asus Xonar DX sound card.

              I suspect it's to do with the integrated Realtek 1220 audio chip on the motherboard, which is only supported in the 4.11 kernel, but for the life of me I can't find anything in the motherboard's BIOS to disable it. I know that Michael used the same Gigabyte motherboard for his benchmarks so I find it strange that I get these errors.

              If anyone has any ideas on how to solve these problems that would be very appreciated!
              In 25 years when I have build pcs, I have not seen Bios that here is not possible to disable motherboard features. When using Linux kernel you can disable pci devices and blacklist drivers, find more information from the Internet.

              Comment


              • #8
                The BIOS is infuriatingly sparse of options.

                I can boot into Ubuntu with acpi=off in the grub bootloader. Will post a fix if/when I find one.

                Comment


                • #9
                  Acpi=off seem to work... but Linux sees only 1 core (that's what /proc/cpuinfo says, no idea why). I'll try 4.11rc1, maybe that will work.

                  Comment


                  • #10
                    Upgrading bios to f4 didn't help. 4.11rc1 didn't help either.

                    Comment

                    Working...
                    X