No announcement yet.

Very strange issue with the latest Mesa OpenGL drivers from Oibaf (picture included)

  • Filter
  • Time
  • Show
Clear All
new posts

  • Very strange issue with the latest Mesa OpenGL drivers from Oibaf (picture included)

    Important up front:
    Kernel: 4.8.0-34-generic x86_64 (64 bit) Desktop: Cinnamon 3.2.7
    This is a strange one and I've exhausted ever OpenGL forum and Wiki I can find. I've used testing tools and gone as far as thinking about recompiling and changing flags, but I'm still new to this "advanced" driver support. Up front I'm using Mint 18.1 (x64), but this problem is presumably independent of OS and centers on either how GTK is being rendered or how OpenGL is now rendering certain textures/raster/icon images in the OS. I've searched just about everyone for a few hours now and have come up empty.

    So, back to the bug. It's best to just show it with a screenshot:

    Imgur Screenshot

    I opened up a few different windows to show the issue in multiple areas, but how other areas are completely unaffected. This only started after the switch to Oibaf PPA drivers. I have used this card and stock radeon drivers in several distros, including long-term use in both Xubuntu and Mint and have never seen anything like this. I tried refreshing the cache and the basics like that, but this isn't a critical issue causing any performance degredation, so I haven't done anything drastic in fear of getting out of my depth and really borking something. I think I got lucky to get these drivers on my SI card to begin with, so don't want to push it. Just want to figure this out and am totally stumped. The next thing I am going to try is to install something like CompizManager and go into advanced settings and try to force it to take over image rendering in the UI, but since Compiz is just Open Gl, I don't know if it'll help.

    Here is an inxi -G for more specifics about what I'm using:

    Graphics: Card: Advanced Micro Devices [AMD/ATI] Cape Verde PRO [Radeon HD 7750/8740 / R7 250E] bus-ID: 01:00.0 Display Server: X.Org 1.18.4 drivers: ati,radeon (unloaded: fbdev,vesa) Resolution: [email protected] GLX Renderer: Gallium 0.4 on AMD CAPE VERDE (DRM 2.46.0 / 4.8.0-34-generic, LLVM 3.9.1) GLX Version: 3.0 Mesa 17.0.0-devel Direct Rendering: Yes

  • #2


    • #3
      Use a rolling release distribution that gives you newer software than mint. Debian testing Xfce has Mesa that fixes your problem and you will have updates more often than when using mint. We did have pink icons with A8-7600, amdgpu kernel driver and Oipaf ppa. Our people did try install win10 and did destroy the partition table so a fresh Debian testing Xfce install solved the problem. We used the radeon kernel driver and now amdgpu driver again.
      You can try the ppa-purge command to remove Oipaf ppa,
      Last edited by debianxfce; 01-19-2017, 04:15 AM.