Announcement

Collapse
No announcement yet.

How am I supposed to use AMDGPU-PRO with an RX 480 on Ubuntu?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Alright, here's how I got it to work:
    Booting from a live USB to try does not work, but choosing the install option from the GRUB menu worked.
    After installing 16.04, the computer did not boot correctly. However, by going into grub and booting into recovery mode and then booting normally, I got into a low graphics mode state.
    From there, I installed AMDGPU-PRO and rebooted and the system now boots normally.

    However, as of right now Vulkan is nonfunctional; I am a member of the video group and I installed the LunarG SDK as instructed on the website. I tried to run Dolphin with Vulkan but got "failed to load Vulkan library" and upon trying vulkaninfo in terminal I was notified that it was not installed. So I did sudo apt-get install vulkan-utils, and now vulkaninfo reports accurately, but Dolphin fails to create a Vulkan instance. I'm downloading the Talos Principle right now to see if it also does not work.
    edit: Talos Principle works fine on Vulkan.
    Last edited by Xicronic; 12-12-2016, 01:43 AM.

    Comment


    • #12
      If you have Dota and Talos working with VK that is it, you have good cards in hands... But Dolphin VK only recently goes out of alpha and now it is on beta... hm, if those emulators ever goes out of beta

      https://github.com/dolphin-emu/dolphin/pull/3935
      https://github.com/dolphin-emu/dolphin/pull/4484
      Last edited by dungeon; 12-12-2016, 02:01 AM.

      Comment

      Working...
      X