Announcement

Collapse
No announcement yet.

RX 470 / AMDGPU-Pro on Debian 9 (testing), and underclocking

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • RX 470 / AMDGPU-Pro on Debian 9 (testing), and underclocking

    Hi everyone,

    I had two questions: 1. have you been able to manage to install 16.40 on Debian testing? I had to patch the kernel a bit (some defines that were causing errors) to get a working module, replaced several binaries (amdgpu dri, libdrm, libglx, libGL) and it almost seemed to work but it fails at X_GLXMakeContextCurrent. Out of ideas, I installed Ubuntu 16.04 (which works well) but it's not a satisfying solution.

    2. Have you guys been able to underclock+undervolt on Linux? On Windows I can go as low as 0.82v @ 1050 MHz, which provides a 40% power decrease (at the wall) with slightly higher FPS when running FurMark. This may seem surprising but I notice the default voltages are way too high so the card throttles like crazy. Same goes for LuxMark which consumes almost 50% less power, for just a 5% lower score.

  • #2
    Why you want to use amdgpu pro? It is old. Latest code is here and make a custom kernel:
    Without DAL:
    https://cgit.freedesktop.org/~agd5f/...-next-4.10-wip
    With DAL:
    https://cgit.freedesktop.org/~agd5f/...md-staging-4.7
    Latest Mesa:
    https://launchpad.net/~oibaf/+archiv...vers/+packages

    However, you can use amdgpu-pro xorg components with the amdgpu kernel driver, so you do not need to patch or compile the dkms driver.

    Comment


    • #3
      Originally posted by debianxfce View Post
      Why you want to use amdgpu pro? It is old. Latest code is here and make a custom kernel:
      Without DAL:
      https://cgit.freedesktop.org/~agd5f/...-next-4.10-wip
      With DAL:
      https://cgit.freedesktop.org/~agd5f/...md-staging-4.7
      Latest Mesa:
      https://launchpad.net/~oibaf/+archiv...vers/+packages

      However, you can use amdgpu-pro xorg components with the amdgpu kernel driver, so you do not need to patch or compile the dkms driver.
      I need OpenCL, that is why...

      Comment


      • #4
        For the record, I figured it out: https://www.phoronix.com/forums/foru...pu-pro-success

        Comment

        Working...
        X