No announcement yet.

Black screen with 4870, Ubuntu Hardy 64 bits

  • Filter
  • Time
  • Show
Clear All
new posts

  • Black screen with 4870, Ubuntu Hardy 64 bits

    I received a Sapphire 4870 today, but I can't get it to work, following the procedure as in:

    Graphics card: Sapphire 4870.
    Monitor: Acer X243W (VGA) connected with dvi-vga cable. 1920x1200 60Hz native.
    Linux version: Ubuntu Hardy 64 bits, fresh installation.
    Drivers: Catalyst 8.8
    BulletProofX deactivated.

    All I see is a black screen after the final rebooting, when GDM login box should be visible.

    Things I've tried:
    Disabling memory remap (my computer has 6 GB of Ram), no difference.
    Adding a modeline to Monitor section in xorg.conf, no difference.
    Last edited by marakaid; 08-22-2008, 02:14 PM.

  • #2
    Can you pls pastebin your xorg log ?


    • #3

      It says something as "device not detected"
      Last edited by marakaid; 08-22-2008, 03:44 PM.


      • #4
        Is there any chance that is not the full log ? It seems to stop right at the good part -- as the drm module is being initialized... that would either imply the system is hanging hard (didn't sound like it from your description) or the log was not fully written to disk when you copied it.

        We have seen problems with some mobos and 4GB or more of RAM - does your memory setup make it easy to go below 4GB ? If not, maybe try the "mem=" boot option to limit memory to maybe 3000K for troubleshooting.


        • #5
          I have found that those procedures have been unnecessary and haven't worked for me, with recent fglrx releases.

          Try a simple: ./


          • #6
            I have started the system without the options "splash silent" to read the entire booting process.
            DKMS autobuild fails with error 7, this is with kernel that I used for multimedia editing and gaming with ETQW.
            If system boots up with generic kernel, the Dkms autobuild works correctly, 2d and 3d is nice, but the game is a bit less responsive than with rt.


            • #7
              Ahh yes, when you try to build the module on the -rt kernel, it tries to access parts of the kernel that are deemed accessible by GPL code only, and since the code isn't licensed under the GPL, it fails. Details to get around it are here: