No announcement yet.

[HD 3870] Distorted picture in wine, vsync problems

  • Filter
  • Time
  • Show
Clear All
new posts

  • [HD 3870] Distorted picture in wine, vsync problems

    Hi all,

    recently upgraded my computer and decided to give ATI/AMD another chance, since they are cheap and perform well. I knew that there'd be some trouble, but hadn't quite expected this.

    So, I'm running openSUSE 11.0, x86_64, with the latest fglrx-drivers.
    Now, my first problems is, when I'm starting a game with wine (tried a few versions, including the latest), the screen is totally distorted. And I mean totally. Not sure if this can be captured on a screenshot, I'll try later.

    Also, vsync is not working correctly, and I'm not even talking about Xv. I have a LCD monitor, so it should limit to 60fps. I've checked it in a few apps, and while glx_gears is capped at 60fps, fgl_glxgears as well as Quake3 and Chromium B.S.U run at 50fps, which is just choppy and ugly.

    I'll be including the Xorg log as well as the config file, hope that anyone can pinpoint me to something.

    Xorg log
    (linked because too long)

  • #2
    Might i suggest if you don't need it commenting out the RadeonHD device and its corresponding screen sections. See if that helps, RadeonHD is known to fight with FGLRX if the some how manage to load together.


    • #3
      I believe I already tried this, but just to be sure I checked again, no changes.
      I have also tried to capture the screen distortion, but on a screenshot it turned up almost fine, though only the games launchmenu could be seen, the rest was black. And I don't have a camera. Although it probably doesn't matter.
      Should've stayed with Nvidia, though they have massive 2D problems on their own on newer cards, I hear. Still ...

      Edit: Installed 8.8 now, and while at least vsync in gaming seems to work, nothing else changed. Well, probably should be happy it didn't break anything ...

      Edit#2: Just read about a workaround in the 8.8 thread, adding Virtual 1921 1200 to the display subsection in xorg.conf seems to fix the corruption ... although the in-game graphics are totally screwed. Gotta love it.
      On a side note, even though I can see just about nothing in the game, performance is on par with my old Geforce 6800. Really nice work, AMD. I'm actually laughing right now.
      Last edited by thora; 08-20-2008, 09:54 PM.