Announcement

Collapse
No announcement yet.

Cannot buildpkg on Fedora/F7 x86_64

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cannot buildpkg on Fedora/F7 x86_64

    I know lots of others have posted a similar problem, but I'm not sure what the actual solution is...any ideas here?

    [[email protected] ati]$ ./ati-driver-installer-8-7-x86.x86_64.run --buildpkg Fedora/F7
    Created directory fglrx-install.W22308
    Verifying archive integrity... All good.
    Uncompressing ATI Proprietary Linux Driver-8.512............................................. ...
    ==================================================
    ATI Technologies Linux Driver Installer/Packager
    ==================================================
    Generating package: Fedora/F7
    mv: cannot stat `/tmp/ATI-fglrx-8.512-1-22387-mikeuw/BUILD/ATI-fglrx-8.512/usr/X11R6/lib/modules/dri/*': No such file or directory
    mv: cannot stat `/tmp/ATI-fglrx-8.512-1-22387-mikeuw/BUILD/ATI-fglrx-8.512/usr/X11R6/lib/*.so.*': No such file or directory
    Package build failed!
    Package build utility output:
    error: %changelog entries must start with *
    Building target platforms: x86_64
    Building for target x86_64
    Removing temporary directory: fglrx-install.W22308

  • #2
    Ok...working through some previous attempts that I have made at this by using the --extract option, and messing around with the fedora packager's files, I found the source of one problem: in packages/Fedora/ATI-fglrx.spec-tmpl, there is a changelog entry without a line that starts with * preceding it - so I commented that out.

    The rest seems to be a lack of presence of the 32-bit drivers, which are also used for the 64-bit packages. Any clues as to why these would be missing?

    Comment


    • #3
      MikeUW: Did you actually get a set of packages built?

      The ATI installer is doing the same thing for fedora 8 and 9, so I'm extremely interested in your results.

      Comment


      • #4
        Unfortunately, no...I've had this problem ever since F7 hit EOL, and I no longer could use the livna repository for updates. I'd stick with the ones on Livna, but they never quite worked right with my hardware.

        I'm hoping somebody that actually knows what the packager scripts are supposed to be doing might have an idea...

        Comment


        • #5
          Mike Larabel said that if we filed a bug report and put the messages concerning this on this forum (AMD/ATI Linux), then it would possibly get some attention. I've already filed a bug report at the unofficial ati bugzilla. And I also created another thread bringing attention to the fact that f8 and 9 are having the same difficulties.

          BTW, if you are using F7 and you have the latest updates downloaded, it's now possible to create an installation respin using the latest updates as a source for creating the respin. The tool is from the fedoraunity project.

          Basically you can create a new install dvd that uses all the latest packages as the source for creating the iso. If we can get the ATI devs to fix the package generation routine, it then becomes possible, using revisor, to create a respin DVD with updates that includes the latest ATI rpms as an installation option, along with the latest F7 kernel. That's one of the things I'm doing with F8.

          Basically you're using the latest bugfixed software at installation time. Including the latest version of anaconda, incidentally.

          Revisor is new, but it's now working. I can give you some more info if you're interested in getting it and trying it out.

          Comment


          • #6
            Thanks Xaphir - do you have links to these reports that you created?

            As for re-spinning F7 - the idea sounds good, and I might look into it...though, I'm not sure it'll be worth my time/effort - the distro is EOL, and within a few months will already be three versions behind the rest. I'm not sure what the benefit of repackaging a permanently out-of-date OS will be...particularly since I don't have any plans at the moment to install F7 anywhere else. If I do install anything, I'd be upgrading to whatever the latest is at that time (probably F10, when it comes out) - that's when this revisor tool might be more handy.

            Comment


            • #7
              For all my trouble, it turns out that this is all because when I used the graphical installer, I kept choosing the distribution specific package option...if I just use the install option, it works fine. I just ran the package with the --install option, let the GUI do everything automatically and it worked. I think I ignored this, because the default installer mentions distribution specific packages, which made me think that I had to pick my specific distribution...but I now realize that this was only for building rpms, not actually installing the driver.

              Now...if only beryl worked on F7. Guess that's what I get for not upgrading.

              Comment

              Working...
              X