Announcement

Collapse
No announcement yet.

Catalyst 15.5 patches needed for kernel 4.x

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Catalyst 15.5 patches needed for kernel 4.x

    Rats! After such a long wait, I was really hoping for something that would help me with the kernel version problem. But, I didn't even get passed the release notes before I had my first problem with Catalyst 15.5. According to the release notes, 15.5 doesn't support any kernel newer than 3.17, which is the same recent version that 15.4 supported, BTW.

    Perhaps this isn't such a problem for distros that don't update kernel pkgs so often, but for Fedora (and others) that keep pace, it's a disaster. But, I actually cannot upgrade to the current supported Fedora (version 22) because there are no kernel packages in Fedora 22 repositories as old as 3.17.

    SO...I figured I'd start a thread here about patches required to fix the new Catalyst 15.5 src for kernel 4.x. I'll try, myself, next week and report back here what I find. But, if someone does it before me, please post your patch references here.

    (I've always been able to find patches other people have made, but I fear one day it will not work out. In fact, as I reported here a couple of months ago, I couldn't get 3.19 to work with patches I found for Catalyst 15.4.)

  • #2
    Ouch. I just went looking for new patches and found nothing. Kernel 4.0 has been around for a little while now, and I'm surprised I didn't turn up much about any Catalyst driver version and 4.0, either.

    Anybody else tried to compile this driver for Kernel 4.0? Any luck that they fixed it but didn't update the release notes?

    (Sorry, but it's a chore to uninstall the old one, upgrade my kernel, and then try to install fglrx just to find that it doesn't work. So I'm trying to do as much research before I try it.)

    Comment


    • #3
      http://archive.ubuntu.com/ubuntu/poo....debian.tar.gz

      debian\dkms\patches\buildfix_kernel_4.0.patch

      Comment


      • #4
        Thanks for all the background.

        I don't understand your reference to the kernel patch. Was that supposed to be a link? That patch is probably the best thing, for me, since I can try to patch the new beta driver or the current stable Omega driver with it, which I know how to do.

        Regarding the tarball, this seems promising, but it looks a little strange. It's already compiled, but documentation is for the public .run installer, so I'm not sure where that leaves me. What is xpic/? This looks Debian oriented; if I have non-Debian-based distribution, how should I use this tarball? Aside from xpic, I think I recognize where everything goes, but clearly there be dragons if I'm just going to plop these files all over my system.

        Comment


        • #5
          I think what d2kx wanted to tell you is to download that tarball and use the patch that is contained in it in the directory debian/dkms/patches/

          Comment


          • #6
            So did I, but there is no such file in the tarball.
            Last edited by Porcelain Mouse; 06-09-2015, 02:37 AM.

            Comment


            • #7
              You can check out this guide, its pretty useful.

              Process Development Summary Below, find the updated installation instructions for the AMD Catalyst?15.5 driver on Fedora 22 with kernel version 4.0.4-303.fc22.x86_64. The process retains much of its content from?past processes, but with the following new changes: The?modification described by the patch stanza?for kcl_acpi.c?in the ultra.patch (originally from Philm of the Manjaro team, all the way?

              Comment


              • #8
                Thanks!!! Yeah, that looks exactly like what I need to upgrade my kernel.

                But, the process for downgrading XOrg X11 to 1.16 is ugly. Yikes. Ironically, F21 seems to be a better platform for Catalyst 15.5 than F22, since F21 has XOrg 1.16. So, I think this process will work even better for me than F22 users. That's something, although I really want to upgrade to F22, so...

                I'd still like to know what to do with the tarball d2kx referenced. That's what Fedora users really need, but I'm not sure how to go about it.

                Comment


                • #9
                  i have mint 17.2 upgraded to kernel 4.0.5 a couple of weeks ago and lost the fglrx i had installed and functioning fairly well-as far as AMD proprietary drivers go in Linux still. I had been at the omega 14.2 and today i installed the latest debian easy to do from AMD site catalyst 15.5 driver or fglrx 2.15.200.obuntu. 3 I can only access the gui panel from the terminal now. it is just about as functional as it was in kernel 3.16.24 and 3.17.x only no menu gui . and, my previous AMD overdrive control has a menu gui but fails on almost all of the features, seems to me that all i got through the debian installation in this kernel 4.0.5 is the driver and that is it even though it shows that everything is installed , not much in terms of function for overdrive. not sure if a patch would help or if it is necessary to go backward. i have the kernel updater and it is showing that there is a 4.1.2 available now. seems as though since AMD made some advances in catalyst for Linux that something beyond 3.17 or even 3.18 would be included . i am fairly new to anything Linux and am making things work in 4.0.5 because it is supported and been around long enough for lots of things.
                  no one has visited this post for a month but i came across it when looking for reasons as to why the catalyst control center isnt showing up in the menu after a 'successful' installation. some low standard for success, i guess.
                  would love to be able to resurrect the AMD Overdrive Control, it was a good tool while it lasted. at least i saved the profiles , just in case.
                  upgrade kernel and have to forget about using upgraded graphics tools, have to downgrade kernel to upgrade gpu features? something is wrong with this picture
                  john

                  Comment


                  • #10
                    Good news, I think I found the patch I needed! Using it, I got the latest Catalyst installed with Kernel 4.0.8.

                    Firstly, though, I *did not* try installing Catalyst 15.7 (Linux pkg 15.20) on F21 with Kernel 4.0, so I cannot confirm my earlier statement that F21 is a good fit.

                    In any case, I did upgrade to F22 and install it (Cat 15.7 (15.20)) using the instructions here:
                    https://bluehatrecord.wordpress.com/...-kernel-4-0-6/

                    This worked pretty well. Now that Catalyst is compatible with Xorg 1.17, it's back to the previous level of AMD support: barely tolerable; it requires changing the source code with a patch from the community. 1) The source code patch file provided is great: it applies without error and is an all-in-one patch. 2) The extra bit about byte-editing the binaries (from http://wiki.cchtml.com/index.php/Fed...allation_Guide) (is completely nuts, first of all, and) may be out-of-date already since my libglx.so didn't contain the string that needed replacement. I recommend not doing that part, just use the patch, compile & install, and just see what happens.

                    Comment

                    Working...
                    X