No announcement yet.

Black Screen with X3450 and X1250 using Xv

  • Filter
  • Time
  • Show
Clear All
new posts

  • Black Screen with X3450 and X1250 using Xv

    Greetings to all,

    I hope that people can give me some tips concerning a big problem. Since lately I'm having major troubles with both my X3450 and X1250 when using Xv related software.

    For a couple of seconds, everything goes without problems when starting Xine or Mplayer using Xv. But then I get the famous Black Screen. CTRL-ALT-1 or CTRL-ALT-BACKSPACE won't work but my system still runs.

    Strange thing is, it didn't had this problem before. But instantly the problems came forward. I've tried using earlier versions of the ATI/AMD drivers. I tried the Ubuntu/Hardy repository drivers, I tried manually installing them. No avail, problem is still there. The only thing I didn't try, is reinstalling. But hey, we're talking Linux here!

    BTW, before somebody tells me to use the OpenSource drivers. They won't work for me. Ati/Radeon drivers don't give any display (No Signal on HDMI) and RadeonHD gives garbled screen and doesn't allow Xv ouput.

    System specs:

    Mainboard : Gigabyte GA-MA69GM-S2H with onboard X1250
    Memory : 2 x 512 and 2 x 1GB Kingston Value RAM
    OS : Ubuntu Hardy 8.04 with Kernel 2.6.24-19 (updated and all)

    My Xorg.conf:

    # xorg.conf (X.Org X Window System server configuration file)
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    Section "ServerLayout"
            Identifier     "Default Layout"
            Screen      0  "aticonfig-Screen[0]-0" 0 0
            Option      "AIGLX" "true"
    Section "Files"
    Section "Module"
            Load  "dbe"
            Load  "extmod"
            Load  "glx"
            Load  "record"
            Load  "freetype"
            Load  "type1"
            Load  "dri"
    Section "InputDevice"
            Identifier  "Generic Keyboard"
            Driver      "kbd"
            Option      "XkbRules" "xorg"
            Option      "XkbModel" "pc105"
            Option      "XkbLayout" "us"
            Option      "XkbVariant" "intl"
            Option      "XkbOptions" "lv3:ralt_switch"
    Section "InputDevice"
            Identifier  "Configured Mouse"
            Driver      "mouse"
            Option      "CorePointer"
    Section "Monitor"
            Identifier   "Configured Monitor"
            VendorName   "Samsung"
            Option      "dpms"
    Section "Monitor"
            Identifier   "aticonfig-Monitor[0]-0"
            Option      "VendorName" "ATI Proprietary Driver"
            Option      "ModelName" "Generic Autodetecting Monitor"
            Option      "DPMS" "true"
    Section "Device"
            Identifier  "Configured Video Device"
            Driver      "vesa"
            Option      "DRI" "true"
            Option      "Monitor-HDMI-0" "Default Screen"
    Section "Device"
            Identifier  "aticonfig-Device[0]-0"
            Driver      "fglrx"
            Option      "mtrr" "off"
            Option      "TexturedVideo" "on"
            Option      "VideoOverlay" "on"
            Option      "OpenGLOverlay" "off"
            Option      "Capabilities" "0x00000000"
            Option      "XAANoOffscreenPixmaps" "true"
            Option      "BlockSignalsOnLock" "on"
            Option      "KernelModuleParm" "locked-userpages=0"
            Option      "UseFastTLS" "0"
            BusID       "PCI:1:5:0"
    Section "Screen"
            Identifier "aticonfig-Screen[0]-0"
            Device     "aticonfig-Device[0]-0"
            Monitor    "Configured Monitor"
            DefaultDepth     24
            SubSection "Display"
                    Depth     24
                    Modes    "1280x720" "1024x768"
    Section "Extensions"
                  Option "Composite" "false"
    Any tips, help and all is greatly appreciated


  • #2
    Do you have Compiz Fusion enabled... some releases of Mplayer have issues with Compiz being enabled, and as for the latest svn copy of it, it does not get full screen video, however it does render a window just fine.

    and as a quick question, what does the output of this command show... mplayer -version


    • #3

      No I don't have Compiz enabled. The Black Screen also occurs when just viewing in Window mode. Since my Ubuntu is my HTPC system (I'm using VDR 1.7.0 with my S2-3200), I mostly use Xine for output.

      Here are my versions of the players:

      [email protected]:~$ xine --version
      This is xine (X11 gui) - a free video player v0.99.6cvs.
      (c) 2000-2007 The xine Team.

      [email protected]:~$ mplayer -v
      MPlayer 1.0rc2-4.2.3 (C) 2000-2007 MPlayer Team
      CPU: AMD Athlon(tm) 64 X2 Dual Core Processor 4200+ (Family: 15, Model: 107, Stepping: 2)
      CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 1
      Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE SSE2

      BTW, I don't get a Black Screen no more (don't know what I changed) but I disabled extmod and I get the following information from my xorg.0.log.old:

      0: /usr/bin/X(xf86SigHandler+0x6a) [0x48402a]
      1: /lib/ [0x7ff67edcc100]
      2: /lib/ [0x7ff67ee16def]
      3: /usr/lib/xorg/modules// [0x7ff679fbc137]
      4: /usr/lib/xorg/modules// [0x7ff67a01b09f]
      5: /usr/lib/xorg/modules// [0x7ff679feb0e6]
      6: /usr/lib/xorg/modules// [0x7ff679feb814]
      7: /usr/lib/xorg/modules// [0x7ff679f6d7d7]
      8: /usr/lib/xorg/modules// [0x7ff679e0f773]
      9: /usr/bin/X [0x495d92]
      10: /usr/lib/xorg/modules/extensions// [0x7ff67d584326]
      11: /usr/bin/X(Dispatch+0x2ef) [0x44eaaf]
      12: /usr/bin/X(main+0x47d) [0x436b9d]
      13: /lib/ [0x7ff67edb81c4]
      14: /usr/bin/X(FontFileCompleteXLFD+0x279) [0x435ed9]
      Fatal server error:
      Caught signal 11.  Server aborting
      (II) AIGLX: Suspending AIGLX clients for VT switch
      As a result, I now get my login screen back.

      Last edited by shalafi; 06-20-2008, 02:30 AM.


      • #4
        Ok, there is few more things to ask...

        1) have you tried to compile mplayer from source, or use the smplayer package for mplayer.

        2) what's the output of the following command:

        xvinfo | grep -B4 YU

        for example, mine gives the following, and is also fully functional:
              id: 0x32315659 (YV12)
                guid: 59563132-0000-0010-8000-00aa00389b71
                bits per pixel: 12
                number of planes: 3
                type: YUV (planar)
              id: 0x30323449 (I420)
                guid: 49343230-0000-0010-8000-00aa00389b71
                bits per pixel: 12
                number of planes: 3
                type: YUV (planar)
              id: 0x32595559 (YUY2)
                guid: 59555932-0000-0010-8000-00aa00389b71
                bits per pixel: 16
                number of planes: 1
                type: YUV (packed)
              id: 0x59565955 (UYVY)
                guid: 55595659-0000-0010-8000-00aa00389b71
                bits per pixel: 16
                number of planes: 1
                type: YUV (packed)
        3) what's the output of the command: