No announcement yet.

AMD Catalyst 8.6 Linux Driver

  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by chibacityblues View Post
    This is annoying.. I setup a MythTV backend and it streams nicely. Video is ok - I can watch TV for hours without a problem... until I switch channels. Sometimes, not always, video gets corrupted like in this screenshot:

    Restarting the frontend fixes it. Is there anything I can do about it?

    I'm having this exact same problem with 8.4 drivers. It seems that if the image size differs when changing channels it messes up the picture. However going back to the MythTV main menu and back to LiveTV fixes it and you can now watch the previously messed up channel. I tried the 8.6 drivers, but I suffered from the image corruption (reported in another thread) and couldn't get any video running from Myth.

    Also with some channels I will not get the totally messed up picture, but instead two identical TV pictures (one on the upper part of the screen and the other on the bottom). Setting the MythTV scan mode to "Progressive" does help with this and fixes the picture. If I record shows with Myth they are totally OK, so it seems to be a problem with GFX driver.



    • System Specs:
      Intel D101GGC MOBO
      Intel Pentium D 805 2,66 Ghz
      Ati Xpress 200 IGP (128 MB Allocated in BIOS)
      Ubuntu Hardy Heron LTS
      1 GB Generic RAM

      Xvideo playback with VideoOverlay option "on" in xorg.conf still "jumps" in the video playback area... OpenGL apps crash with errors... VLC OpenGL video Playback doesn't work, and Mplayer crashes when closing the program with OpenGL video output... Please guys this is and old chip... some decent support for video playback would be nice...


      • Sounds like the driver isn't installed properly. What does "fglrxinfo" say?


        • After disabling the memory remap feature of my asus P5Q-E I can use only 3.3GB of my 4GB ram but Catalyst 8.6 seems to work :-)
          Thank you.

          Is this a problem a new Catalyst version can solve or is a fixed bios needed to have access to all of my 4GB ram?

          mtrr now looks like this:
          reg00: base=0x00000000 ( 0MB), size=2048MB: write-back, count=1
          reg01: base=0x80000000 (2048MB), size=1024MB: write-back, count=1
          reg02: base=0xc0000000 (3072MB), size= 256MB: write-back, count=1
          reg03: base=0xd0000000 (3328MB), size= 256MB: write-combining, count=1


          • hello, I have another problem with the catalyst drivers and my sony w4000 hdtv

            I use a hdmi connection, and the problem is that if I switch to another hdmi output on the TV, when I switch back to the hdmi input of the computer, the screen remains black.

            If I want to see something I must switch to console with ctrl+alt+F1, and switch back again to the X display ctrl+alt+F7.

            This happens with a radeon9600pro and the radeon hd4850 on two different computers running ubuntu and two different w4000 screen.
            There is not this problem on windows, or my nvidia 6600GT


            • Strange things happen


              after the first succes, my system did now a large step backwards. I don`t know what changed, but _sometimes_, I got a problem this my 4Gig Ram. I don`t know if it is an issue withe the ATI card, but here are the symptoms:

              every 64Bit Kernel, i try segfaults instantly, before starting initrd. When i remove 2G or use a 32Bit Kernel all is fine.
              Tried with
              64Bit Ubuntu/Hardy + Debian/Lenny 2.6.25-2-amd64
              I see something about a segfault on CPU1 SMP
              The Debian kernel allowed me to scroll backwards, and i find lots of
              "SLAB: cache with size 524288 has lost its name"

              As far, as i understand, this could be fixed with these mtrr-thingies, but my kernel now crashes, before i can run any script.

              My Gigabyte P45-DS3 has no option to switch any memory management or remapping. NB: I just installed the new F6-BIOS, but i feel, the Segfault comes earlier now.

              any suggestions of magic kernel-options?

              best wishes,



              • Press CTRL-F1 to see hidden options in BIOS.


                • before:
                  reg00: base=0x00000000 ( 0MB), size=4096MB: write-back, count=1
                  reg01: base=0xe0000000 (3584MB), size= 512MB: uncachable, count=1
                  reg02: base=0xd0000000 (3328MB), size= 256MB: uncachable, count=1
                  reg03: base=0x100000000 (4096MB), size=1024MB: write-back, count=1
                  reg04: base=0x130000000 (4864MB), size= 256MB: uncachable, count=1
                  reg05: base=0xcff00000 (3327MB), size= 1MB: uncachable, count=1

                  reg00: base=0x00000000 ( 0MB), size=2048MB: write-back, count=1
                  reg01: base=0x80000000 (2048MB), size=1024MB: write-back, count=1
                  reg02: base=0xc0000000 (3072MB), size= 256MB: write-back, count=1
                  reg04: base=0xe0000000 (3584MB), size= 256MB: uncachable, count=1
                  reg05: base=0xf0000000 (3840MB), size= 256MB: uncachable, count=1
                  reg06: base=0x100000000 (4096MB), size=1024MB: write-back, count=1

                  reg03 3072-3328 was set to write-combining, but after fglrx install it shows up empty

                  echo "disable=0" >| /proc/mtrr
                  echo "disable=5" >| /proc/mtrr
                  echo "disable=1" >| /proc/mtrr
                  echo "disable=3" >| /proc/mtrr
                  echo "disable=4" >| /proc/mtrr
                  echo "disable=2" >| /proc/mtrr
                  echo "disable=6" >| /proc/mtrr
                  echo "base=0x00000000 size=0x80000000 type=write-back" >| /proc/mtrr
                  echo "base=0x80000000 size=0x40000000 type=write-back" >| /proc/mtrr
                  echo "base=0xC0000000 size=0x20000000 type=write-back" >| /proc/mtrr
                  echo "base=0xD0000000 size=0x10000000 type=write-combining" >| /proc/mtrr
                  # System Devices:  3584-3840 3840-4096
                  echo "base=0xE0000000 size=0x10000000 type=uncachable" >| /proc/mtrr
                  echo "base=0xF0000000 size=0x10000000 type=uncachable" >| /proc/mtrr
                  # High memory area: 4096-5096
                  # I believe video memory lands here too
                  echo "base=0x100000000 size=0x40000000 type=write-back" >| /proc/mtrr
                  Using it for a while now. 3d acceleration works. What I noticed at a time of this writing, is that in 7zip benchmark performance grew and now is the same as in windows! Before it lagged behind by 15-20%

                  And believe me, I tried Ctrl-F1 in bios. Seems the function is not there on latest motherboards. All advanced settings are unlocked by default.


                  • Well on my G33-DS3R it is possible to unlock. Did you press that directly in the main BIOS menu? There are not much more settings, just a few.


                    • Hi,

                      When i press Ctrl-F1, die only additional thing is see, is the determination of IRQs.
                      I just upgrades to a Beta Bios (F7a) but ist did not help. The kernelpanic comes, but it comes later than with F6. Annoyingly BEFORE i can run any script.
                      Maybe it would be possible to put that into initrd, but now i leave for holidays.. :-)