Announcement

Collapse
No announcement yet.

black border

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • bishamon
    started a topic black border

    black border

    Hi

    Anyone using the latest 8.5 ati drivers? HAd a hard time getting it to compile and work. Finally got it compiled and my system can finally boot up to X. However, now my view are no longer display in full screen. I have a black border around the entire screen. Anyone else faced this problem?

    Before when I was on 8.4 and 8.3, never encounter this problem before.

    Is it an xorg.conf config issue? I have disable almost all the options i have inside already but still, it wont run in full screen. A alt-ctrl-backspace will restart X with the new xorg.conf without having to reboot the system, right?

    Anyone can help me?

  • kaivai
    replied
    So this is very late - 3 years after the last post, but I still ran into the problem anyways, and I hope this might help anyone else who runs into the same problem.
    This is an alternate solution to the problem.

    I wrote a script that writes the additions to /etc/ati/amdpscdb on startup. Before applying this, you should probably read the following:

    What you should know before doing this:

    Code:
    man update-rc.d
    Linux uses run levels in which it starts programs as the computer boots.

    0 --> when the computer shuts down
    s or 1 --> when the computer boots
    2,3,4,5 --> different run levels (you can see which programs boot in each in /etc/rc2.d/,/etc/rc3.d/, /etc/rc4.d/ etc...
    6 --> a reboot

    if you wanted to jump straight to a run level you can use the command telinit 3, telinit5 etc.

    Note that apparently distrobutions can choose to have programs run at different run levels. I cannot remember the man page that I read this in. sorry.

    Explanation:
    In Debian 6.3 - FGLRX runs it's first script in run level 2.
    I assumed that this is where it generates /etc/ati/amdpcsdb
    so I added a script that runs at that run level (actually I was impatient and made it start at 2,3,4,and 5)
    the script looks for the line:

    Gxo50HzTimingSupport=V1/Gxo50HzTimingSupport=V1
    and adds
    DigitalHDTVDefaultUnderscan=V0
    to the next line

    check your amdpcsdb to make sure that line exists, if it does not, choose another line under the same heading (the part in brackets)



    Instructions:

    -
    Code:
    cd /etc/init.d
    -
    Code:
    nano fglrxfix
    - enter the following:
    Code:
    	# FGLRX underscan fix
    	#-----------------------------
    
    sed 's/Gxo50HzTimingSupport=V1/Gxo50HzTimingSupport=V1\nDigitalHDTVDefaultUnderscan=V0/g' </etc/ati/amdpcsdb>wpbuffer	
    sudo cp wpbuffer /etc/ati/amdpcsdb
    sudo rm wpbuffer
    
    exit0
    -
    Code:
    chown root fglrxfix
    #makes root owner of fglrxfix
    -
    Code:
    chmod 4755 fglrxfix
    #makes fglrxfix executable as su

    -
    Code:
    update-rc.d fglrxfix start 20 2 3 4 5 .
    #makes fglrxfix run on startup (basically)

    -you're done

    This seems like a giant pain in the ass, but it's waaaaaaaaaaaaaay better than having to exit and restart the xserver every time you log in. This method works with multiple monitors.

    Cheers folks!

    Leave a comment:


  • soder
    replied
    Originally posted by WhatWasPrivacy View Post
    Having finally (for the moment, with 8.12, because I haven't had the guts to install the latest yet) solved the black borders on my setup, I thought I should share the solution that consistently works, for me at least. This is on a board with an integrated Radeon HD 3200 chip.

    Here's a compressed version of my documentation that I use if I need to rebuild my test machine (yes, I guess there's a silver lining somewhere. Having challenging graphics drivers finally made me do what I should have done a long time ago: partition my machine so that I now have a test and production media center ).
    • install ati-driver-installer-8-12-x86.x86_64.run
    • after reboot, admire black borders for the last time
    • change resolution to 1280x720 (don't think this is needed, I just like that resolution)
    • sudo aticonfig --overlay-type=Xv
    • sudo aticonfig --lcd-mode=full
    • sudo aticonfig --enable-monitor=tmds2i
    • sudo aticonfig --desktop-setup=single
    • sudo aticonfig --sync-vsync=on
    • make new modelines with
    • gtf 1280 720 50
    • gtf 1280 720 60
    • add modelines in the monitor section of xorg.conf
    • add modes "1280x720" in the subsection of the screen in xorg.conf
    • reboot
    • mourn loss of black borders


    So my Monitor section looks like this:
    Code:
    Section "Monitor"
            Identifier   "aticonfig-Monitor[0]-0"
            Option      "VendorName" "ATI Proprietary Driver"
            Option      "ModelName" "Generic Autodetecting Monitor"
            Option      "DPMS" "true"
            Modeline "1280x720_60.00"  74.48  1280 1336 1472 1664  720 721 724 746  -HSync +Vsync
            Modeline "1280x720_50.00"  60.47  1280 1328 1456 1632  720 721 724 741  -HSync +Vsync
    EndSection
    My Device section like this:
    Code:
    Section "Device"
            Identifier  "aticonfig-Device[0]-0"
            Driver      "fglrx"
            Option      "VideoOverlay" "on"
            Option      "OpenGLOverlay" "off"
            Option      "Centermode" "off"
            Option      "EnableMonitor" "tmds2i"
            Option      "DesktopSetup" "single"
            Option      "Capabilities" "0x00000800"
            BusID       "PCI:1:5:0"
    EndSection
    And the Screen section like this:

    Code:
    Section "Screen"
            Identifier "aticonfig-Screen[0]-0"
            Device     "aticonfig-Device[0]-0"
            Monitor    "aticonfig-Monitor[0]-0"
            DefaultDepth     24
            SubSection "Display"
                    Viewport   0 0
                    Depth     24
                    Modes    "1280x720"
            EndSubSection
    EndSection
    This works for me and... dare I say... makes me happy

    Obviously besides tears of joy I also still experience tears of movement onscreen, but that has become a lot better with 8.12 for me. Once I gather up the courage, I'll try the latest.
    I jus tried all that, but, when I restart, my TV will not even give me a screen.
    It flashes between 1080p and 720p and cant find something it can show.

    I think it has something to do about me missing the amdpcsdb, but I cant figuer it out how to recreate it.

    /S?der

    Leave a comment:


  • soder
    replied
    Originally posted by bofh View Post
    Hi,

    I have a AMD 780 based board (Gigabyte GA-MA78GM-S2H) as HTPC connected to an Panasonic TH42 PX80E (via HDMI).
    The box is running under Gentoo with Catalyst 8.10.
    X is running with 1280x720 @60 Hz, the TV recognises it as "720p". With Overscan turned off in the TV Menu, I get black borders around the screen (~ 3 cm).

    aticonfig --set-pcs-val=MCIL,DigitalHDTVDefaultUnderscan,0 didnt change anything.

    After running
    aticonfig --set-dispattrib=tmds2i,positionX:0
    aticonfig --set-dispattrib=tmds2i,positionY:0
    aticonfig --set-dispattrib=tmds2i,sizeX:1280
    aticonfig --set-dispattrib=tmds2i,sizeY:720
    the black borders are gone!

    The Problem occurs at the next Xorg start/restart: Xorg doesnt start any more, I get only a black screen! WTF ?!?

    aticonfig stored the position / size changes in /etc/ati/amdpcsdb.
    If I delete the changes made by aticonfig, Xorg starts again, but naturally the black borders are there again!

    I deleted /etc/ati/amdpcsdb to make sure that this is not a problem with legacy settings from older catalyst versions. After running aticonfig again, Xorg doesnt start. I didnt found any significant error message in the Xorg log.

    Does anybody know how
    x aticonfig can be prevented to store these settings in amdpcsdb?
    x or how could Xorg be persuaded to start in spite of these settings in amdpcsdb?

    Thanks,
    Dominik
    I just have to say, I have the same TV and same motherboard. And same problem. I finaly solved my problem with the HDTVunderscan 0 you also tested. The aticonfig --set-dispattrib=tmds2i also work, everytime, but I prefer to solve it as it should. And for me that was the HDTVunderscan 0, at least it was before.

    Now Ive tried newer drivers, and they didnt work for me, so Im back to the 8.552 again.
    But, now my problem is back, and I cant use the setting I used to anymore. My amdpcsdb are gone, and I cant understand why.

    Dont understand why that file isnt created when doing the aticonfig --initial --force

    This driving my craxy...

    /S?der

    Leave a comment:


  • WhatWasPrivacy
    replied
    Removing the modelines, only leaving the forced mode gives me black borders again.

    Leave a comment:


  • Kano
    replied
    Leave the forced mode but remove the modelines.

    Leave a comment:


  • WhatWasPrivacy
    replied
    Originally posted by Kano View Post
    But the modelines are most likely not used, did you try without?
    Yes, I did. I stepped through the various things that I tried, and it is the modelines that make the difference for me.
    Although, let me qualify that. They make the difference after the other steps. I haven't tried them in isolation yet, so it could be a combination of things.

    I also recall reading (can't find source) that we shouldn't use modelines anymore, an don't remember why I decided to try it. (desperation? )

    (edit: doubt is good, so I just double checked to make sure and yes: removed modelines and mode in subsection -> black borders. Added lines back in -> bye bye borders. Strictly speaking that's still not testing them in isolation, but good enough for me)
    Last edited by WhatWasPrivacy; 01-31-2009, 08:05 PM.

    Leave a comment:


  • Kano
    replied
    But the modelines are most likely not used, did you try without?

    Leave a comment:


  • WhatWasPrivacy
    replied
    Having finally (for the moment, with 8.12, because I haven't had the guts to install the latest yet) solved the black borders on my setup, I thought I should share the solution that consistently works, for me at least. This is on a board with an integrated Radeon HD 3200 chip.

    Here's a compressed version of my documentation that I use if I need to rebuild my test machine (yes, I guess there's a silver lining somewhere. Having challenging graphics drivers finally made me do what I should have done a long time ago: partition my machine so that I now have a test and production media center ).
    • install ati-driver-installer-8-12-x86.x86_64.run
    • after reboot, admire black borders for the last time
    • change resolution to 1280x720 (don't think this is needed, I just like that resolution)
    • sudo aticonfig --overlay-type=Xv
    • sudo aticonfig --lcd-mode=full
    • sudo aticonfig --enable-monitor=tmds2i
    • sudo aticonfig --desktop-setup=single
    • sudo aticonfig --sync-vsync=on
    • make new modelines with
    • gtf 1280 720 50
    • gtf 1280 720 60
    • add modelines in the monitor section of xorg.conf
    • add modes "1280x720" in the subsection of the screen in xorg.conf
    • reboot
    • mourn loss of black borders


    So my Monitor section looks like this:
    Code:
    Section "Monitor"
            Identifier   "aticonfig-Monitor[0]-0"
            Option      "VendorName" "ATI Proprietary Driver"
            Option      "ModelName" "Generic Autodetecting Monitor"
            Option      "DPMS" "true"
            Modeline "1280x720_60.00"  74.48  1280 1336 1472 1664  720 721 724 746  -HSync +Vsync
            Modeline "1280x720_50.00"  60.47  1280 1328 1456 1632  720 721 724 741  -HSync +Vsync
    EndSection
    My Device section like this:
    Code:
    Section "Device"
            Identifier  "aticonfig-Device[0]-0"
            Driver      "fglrx"
            Option      "VideoOverlay" "on"
            Option      "OpenGLOverlay" "off"
            Option      "Centermode" "off"
            Option      "EnableMonitor" "tmds2i"
            Option      "DesktopSetup" "single"
            Option      "Capabilities" "0x00000800"
            BusID       "PCI:1:5:0"
    EndSection
    And the Screen section like this:

    Code:
    Section "Screen"
            Identifier "aticonfig-Screen[0]-0"
            Device     "aticonfig-Device[0]-0"
            Monitor    "aticonfig-Monitor[0]-0"
            DefaultDepth     24
            SubSection "Display"
                    Viewport   0 0
                    Depth     24
                    Modes    "1280x720"
            EndSubSection
    EndSection
    This works for me and... dare I say... makes me happy

    Obviously besides tears of joy I also still experience tears of movement onscreen, but that has become a lot better with 8.12 for me. Once I gather up the courage, I'll try the latest.

    Leave a comment:


  • asw20pilot
    replied
    Bridgman, thank you very much for your quick replies and your work on the driver.

    For everyone's information:
    Last night I tried adding an NVidia 8600GT card from another computer to my 780G setup. Ubuntu 8.10 immediately offered to install the right proprietary drivers and everything worked flawlessly at once. HD video playback without a glitch.

    The only drawback is that the system draws 25W more power than without the NVidia card, and that's although it is a passively cooled fanless card. That sort of defeats the purpose of my low power setup, so it is not satisfactory. The whole system only draws 45W in idle without the extra graphics card.

    Best regards,
    Mikkel

    Leave a comment:

Working...
X