No announcement yet.

Catalyst 8.5 can't detect my monitor settings correctly

  • Filter
  • Time
  • Show
Clear All
new posts

  • Catalyst 8.5 can't detect my monitor settings correctly

    So, I downloaded Catalyst 8.5 and installed it and everything worked fine (after a bit hacking).
    My first experience was... well, nothing. fglrx adjusted a vertical and horizontal refresh rate pair that my monitor couldn't display. So, I adjusted them manually, by guessing as I haven't got the manual of the monitor anymore (I once knew of a program that could tell them but I forgot the name of it, anybody got a clue?).
    However, after a "bit" guessing I finally found a pair that worked. Kind of. The first thing is that I can't adjust anything more that 60 Hz (my monitor can do 75 Hz), but that's not the worst problem (probably is just because the values for hsync and vrefresh aren't correct).
    Somehow, the screen uses 1280x1024 (as it should) but it's somewhat squeezed... I took a screenshot of it, and for my surprise, the screenshot is at 1920x1080! (and my monitor _was_ at 1280x1024 for sure).
    I'll edit this post later when I've found an imagehost an provide you with the screenshots, but for now: just imagine a 1920x1080 screenshot which is compressed to 1280x1024. Looks kinda strange.

    the 1920x1080 screenshot:
    the 1280x1280 screenshot: (the way it should look)
    the first one squeezed: (the way it looks)

    However, here's my xorg.conf:

    Originally posted by xorg.conf
    Section "ServerLayout"
    Identifier "single head configuration"
    Screen 0 "aticonfig-Screen[0]" 0 0
    InputDevice "Keyboard0" "CoreKeyboard"

    Section "Files"

    Section "Module"

    Section "ServerFlags"
    Option "AIGLX" "on"

    Section "InputDevice"
    Identifier "Keyboard0"
    Driver "kbd"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "de"
    Option "XkbVariant" "neo"

    Section "Monitor"
    Identifier "aticonfig-Monitor[0]"
    HorizSync 60.0 - 72.0
    VertRefresh 60.0 - 72.0
    Option "VendorName" "ATI Proprietary Driver"
    Option "ModelName" "Generic Autodetecting Monitor"
    Option "DPMS" "true"

    Section "Device"
    Identifier "aticonfig-Device[0]"
    Driver "fglrx"

    Section "Screen"
    Identifier "aticonfig-Screen[0]"
    Device "aticonfig-Device[0]"
    Monitor "aticonfig-Monitor[0]"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24

    Section "Extensions"
    Option "Composite" "Enable"
    One other funny thing is, that when I run KRandRTray I get a normal display again.
    This is on a Fedora 8 machine and in case it helps, I have an X17-3 Monitor by Fujitsu Siemens (which works well under Windows and did under Catalyst 8.4)

    Thank you for any help regarding my problem and just ask if you need some additional info!

    EDIT: Okay, got it by specifying fixed resolution values.
    Last edited by NeoBrain; 05-24-2008, 03:52 AM. Reason: fixed

  • #2
    Have you tried changing the resolution from within the catalyst control center?
    This is the best way to change resolutions with fglrx.