No announcement yet.

ati drivers and Fedora 9

  • Filter
  • Time
  • Show
Clear All
new posts

  • ati drivers and Fedora 9

    Fedora 9 is finally out. Can anyone confirm that latest ATI drivers installs and fglrx compiles on this release correctly?

  • #2
    F9 locked down after the most recent fglrx driver was locked, so I wouldn't be surprised if there were issues.

    Our testing focus for fglrx right now is on new GPUs and already-released distros, while the open source drivers cover the unreleased distros.


    • #3
      Anyone with testing on the open source drivers and F9? I have an X1600. Just curious to others' results.

      If not, I'll probably be installing F9 to test soon and can post results.


      • #4
        I`ve got x1200 and I can't modprobe the fglrx module couse of error :
        fglrx: Unknown symbol flush_tlb_page
        Symbol init_mm is marked as UNUSED, however this module is using it.
        This symbol will go away in the future.
        Please evalute if this is the right api to use, and if it really is, submit a report the linux kernel mailinglist together with submitting your code for inclusion.
        Can someone write ho to patch it, or post a link to such a instruction ?
        Last edited by kostekjo; 05-19-2008, 06:03 PM.


        • #5
          It looks like there are one or two things in F9 that fglrx does not like: 1) the 2.6.25 kernel and 2) Xorg server 1.5. Bridgman, do you have any info whether these two should be supported by Catalyst 8.5? If only the kernel is supported, we might need to downgrade xorg-x11-server, as it was the case before with Fedora7 and the 8.38.6 driver.


          • #6
            For 32 bit you can use:


            For 64 bit you need to patch your kernel.

            diff -Nru linux-2.6.25.orig/arch/x86/kernel/smp_64.c linux-2.6.25/arch/x86/kernel/smp_64.c
            --- linux-2.6.25.orig/arch/x86/kernel/smp_64.c	2008-04-17 04:49:44.000000000 +0200
            +++ linux-2.6.25/arch/x86/kernel/smp_64.c	2008-04-23 18:17:45.000000000 +0200
            @@ -269,6 +269,7 @@
             static void do_flush_tlb_all(void* info)


            • #7
              Using a Sapphire X1600 Pro (512 MB) I tried out the preview version of F9 and it didn't even get the "init" done, that is, I guess it tried to start the graphical init process and then failed to display anything (hardlocked). I didn't have the time (and didn't want to) further investigate this and just installed F8 instead, which does provides 3d accel AND KDE 4 (though it's from an inofficial repo).
              I'm still looking for some Amarok 2 builds for Fedora, but that's another topic


              • #8
                I don't have any /arch/x86/kernel/smp_64.c file ?

                Guess I just wait for the official drivers. Now I use the radeon driver, it's good but I've no 3d support...


                • #9
                  On newer kernels it is somewhere else, that was for pure 2.6.25.


                  • #10
                    Originally posted by peper View Post
                    Fedora 9 is finally out. Can anyone confirm that latest ATI drivers installs and fglrx compiles on this release correctly?
                    I just installed F9 which has the ATI 6.8.0-12.fc9(x86_64). I ran into problems. The system told me there were updates, which included the ATI driver 6.8.0-14.fc9(x86_64). If I install that update I am greeted by a black screen on reboot. I did install the RaadeonHD 1.2.1 drivers no problem. After installing RadeonHD, if I try to roll back to the ATI driver, I get the black screen on reboot. I'm going to stick the the default install of the ATI 6.8.0-12.fc9(x86_64) driver.

                    AMD Sempron 1800+
                    Jetway ATI xpress200 MB
                    ATI x1900GT
                    1Gb RAM