Announcement

Collapse
No announcement yet.

question about compiz (prop. drivers working)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • question about compiz (prop. drivers working)

    Hi,

    I followed the how-to here:

    http://www.phoronix.com/forums/showthread.php?t=7193

    and got the proprietary drivers working fine. Direct rendering is on when I type glxinfo.

    Anyhow, I would like to get compiz working - but I'm confused about all of this xgl/aiglx stuff. When I reinstall xgl, my ati drivers are no longer working. When I uninstall XGL, I cannot get compiz working.

    Can someone give me a suggestion?

  • #2
    Ooops... I should have said that I'm working with Gutsy (ubuntu 7.10)

    Cheers.

    Comment


    • #3
      Originally posted by jacksmash View Post
      Ooops... I should have said that I'm working with Gutsy (ubuntu 7.10)

      Cheers.
      Ok.. from some further searching I've tried enabling AIGLX in my xorg.conf. I've also tried whitelisting the fglrx driver in my /usr/bin/compiz file.

      When I try to run compiz --replace I just get a bunch of messages. When I try to enable desktop effects from the gui, i just get a message saying "Desktop effect could not be enabled".

      The messages I get while running compiz --replace --indirect-rendering are as follows:

      Checking for Xgl: not present
      Checking for texture_from_pixmap: present
      Check for non power of two support: present
      Checking for Composite Extension: present
      etc

      then finally:
      /usr/bin/compiz: 378 /usr/local/bin/compiz: not found
      metacity: Unknown option --indirect-rendering


      Thanks for any suggestions.

      Comment


      • #4
        Originally posted by jacksmash View Post
        Ok.. from some further searching I've tried enabling AIGLX in my xorg.conf. I've also tried whitelisting the fglrx driver in my /usr/bin/compiz file.

        When I try to run compiz --replace I just get a bunch of messages. When I try to enable desktop effects from the gui, i just get a message saying "Desktop effect could not be enabled".

        The messages I get while running compiz --replace --indirect-rendering are as follows:

        Checking for Xgl: not present
        Checking for texture_from_pixmap: present
        Check for non power of two support: present
        Checking for Composite Extension: present
        etc

        then finally:
        /usr/bin/compiz: 378 /usr/local/bin/compiz: not found
        metacity: Unknown option --indirect-rendering


        Thanks for any suggestions.

        Ok... seem to have gotten it to work after modifying the /usr/bin/compiz file according to this discussion:

        http://ubuntuforums.org/showthread.php?t=585252

        Cheers.

        Comment

        Working...
        X