Announcement

Collapse
No announcement yet.

ATI fglrx driver and component output using driver version 8.4

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • ATI fglrx driver and component output using driver version 8.4

    Has anyone gotten component output to TV working with the fglrx ATI driver and an Integrated X1250? I can get a picture, but it is grey (monochrome). I have tried various options in my xorg.conf file and have succeeded in getting the picture to become very blue (or very red). I've spent many hours googling, and have tried many options, but I can't seem to get better than this. The S-Video display fine and looks good. I've attached my xorg.conf for reference (and you'll see it's been heavily hacked up). Anyone have any ideas to try?

    Rob

    # /etc/X11/xorg.conf (xorg X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
    # (Type "man /etc/X11/xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    # sudo dpkg-reconfigure -phigh xserver-xorg

    Section "Files"
    FontPath "/usr/share/fonts/X11/misc"
    FontPath "/usr/X11R6/lib/X11/fonts/misc"
    FontPath "/usr/share/fonts/X11/cyrillic"
    FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
    FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
    FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
    FontPath "/usr/share/fonts/X11/Type1"
    FontPath "/usr/X11R6/lib/X11/fonts/Type1"
    FontPath "/usr/share/fonts/X11/100dpi"
    FontPath "/usr/X11R6/lib/X11/fonts/100dpi"
    FontPath "/usr/share/fonts/X11/75dpi"
    FontPath "/usr/X11R6/lib/X11/fonts/75dpi"
    # path to defoma fonts
    FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    EndSection

    Section "Module"
    # Load "i2c"
    # Load "bitmap"
    # Load "ddc"
    Load "dri"
    # Load "extmod"
    # Load "freetype"
    Load "glx"
    # Load "int10"
    # Load "vbe"
    Load "v4l"
    Load "dbe"
    Load "fglrx"
    EndSection

    Section "InputDevice"
    Identifier "Generic Keyboard"
    Driver "kbd"
    Option "CoreKeyboard"
    Option "XkbRules" "xorg"
    Option "XkbModel" "pc104"
    Option "XkbLayout" "us"
    EndSection

    Section "InputDevice"
    Identifier "Configured Mouse"
    Driver "mouse"
    Option "CorePointer"
    Option "Device" "/dev/input/mice"
    Option "Protocol" "ImPS/2"
    Option "Emulate3Buttons" "true"
    EndSection

    Section "Device"
    Identifier "Generic Video Card"
    Driver "vesa"
    BusID "PCI:1:5:0"
    EndSection

    Section "Device"
    Identifier "Radeon Xpress 1250"
    Driver "fglrx"
    # Option "MetaModes" "720x480; 640x480"
    # Option "MonitorLayout" "NONE,TV"
    Option "TVStandard" "Video"
    # Option "UseFBDev" "false"
    Option "VideoOverlay" "on"
    Option "OpenGLOverlay" "off"
    Option "TVFormat" "NTSC-M"
    # Option "TVFormat" "NTSC"
    # Option "ForceMonitors" "crt1,tv"
    Option "ForceMonitors" "tv,none"
    Option "NoTV" "no"
    Option "UseInternalAGPGART" "no"
    Option "XAANoOffscreenPixmaps" "on"
    Option "TexturedVideo" "on"
    Option "OpenGLOverlay" "off"
    # Option "Textured2D" "on"
    # Option "TexturedXrender" "on"
    # Option "UseFastTLS" "1?
    Option "OverlayOnCRTC2" "1"
    Option "DesktopSetup" "clone"
    # Option "TVHSizeAdj" "0"
    # Option "TVVSizeAdj" "0"
    # Option "TVHPosAdj" "0"
    # Option "TVVPosAdj" "0"
    # Option "TVHStartAdj" "0"
    # Option "TVColorAdj" "0"
    BusID "PCI:1:5:0"
    EndSection

    Section "Monitor"
    Identifier "Generic Monitor"
    Option "DPMS"
    HorizSync 28-32
    VertRefresh 43-60
    EndSection

    Section "Monitor"
    Identifier "JVC AV-32D201"
    VertRefresh 60.0
    # Option "TV Format" "NTSC"
    # ModeLine "NTSCspec-59.94i" 14.318 768 784 848 910 483 484 492 525 Interlace
    # ModeLine "Broadcast-59.94i" 483 484 492 525 Interlace
    # ModeLine "NTSC-DVD-59.94i" 13.5 720 736 800 858 480 484 492 525 Interlace
    # ModeLine "NTSC-DVD-60i" 13.514 720 736 800 858 480 484 492 525 Interlace
    # ModeLine "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
    ModeLine "640x480" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
    Gamma 1.0
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    Device "Generic Video Card"
    Monitor "Generic Monitor"
    DefaultDepth 24
    SubSection "Display"
    Depth 1
    Modes "640x480"
    EndSubSection
    SubSection "Display"
    Depth 4
    Modes "640x480"
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "640x480"
    EndSubSection
    SubSection "Display"
    Depth 15
    Modes "640x480"
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "640x480"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "640x480"
    EndSubSection
    SubSection "Display"
    Depth 32
    Modes "640x480"
    EndSubSection
    EndSection

    Section "Screen"
    Identifier "Family Room TV"
    Device "Radeon Xpress 1250"
    Monitor "JVC AV-32D201"
    DefaultDepth 24
    SubSection "Display"
    Depth 16
    Modes "640x480"
    EndSubSection
    SubSection "Display"
    Depth 24
    Virtual 640 480
    Modes "640x480"
    EndSubSection
    SubSection "Display"
    Depth 32
    Modes "640x480"
    EndSubSection
    # Option "Connected Monitor" "TV"
    # Option "TVStandard" "NTSC"
    # Option "TVStandard" "HD480i"
    # Option "TVStandard" "DVD"
    # Option "TVOutFormat" "Component"
    # Option "MetaModes" "720x480; 640x480"
    EndSection

    Section "Extensions"
    Option "RENDER" "Enable"
    Option "DAMAGE" "Enable"
    # Option "Composite" "Enable"
    Option "Composite" "Disable"
    Option "XVideo" "Enable"
    EndSection

    Section "ServerLayout"
    Identifier "Default Layout"
    Screen "Default Screen"
    InputDevice "Generic Keyboard"
    InputDevice "Configured Mouse"
    EndSection

    Section "ServerLayout"
    Identifier "layout-fr_client"
    Screen "Family Room TV"
    InputDevice "Generic Keyboard"
    InputDevice "Configured Mouse"
    EndSection

    Section "DRI"
    Mode 0666
    EndSection

    Section "ServerFlags"
    # Option "AIGLX" "on"
    Option "AIGLX" "off"
    EndSection

  • #2
    Oops

    I'm using the fr-client layout in that xorg.conf file.

    Comment


    • #3
      This is what my setup looks like with component:



      With s-video the colors are correct. Any progress on fixing the colors using component TV-out?

      Posted on ubuntuforums.org also

      Comment


      • #4
        Looked like HW fault for me

        Try rebooting with your TV connected to just the composite output and see if your BIOS screen(s) have correct colors. I did this and noticed that my composite output didn't have color, so I contacted Gigabyte and sent it back to them for them to look at once they told me the composite output should have color (one of the component outputs doubles as composite). At this point I don't think it was a driver/configuration issue since the composite output wasn't right in the BIOS screens.

        However, UPS promptly damaged the package so Gigabyte won't touch it and it's being send back to me, so I don't have confirmation that it's a hardware issue.

        Comment

        Working...
        X