No announcement yet.

Trouble with Updating ATI Driver for Direct Rendering

  • Filter
  • Time
  • Show
Clear All
new posts

  • Trouble with Updating ATI Driver for Direct Rendering

    It seems that every time I try to update my ATI Radeon 9800 Pro card on 8.04, using any of the installation methods, I cannot get fglrxinfo to mention ATI at all and it's all entirely Mesa.

    The first two inconsistencies I noticed was that wanted me to access the Restricted Driver Manager which I could not find. So I passed over this step to Method 1. Method 1 went without a hitch until the fglrxinfo command which obviously showed something didn't go right because every line was Mesa. I also made every attempt to remove Mesa by removing everything that mentions fglrx, making sure the Device Driver is fglrx, etc.

    The second method on that page went well until

    sudo sh --buildpkg Ubuntu/hardy

    where it said I could not run it (yes I downloadeded it). I also could not collect packages "ia32-libs" and "" before proceeding because I tried googling and searching the ubuntu forums for these but no luck. What's also worth noting is that Hardware Drivers makes no mention of ATI and it's really weird because it did prior to me trying out the plethora of driver install methods for various Ubuntus.

    I also tried using Envy but that did not solve the Mesa issue and because of that, I've still yet to get direct rendering on my computer which is my primary goal. That, and I'd like to get WoW running with my ATI card by resolving the rendering issue and the resolution issue I get from switching windows.

    For additional info: Refer to my ubuntu-equivalent thread:

    And my stats:

    2 gigs of RAM.
    Asus P4C-800-E Deluxe
    Pent 4
    ATI Radeon 9800 Pro
    Unsure about 32bit or 64bit.

    I'd greatly appreciate any help.
    Last edited by Ericf88; 04-29-2008, 04:59 PM.