No announcement yet.

External Monitor won't go past 1024x768 on 8.3

  • Filter
  • Time
  • Show
Clear All
new posts

  • External Monitor won't go past 1024x768 on 8.3


    I've got a Dell Inspiron 6400, Mobility X1400 128mb, with a 1440x900 internal display. I also have a Gateway FPD2185W (1680x1050) and a Dell 24" (1920x1200) close by. I had been using the 7.11 Catalyst package exclusively and had no problems (well, no major issues anyway) with using the Gateway and the internal monitor at the same time.

    Now, the problems began when I tried to hook it up to the Dell; it wouldn't do the normal plug in - amdcccle detect - enable - bit, so I restarted. Then I got it to enable but it messed up the DPI of the screen and reported only having 1024x768 available, with approximately the left 1/3 of that screen being black. I tried to use the Gateway after this and got the same issue. I upgraded then to 8.3 and the issue persists exactly.

    The fglrx driver is detecting a 1990 CRT, 40x30 cm with a maximum resolution of 1024x768 (and with the preferred mode not being the first one listed) for BOTH monitors -- the exact same "CRT" in fact. Both monitors are being connected via. VGA. They have had no problems being used in the past (say, about 3 months ago).

    Any clues?