No announcement yet.

Problem with 8.01: "Failed to initialize ASIC in kernel"

  • Filter
  • Time
  • Show
Clear All
new posts

  • #21
    Originally Posted by Antiarch View Post
    The good news is there's a simple work around for it. Find the Device section in your xorg.conf (Section "Device") and look for a line that starts with BusID. In quotes will be something like "1:0:0" (there will be different numbers depending on your card) Before that string of numbers, add "PCI:", to make it look like this: "PCI:1:0:0".
    This seems to have worked for me. Currently running AIGLX at ~2300fps in glxgears and between 505 and 515 fps in fgl_glxgears.

    Had a few issues getting it going, but i think that was related to XGL and my xorg.conf.

    Last edited by combatdoc; 01-30-2008, 08:43 PM.


    • #22
      Worked for me too, 3D is working again Thanks!


      • #23
        i dont have a BusID field at all - 1400X, Suse 10.3

        hello!!! help!!!

        i'm a novice, so this is really discouraging me. i'm using a dell inspiron 9400, mobility 1400X, opensuse 10.3, 64bit version. i should have a resolution of 1400x900, but dont get it. I don't have any 3D either. i downloaded the driver from i installed it, and BAM! it failed to get the graphical screen. Ctrl +Alt + F1 failed to get console too. i had to reboot with single option at GRUB prompt, and replace the xorg.conf file with a backup i made. that got me back my graphics, but still with a resolution of 1152x864. i tried did an uninstall of the fglrx driver, and reinstalled and it broke again. i get the error message
        (EE) fglrx(0): Failed to initialize ASIC in kernel. etc,etc

        however i DONT HAVE A BusID line in my xorg.conf file at all!

        what do i do?

        I hope i've provided enough information


        • #24
          You are not alone. I've this issue with the 8.5 release on ubuntu hardy with a X1300 pcie.

          This driver seems to be worse for my card every release.

          I had no BusID in my xorg.conf, now i have but it doesn't make any difference. Someone has a clue to help me out?


          • #25
            allartk, what errors are you getting in the X log ?


            • #26
              Here the warnings and error from my Xorg.0.log

              $ grep '(EE)\|(WW)' Xorg.0.log 
                      (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
              (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
              (WW) fglrx: No matching Device section for instance (BusID PCI:1:0:1) found
              (WW) fglrx: No matching Device section for instance (BusID PCI:1:0:1) found
              (EE) fglrx(0): Failed to initialize ASIC in kernel.
              (WW) fglrx(0): board is an unknown third party board, chipset is supported
              (WW) fglrx(0): Only one display is connnected,so single mode is enabled
              (EE) fglrx(0): [pcie] Failed to gather memory of size 261120Kb for PCIe. Error (-1007)
              (EE) fglrx(0): atiddxDriScreenInit failed, GPS not been initialized. 
              (WW) fglrx(0): ***********************************************
              (WW) fglrx(0): * DRI initialization failed!                  *
              (WW) fglrx(0): * (maybe driver kernel module missing or bad) *
              (WW) fglrx(0): * 2D acceleraton available (MMIO)             *
              (WW) fglrx(0): * no 3D acceleration available                *
              (WW) fglrx(0): ********************************************* *
              (WW) fglrx(0): Textured Video not supported without DRI enabled.
              (WW) fglrx(0): Option "VendorName" is not used
              (WW) fglrx(0): Option "ModelName" is not used
              (EE) fglrx(0): firegl_SetSuspendResumeState FAILED -1003.
              edit: I can post the used xorg.conf in the evening (about 8 hours ) but I was a bit in a hurry this morning
              Last edited by allartk; 05-26-2008, 03:41 AM.


              • #27
                I switched to the OSS driver..


                • #28
                  Not sure if this is relevant, but how much system memory do you have ? Wondering if this might be a low memory issue; looks like we're trying to grab 256MB during kernel driver initialization and failing.


                  • #29
                    Nah, probably not memory. I suspect a bad installation.

                    Start fresh with "sudo rm -rf /var/lib/dkms/fglrx", then install again. (You might consider first switching to the vesa driver and rebooting to the the fglrx modules 'n everything unloaded.)
                    I've written a script for Ubuntu types to assist in installation... You can get it here. (Excuse the messy post there, I have yet to clean it up.)

                    EDIT: Oh yeah, that'll install Catalyst 8.4 (the most recent being 8.5). If you want/need Catalyst 8.5, you can edit lines 69 and 72, replacing the "8-4-x86" with "8-5-x86". No other changes are necessary.
                    Last edited by SheeEttin; 05-28-2008, 10:20 PM.


                    • #30
                      Thanks for the answer, the errors are gone, but nothing is displayed. So I have a black screen.. The last rows in my Xorg.1.log are:
                      (**) Configured Mouse: always reports core events
                      (**) Option "Device" "/dev/input/mice"
                      (**) Option "Emulate3Buttons" "true"
                      (**) Configured Mouse: Emulate3Buttons, Emulate3Timeout: 50
                      (**) Option "ZAxisMapping" "4 5"
                      (**) Configured Mouse: ZAxisMapping: buttons 4 and 5
                      (**) Configured Mouse: Buttons: 9
                      (**) Configured Mouse: Sensitivity: 1
                      (II) evaluating device (Configured Mouse)
                      (II) XINPUT: Adding extended input device "Configured Mouse" (type: MOUSE)
                      (II) evaluating device (Generic Keyboard)
                      (II) XINPUT: Adding extended input device "Generic Keyboard" (type: KEYBOARD)
                      (II) Configured Mouse: ps2EnableDataReporting: succeeded
                      (II) AIGLX: Suspending AIGLX clients for VT switch
                      my xorg.conf is

                      # xorg.conf (xorg X Window System server configuration file)
                      # This file was generated by dexconf, the Debian X Configuration tool, using
                      # values from the debconf database.
                      # Edit this file with caution, and see the xorg.conf manual page.
                      # (Type "man xorg.conf" at the shell prompt.)
                      # This file is automatically updated on xserver-xorg package upgrades *only*
                      # if it has not been modified since the last upgrade of the xserver-xorg
                      # package.
                      # If you have edited this file but would like it to be automatically updated
                      # again, run the following command:
                      #   sudo dpkg-reconfigure -phigh xserver-xorg
                      Section "ServerLayout"
                      	# Uncomment if you have a wacom tablet
                      	#	InputDevice     "stylus"	"SendCoreEvents"
                      	#	InputDevice     "cursor"	"SendCoreEvents"
                      	#	InputDevice     "eraser"	"SendCoreEvents"
                      	Identifier     "Default Layout"
                      	Screen      0  "aticonfig-Screen[0]" 0 0
                      	InputDevice    "Generic Keyboard"
                      	InputDevice    "Configured Mouse"
                      #	Option	    "AIGLX" "false"
                      Section "Files"
                      Section "Module"
                      #	Load  "glx"
                      #	Load  "GLcore"
                      #	Load  "dri"
                      #	Load  "v4l"
                      Section "InputDevice"
                      	Identifier  "Generic Keyboard"
                      	Driver      "kbd"
                      	Option	    "CoreKeyboard"
                      	Option	    "XkbRules" "xorg"
                      	Option	    "XkbModel" "pc105"
                      	Option	    "XkbLayout" "us"
                      Section "InputDevice"
                      	Identifier  "Configured Mouse"
                      	Driver      "mouse"
                      	Option	    "CorePointer"
                      	Option	    "Device" "/dev/input/mice"
                      	Option	    "Protocol" "ImPS/2"
                      	Option	    "ZAxisMapping" "4 5"
                      	Option	    "Emulate3Buttons" "true"
                      Section "InputDevice"
                      	Identifier  "stylus"
                      	Driver      "wacom"
                      	Option	    "Device" "/dev/input/wacom"
                      	Option	    "Type" "stylus"
                      	Option	    "ForceDevice" "ISDV4"# Tablet PC ONLY
                      Section "InputDevice"
                      	Identifier  "eraser"
                      	Driver      "wacom"
                      	Option	    "Device" "/dev/input/wacom"
                      	Option	    "Type" "eraser"
                      	Option	    "ForceDevice" "ISDV4"# Tablet PC ONLY
                      Section "InputDevice"
                      	Identifier  "cursor"
                      	Driver      "wacom"
                      	Option	    "Device" "/dev/input/wacom"
                      	Option	    "Type" "cursor"
                      	Option	    "ForceDevice" "ISDV4"# Tablet PC ONLY
                      Section "Monitor"
                      	Identifier   "aticonfig-Monitor[0]"
                      	Option	    "VendorName" "ATI Proprietary Driver"
                      	Option	    "ModelName" "Generic Autodetecting Monitor"
                      	Option	    "DPMS" "true"
                      Section "Device"
                      	Identifier  "aticonfig-Device[0]"
                      #	Driver      "ati"
                      	BusID	"PCI:1:0:0"
                      	Driver	"fglrx"
                      #	Option          "AccelMethod"   "EXA"
                      	Option		"NoDRI"
                      #	Option "TexturedVideoSync" "on"
                      #	Option "TexturedVideo" "on"
                      #	Option "OpenGLOverlay" "off"
                      #	Option "VideoOverlay" "off"
                      #	Option "XaaNoOffscreenPixmaps" "1"
                      Section "Screen"
                      	Identifier "aticonfig-Screen[0]"
                      	Device     "aticonfig-Device[0]"
                      	Monitor    "aticonfig-Monitor[0]"
                      	DefaultDepth     24
                      	SubSection "Display"
                      		Viewport   0 0
                      		Depth     24
                      Section "DRI"
                      	Mode         0666
                      Section "Extensions"
                      	Option	    "Composite" "Disable"
                      nodri en no composite is for testing..

                      But for now i will stay at the OSS driver with 3d. (the former fglrx had also problems on my system, that is why I gave it a try).
                      Last edited by allartk; 05-29-2008, 07:55 AM.