Announcement

Collapse
No announcement yet.

FPS capped on Linux (AMD fglrx drivers)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • FPS capped on Linux (AMD fglrx drivers)

    Recently I bought AMD R9 270X 4GB Graphics card after my old card died.

    I checked various benchmarks for this card on Linux before buying, I know Nvidia has much better drivers (but most of my Linux use is development oriented)
    I was expecting stable 60 FPS, on games like Dota 2, CS:GO, Civ 5, Kerbal Space Program or War Thunder.
    But somehow I'm getting extremely unstable FPS limited around 30, few spikes will go up to 60..

    Turning vsync on or off doesn't have any significant effect... I tried it on various distros, and different versions of drivers.

    Currently I'm using Ubuntu 14.04 and latest Catalyst 14.12, but the issue remains.

    Is anyone else facing the same issue?

  • #2
    Do you know the difference between double and triple buffering when vsync is enabled? Also fglrx is the biggest crap possible for source engine (all new valve games). Best: return the card.

    Comment


    • #3
      Are you sure you're using Catalyst and the installation didn't fail? If you are, what performance do you get with open source drivers?

      Comment


      • #4
        Originally posted by Kano View Post
        Do you know the difference between double and triple buffering when vsync is enabled? Also fglrx is the biggest crap possible for source engine (all new valve games). Best: return the card.
        Well, I'm not disappointed with the card.. I got it for $170 and it can run FarCry 4, Shadow of Mordor on pretty high specs without a flicker.. I'm just finding a way that will keep me from rebooting my machine for a few turns or rounds of games.

        Originally posted by eydee View Post
        Are you sure you're using Catalyst and the installation didn't fail? If you are, what performance do you get with open source drivers?
        Installation seems fine, I got a bit less of fps drops on open source drivers.. but it still wasn't up to the mark and some games had artifacts and bugged out textures and particles.

        Comment


        • #5
          Originally posted by Kano View Post
          Do you know the difference between double and triple buffering when vsync is enabled? Also fglrx is the biggest crap possible for source engine (all new valve games). Best: return the card.
          Well, first of all.. I'm not disappointed with the card, I got it for $170 and it can easily run FarCry 4, Shadow of Mordor on high+ without a flicker... I'm only looking for a way to avoid rebooting my PC for few turns or rounds of games.

          Originally posted by eydee View Post
          Are you sure you're using Catalyst and the installation didn't fail? If you are, what performance do you get with open source drivers?
          Catalyst installation is successful.. I tried open source drivers as well, They give less violent flickers but average FPS ins't up to the mark.. and usually have buggy textures, particle effects.

          Comment


          • #6
            That sounds quite strange, if you can't go above 60fps that sounds like vsync enabled and/or you might have Tear Free option enabled.

            Turning vsync on or off doesn't have any significant effect...
            Last edited by dungeon; 12-19-2014, 10:53 AM.

            Comment


            • #7
              Originally posted by PizzaCat View Post
              I'm only looking for a way to avoid rebooting my PC for few turns or rounds of games.
              I imagine it's not the case, but you could double check the cooling is clean and working fine, and keep an eye on the temps and freqs with
              Code:
              sudo aticonfig --odgc; sudo aticonfig --odgt;
              My 8970M got dusty fins after a couple trips and two things were happening: it would overheat when playing and subsequently was set to the lowest speed until the next reboot.

              It still drops to 30 on busy tank maps on War Thunder and antialiasing is a mess, tho.

              Comment


              • #8
                Originally posted by dungeon View Post
                That sounds quite strange, if you can't go above 60fps that sounds like vsync enabled and/or you might have Tear Free option enabled.
                It's not like it never goes above 60.. If I turn of Tear Free from CCC and then disable vsync in the game as well, sometimes it spikes up 120 causing screen tearing.. then next second it drops to 15-20.

                Originally posted by SpaceJunk View Post
                I imagine it's not the case, but you could double check the cooling is clean and working fine, and keep an eye on the temps and freqs with
                Code:
                sudo aticonfig --odgc; sudo aticonfig --odgt;
                My 8970M got dusty fins after a couple trips and two things were happening: it would overheat when playing and subsequently was set to the lowest speed until the next reboot.

                It still drops to 30 on busy tank maps on War Thunder and antialiasing is a mess, tho.
                My temperatures are totally fine, on idle it's about 32-36 C, while in-game it's about 45C-50C, The issue being that GPU is not utilized.. I get 40C while playing Civ 5 on Linux (maxed out settings), Since it's turn-based I didn't even notice I had FPS issue on that game.. While playing on Windows temperature goes upto 55C maxed out settings but stable 60 fps.

                I also compared frequency and found out somehow it's capped on Linux.. upto 300-450.. On Windows it goes upto 1070.

                Comment


                • #9
                  Originally posted by PizzaCat View Post
                  I also compared frequency and found out somehow it's capped on Linux.. upto 300-450.. On Windows it goes upto 1070.
                  It's only capped on fgl_glxgears..
                  Code:
                  Default Adapter - Supported device 6810
                                              Core (MHz)    Memory (MHz)
                             Current Clocks :    450           1400
                               Current Peak :    1070           1400
                    Configurable Peak Range : [300-1400]     [150-1625]
                                   GPU load :    24%
                  
                  Default Adapter - Supported device 6810
                                    Sensor 0: Temperature - 35.00 C

                  When I'm in game it's 1070 .. but the GPU load is stuck at low.
                  Code:
                  Default Adapter - Supported device 6810
                                              Core (MHz)    Memory (MHz)
                             Current Clocks :    1070           1400
                               Current Peak :    1070           1400
                    Configurable Peak Range : [300-1400]     [150-1625]
                                   GPU load :    20%
                  
                  Default Adapter - Supported device 6810
                                    Sensor 0: Temperature - 42.00 C

                  Comment


                  • #10
                    I also compared frequency and found out somehow it's capped on Linux.. upto 300-450.. On Windows it goes upto 1070.
                    CCC shows 1070 there, but those clocks changes dinamicaly. If 3D is not used it is at minimum, try runing glxgears in console for example and while it running recheck current clocks.

                    Do you have AMD CPU maybe? You might try to set cpufreq to performance, that can be awfull sometimes... slowing down things for drivers in some cases (usually minus 18%) and can made render stuttering so fps rate goes down even more.

                    Comment

                    Working...
                    X