No announcement yet.

ubuntu 7.10 Dell latitude D531 lcd projector

  • Filter
  • Time
  • Show
Clear All
new posts

  • ubuntu 7.10 Dell latitude D531 lcd projector

    I am running ubuntu Gutsy (7.10) on a Dell Latitude D531 with "an integrated ATI Radeon X1270 graphics processor". I have installed the fglx driver with the restricted drivers management option of ubuntu. All known problems are solved but one: I cannot get an external lcd projector (for presentations) to work off the standard 15 pin cable. It works in VISTA (sigh :-) and when running from the live ubuntu starter CD (before installing the system -- Fn-F8 acts as a simple toggle between the laptop screen and the external lcd projector). However once the system is installed, either with or without the fglx driver, Fn-F8 no longer seems to do anything. If I restart x/gnome with a CTL-ALT-backspace and/or reboot the system with the lcd projector on and cabled, both screens go blank (at least they are mirrored ! Does anyone have any suggestions?

  • #2
    S-Video works

    Updating my own post. At the suggestion of a friend, I tried the S-Video port as a way to connect to the lcd projector. It works just fine.


    • #3
      I'm not sure what forays anyone has made into the Fn-F8 thing (if indeed it does work on the LiveCD that is something!) but as for the display-switching anyway, have you tried the catalyst control centre, or possibly xrandr if using an open-source driver?


      • #4
        using fglx

        I plead ignorance about the catalyst control center, but will do some web searching to bring myself up to speed. As I want to be able to show ubuntu at its best, with the rotating cube in action, I am using the fglx driver from ati. Hence the post in this forum. I also am ignorant about xrandr, but will again do some reading.

        Thanks for your interest in this problem. I would really like to find a nice solution.


        • #5
          partial workaround? D531 laptop ati X1200

          Recent work tracking down why virtual consoles don't work in ubuntu 7.10 on my Dell D531 laptop (CTL-ALT-F1) had me unblacklist some frame buffer stuff (see posting on

          Now, it appears that the external VGA port on the laptop works if I connect a device before booting up. I would still like to understand aticonfig, and if the recent driver 8.01 has any bearing on this problem. Any and all suggestions are most welcome.


          • #6
            need an engineers input!

            my last post may be misleading. I can confirm that a 'passive' lcd screen, that is a screen taken off another computer system I have and simply plugged into the vga port on my Dell D531 laptop, works. However, the SONY lcd projector, which 'autoscans' for input from the computer -- does not. That is, it does not work under ubuntu linux with the ati driver. However, that same lcd projector works just fine on the same laptop under (shudder) VISTA. What is the difference? What does the lcd projector look for that the simple lcd screen does not? Also, note that this may have nothing to do with frame buffer changes as suggested by my previous post.