Announcement

Collapse
No announcement yet.

AMD Quietly Releases Catalyst 14.8 Linux Driver

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • AMD Quietly Releases Catalyst 14.8 Linux Driver

    Phoronix: AMD Quietly Releases Catalyst 14.8 Linux Driver

    At the end of last week AMD quietly released the Catalyst 14.8 binary driver for Linux that went unnoticed until now...

    http://www.phoronix.com/vr.php?view=MTc2MzM

  • #2
    I hope it actually works, I've mostly dumped AMD for nVidia over their Linux, and Windows, drivers.

    Radeonsi works great for everything but games

    Comment


    • #3
      Originally posted by Britoid View Post
      I hope it actually works, I've mostly dumped AMD for nVidia over their Linux, and Windows, drivers.

      Radeonsi works great for everything but games
      Don't get your hopes too high for this particular driver, as it says "embedded".

      Comment


      • #4
        Take care i'm pretty sure this driver is for embedded graphics only.

        E8860
        E6760
        E6460
        R-Series 2nd Gen formally codenamed ?Bald Eagle?
        R-Series 1st Gen formally codenamed ?eTrinity?
        G-Series SOC
        G-Series
        Radeon HD 6970M
        Radeon HD5770

        Comment


        • #5
          I've dumped catalyst for the free radeon driver. It's still an old 6870, so it's actually quite nice and only a little slower than catalyst in most cases AFAICT. It definitely helps if you want things to just work (TM).

          Now I'm waiting for radeonsi to get some serious performance tuning before I buy a new card. If they don't manage to do that within ~1year I'll consider buying nvidia this time, as I plan to get new mobo+cpu+ram+gpu (probably need a silent replacement for my 5 years old power supply that is a little noisy) after Broadwell or Skylake are released (not sure if I'm going to wait for Skylake). I hope the radeon situation improves, because I love having no headaches with proprietary driver updates etc. I know that is supposed to be easier with nvidia compared to catalyst.

          Comment


          • #6
            That's not the Catalyst 14.8, it's the embedded version of the 14.6.

            Comment


            • #7
              You keep saying it doesn't work with 3.16 but back to 14.6 does on my arch setup...

              Comment


              • #8
                Still no E8860 support

                I tried Catalyst 14.8 for Linux yesterday, in the hope that it would finally add support for the newish Radeon E8860 Embedded GPU.

                Alas not.

                Comment


                • #9
                  this is a new catalyst or not?

                  Comment


                  • #10
                    Originally posted by chris200x9 View Post
                    You keep saying it doesn't work with 3.16 but back to 14.6 does on my arch setup...
                    Are you compiling the driver as-is from AMD, or using the fglrx package in the AUR? I'm almost certain the package maintainer does a patch to allow it to work on newer kernels, and such a patch can also be done for any other distro.

                    It's the plain package from AMD (unmodified) that doesn't work on kernels higher than 3.14 I think.

                    Comment

                    Working...
                    X