No announcement yet.

Fglrx 8.43 : have OGL... but not 3D?

  • Filter
  • Time
  • Show
Clear All
new posts

  • Fglrx 8.43 : have OGL... but not 3D?

    Copied from here:

    okay, based on the post asking about how to enable ATi's extensions because some seemed to be missing... I just ran Cedega's system tools on an HD 2600, x1900, and an x1800. On all 3, while I'm showing OpenGL Direct Rendering is operational... 3D Acceleration is failing.

    I did a quick dpkg-reconfigure on the x1900, and got the same result. OpenGL DRI works... 3D acceleration doesn't.

    I'm not sure if this is an error with the Mepis driver installs or not. Another Linux install on the HD 2600 (OpenSuse if you really wanted to know) is showing no problems with 3D acceleration.

    I have been able to duplicate the artifacts being reported in other threads on the x1800. As Snowmover reported, installing the catalyst control center and forcing it to "identify" displays fixes the artifacts.
    SV : here's the thing. I use Cedega lot for CoH... and I couldn't tell a bloody difference between the 8.40 driver and the 8.43 driver. My OGL screen-saver also worked properly. So... as far as I could tell, everything "seemed" to be working after the driver install. The Fglrx control center indicated that the fglrx driver was installed and working properly, with no Mesa malarkey.

    So... I'm a little embarrassed to only now go "hey, somebody's right, something is screwy here"

    Edit: okay, next troubleshooting step I've taken is to remove the SMP kernel module. Fglrx control center now shows that the system is running under Mesa3D. Cedega now reports I have 3D acceleration... but OpenGL acceleration fails.


    edit : next update: used synaptic to reload the smp kernel module. Rebooted, checked Fglrx control Center. It showed that the fglrx driver was loaded. Checked Cedega. Again, OpenGL works, 3d acceleration reported broken.

    Used Mepis X-Assistant to force vesa driver. Rebooted, got text login. went through dpkg-reconfigure xserver-xorg forcing vesa as driver. Loaded into X, checked Fglrx Control Center. It will not start as the fglrx driver is not present. Deleted /etc/ATi



    Okay, on the reboot, used Mepis X Assistant to install the fglrx driver. No issues reported. Rebooted again.

    Checked fglrx control center, and it states the fglrx driver is not loaded. Check Synaptic, and the fglrx driver and kernel module are present. Use Mepis X Assistant again and reboot.

    Fglrx control center reports the driver still has not been loaded. Force with dpkg-reconfigure xserver-xorg. Reboot and Fglrx control center says the Fglrx driver is loaded. Check Cedega... still no 3D acceleration.


    Okay... I'm honestly not sure what's errored, but something in the Mepis Setup works. I know the driver itself works because I've got it running on another distribution on the same hardware. Part of me wondered if it was related to the older 8.40 profile, but removing the /etc/ATi entry should have cleared that as a potential problem.

    So... if you have an ATi card... sit tight.

    So, appearently clearing and configuring the drivers didn't seem to change anything... so now I'm trying to figure out if this is actually a problem with the driver, with the kernel module... or what...

    and I have no idea what steps to take from here for troubleshooting.