No announcement yet.

3D acceleration freezes PC with 8.43.2 drivers

  • Filter
  • Time
  • Show
Clear All
new posts

  • 3D acceleration freezes PC with 8.43.2 drivers

    I have a Sapphire ATI9600 Pro graphics card
    and I am experiencing problems using it under openSUSE10.3.

    I installed the system with its graphic (MESA) drivers and
    everything went fine, including 3D acceleration.
    I turned-on 3D acceleration during the installation procedure
    and applications using it (games such Xmoto, Chromium, Briquolo etc.)
    run without problem.
    I installed ATI proprietary drivers, after, using the rpm method/generation
    for openSUSE 10.3 and the usual rpm -ivh fglrx.... afterward.
    The version of these should be the 8.43.2, which should be the latest,
    at the moment of writing.
    Everything went fine (i.e. no error messages resulted from installation procedure).
    Configuration via sax2 -r -m 0=fglrx was also successful.
    The sax2 graphical interface gave the card without 3D acceleration (ghost)
    but this is a known issue as it is written within ATI drivers acompanying documentation.
    Test with glxinfo and fglrxinfo gave the 3D acceleration working properly,
    i.e. the reported openGL dirvers are all by ATI (not MESA anymore).
    The system also run without problems for everything but the aforementioned
    games. The (strange) behaviour I observe when I launch one of the above applications
    (games) is a computer freeze almost complete. I say almost because the mouse
    pointer is still alive, i.e. if I move mouse around the arrow pointer on the screen
    follows it, but except for this aspect everything else on my computer appear to be frozen,
    including the graphs of system performances that suddenly stops whenever I launch for
    example Xmoto.


    Processor : AMD Athlon XP2800 (32 bit processor).
    Video Card : Sapphire Radeon 9600 Pro (256MB of memory).
    Motherboard: ASROCK KTVT4-4x, chipset VIA KT400.
    Memory : 2 Banks of 1 GB each DDR400.

    Any help is appreciated, thanks!

  • #2
    ATI 7.11 CC problem "solved"

    Hello, I opst here the workaround I found for my own problem, in case some other experiences the same fault.
    Reverting to old 8.40.4 drivers worked for me.
    There are a coupke of hangs with Xmoto but I think that
    is something I can live with.