No announcement yet.

AGP PCI-E Issues (Rialto chip) No Interupt (IRQ) assigned, Poor performance.

  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Originally posted by Crunchy View Post
    I'd interpret this as saying that the IRQ manager is disabled till full MTRR support is written.
    My take on this is that fglrx can't handle the certain type of GART memory (cacheable memory).
    I disabled the MTRR register that should've been used for the AGP apeture but it wasn't recreated when I launched X as I would expect. Here's what I did:

    > cat /proc/mtrr
    reg00: base=0x00000000 (   0MB), size=1024MB: write-back, count=1
    reg01: base=0xe0000000 (3584MB), size= 256MB: write-combining, count=1
    reg01 is the area that should be used for the AGP apeture. So I disable it:

    > echo "disable=1" >| /proc/mtrr
    > cat /proc/mtrr
    reg00: base=0x00000000 (   0MB), size=1024MB: write-back, count=1
    I'd suggest making the AGP area uncacheable by running
    echo "base=0xe0000000 size=0x10000000 type=uncachable" >! /proc/mtrr
    Last edited by figvam; 11-27-2007, 02:53 AM.


    • #12
      nice try, but it looks like that the ati-devs made no function to check if the gartmem is cacheable or not, they simply disabled the irq manager in the case of a rialto-based card + cacheable agp memory( some sort of default )
      somebody want to hex the conditional-function?

      I begin to think that reversing this shit is way faster than the developement process


      • #13
        Scrap what I wrote above about setting memory ranges via MTRR. I got my hands on x1950Pro and tried my idea - it doesn't work.


        • #14
          Committed the bug to the bugzilla to write it in stone!

          bug #914

          I don't expect/want this discussion to move overthere, but those registered to the bugzilla may wanna simply confirm it or something. The big does link to here aswell to keep discussion here.


          • #15
            As i already wrote on the previous topic, i've exactly the same trouble with 'Sapphire Radeon HD 2600 XT AGP 256Mo' on on Fedora 7 (x86_64) and Catalyst Linux 7.11.


            • #16
              Originally posted by Kitof View Post
              As i already wrote on the previous topic, i've exactly the same trouble with 'Sapphire Radeon HD 2600 XT AGP 256Mo' on on Fedora 7 (x86_64) and Catalyst Linux 7.11.
              As it's a PCI-E chip on a AGP card it has the realto chip, which is really the cause of this problem (not the chip just the PCI-E -> agp bridge in the driver).

              Thanks for joining our cause though the more complaining the better.


              • #17
                I'll post my test results tomorrow on the bugtracker... i've still the feeling that this won't help much, but what other things can we do?

       the code and let us do the work ;-)


                • #18
                  Oliver wrote:

                  "So instead of mindlessly complaining, I put back my old old 9500Pro AGP thatI borrowed my brother (his own was being RMAed) and I tried that one out with 8.42.3"

                  And I bought one of those. The Horror.

                  I get the same interrupt error on my X1950 pro in PCL2007. The latest 7-11 driver enables me to activate direct rendering (other drivers wouldn't) as confirmed by glxinfo, but when I run fgl_glxgears or an opengl screen saver, I get a black screen.

                  Hunting around, I found references to the NForce3 nvidia mobo agp chip. Does everyone here use that? Tried flashing my K8NS Ultra-939 from v5 to v6, with no effect.

                  Would sure be nice to have this card working as well in linux as in Windows 2000. I'm tempted to ask a dozen questions about how best to choose MPlayer video drivers and other stuff to get the best performance, but I'll read the X manpages first.

                  Know any good faq's on the AGP and "GART" stuff? All this stuff is still swirling around in my tiny little mind. XGL, GLX, DRI, GART, Xv, DRM...The Horror...


                  • #19
                    You need to set you AGP apeture to at least 256MB to remove the black screen problem.

                    I have an nForce3 too but others have the same problems with Via boards too.


                    • #20
                      Thanks Crunchy, it works! I'm getting several thousand rather than several hundred in fgl_/glxgears, and the opengl screen savers have much better fps. But when I try running Beryl, the cube-sides are white and my machine locks if I try the 3-finger Ctrl-Alt-Bkspc escape from X.

                      I tried "AGPSize" and "GARTSize" xorg.conf device options to no effect, got log warnings that they're "not used". So I googled around and discovered my bios has a hidden Cntrl-F1 for a menu with AGP aperture settings! I'd like to NEMP the ass of the moron that hid that menu. Had other settings too.

                      I found wikipedia articles for all the basic, obscure X acronyms, AGP & GART.

                      I still get that interrupt error though. Is that why my card locks when I try to leave X? What's the interrupt for? Does not caching cause a performance loss?