No announcement yet.

ATI Mobility X1700 with FC6

  • Filter
  • Time
  • Show
Clear All
new posts

  • ATI Mobility X1700 with FC6


    Im using ATI Mobility X1700 with FC6 and was trying those ATI installer 8.29 8.30.3 but none is working. I understand that those driver are not support X1700. Is there any driver(better resolution/3D) that i can use on FC6?



  • #2
    The Mobility X1700 should be supported. The MOBILITY RADEON X1700 (M66-XT 71D6) and MOBILITY RADEON X1700 (M66-P 71D5) are supported by fglrx.

    So the driver installs but you aren't able to load the module or where exactly are you running into problems?
    Michael Larabel


    • #3
      Thanks for the quick reply

      I used your the script on 8.29/8.28 which give me rpm build fail, bad exit status from /tmp/..., and i tried to --buildpkg Fedora/FC6 it doesnt work either

      then i made a clean install again without kernel update this time, ty to use 8.29 and i has the same error. By using the 8.30.3 with --buildpkg Fedora/FC6 it gave me 4 rpm packages. and i used rpm -Uvh to install one by one, and did a aticonfig --initial.

      After reboot, my laptop just give me a blank screen and i managered to login using Single mode and i replace the xorg.cong with the sample xorg-fc6-sample.conf and reboot, it still gave me a blank screen

      By tailing the log/Xorg.0.log
      I found an EE

      EE chipset is not recognized

      I have removed those ATI rpm on single mode and get back here, and Now i can use your script to make rpm successful on 8.29, and will give it a try!


      • #4
        If you continue to run into problems, let me know. By chance your PCI ID for your specific X1700 model could be missing from the drivers. and if so I will check with ATI/AMD about that.
        Michael Larabel


        • #5

          Im back this time using 8.29, with
          aticonfig --initial --input=/etc/X11/xorg.conf

          no more blank screen. however i check the Xorg.0.log

          EE AIGLX:Screen 0 is not DRI capable

          only 1024x768, nothing change from original vesa

          Then i replace the xorg.conf with xorg-fc6-sample.conf

          do an init 3 then 5, now i have 1280x800 but have the following EE

          (EE) AIGLX error: dlsym for __driCreateNewScreen_20050727 failed (/usr/lib/dri/f
 undefined symbol: __driCreateNewScreen_20050727)
          (EE) AIGLX: reverting to software rendering

          [[email protected] ~]# fglrxinfo
          display: :0.0 screen: 0
          OpenGL vendor string: ATI Technologies Inc.
          OpenGL renderer string: Generics
          OpenGL version string: 2.0.6065 (8.29.6)



          • #6
            AIGLX (e.g. Fedora Desktop Effects) are not currently supported by the fglrx display drivers.
            Michael Larabel