No announcement yet.

xorg, ati r200 free driver, suddenly no hardware acceleration

  • Filter
  • Time
  • Show
Clear All
new posts

  • xorg, ati r200 free driver, suddenly no hardware acceleration

    Hardware acceleration seems to be completely gone from one day to another. It was working ok and today I noticed it isn't anymore. I'm using radeon r200 free driver.

    [[email protected] ~]$ $ glxgears -info
    GL_RENDERER = Mesa GLX Indirect
    GL_VERSION = 1.2 (1.5 Mesa 6.5.1)
    GL_VENDOR = Mesa project: (...)

    I tried to delete xorg.conf and restart X, but the situation didn't changed. system-config-display couldn't help also, but it correctly reports my card as Radeon 9200 SE. I don't have any idea why this is happening since it was working before.

    Here goes my xorg.conf. I'd appreciate if someone could compare with his own copy to see if mine is lacking something:

    [[email protected] X11]# cat xorg.conf
    # Xorg configuration created by system-config-display

    Section "ServerLayout"
    Identifier "single head configuration"
    Screen 0 "Screen0" 0 0
    InputDevice "Keyboard0" "CoreKeyboard"

    Section "InputDevice"
    Identifier "Keyboard0"
    Driver "kbd"
    Option "XkbModel" "abnt2"
    Option "XkbLayout" "br"

    Section "Device"
    Identifier "Videocard0"
    Driver "radeon"

    Section "Screen"
    Identifier "Screen0"
    Device "Videocard0"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    Modes "1152x864" "1152x864" "1152x768" "1152x768" "1024x768" "1024x768" "800x600" "800x600" "640x480" "640x480"
    SubSection "Display"
    Viewport 0 0
    Depth 16
    Modes "1152x864" "1152x864" "1152x768" "1152x768" "1024x768" "1024x768" "800x600" "800x600" "640x480" "640x480"

    From my /var/log/Xorg.0.log:

    (WW) RADEON(0): [agp] AGP not available
    (EE) RADEON(0): [agp] AGP failed to initialize. Disabling the DRI.
    (II) RADEON(0): [agp] You may want to make sure the agpgart kernel module is loaded before the radeon kernel module. (...)

    Any ideas?
    Last edited by pmatiello; 11-18-2006, 08:47 PM.

  • #2
    Just to make sure, you are wanting to use the open-source Radeon drivers, correct? (And not the proprietary fglrx drivers).

    Had you tried specifying any additional options for your config (see here)?
    Michael Larabel


    • #3
      Yes, I want the open source drivers.

      I tried enabling dri by hand editing xorg.conf, but I got the same results. Seems like there's some problem with agp; maybe a kernel update broke something?

      I'll keep trying; thanks for the help.


      • #4
        A kernel update shouldn't have broken it for the open-source drivers.

        The options I was referring to were mainly with the xorg.conf AGP options.
        Michael Larabel


        • #5
          I understand, but xorg options didn't help. :/
          Last edited by pmatiello; 11-19-2006, 12:09 AM.


          • #6
            Some more information:

            [[email protected] ~]$ dmesg |grep drm
            [drm] Initialized drm 1.0.1 20051102
            [drm] Initialized radeon 1.25.0 20060524 on minor 0
            [drm:radeon_cp_init] *ERROR* radeon_cp_init called without lock held
            [drm:drm_unlock] *ERROR* Process 2470 using kernel context 0
            [drm:radeon_cp_init] *ERROR* radeon_cp_init called without lock held
            [drm:drm_unlock] *ERROR* Process 2914 using kernel context 0

            Google says it happens when radeon driver is loaded before agpgart.


            • #7
              I did it!

              I booted with a xen-enabled kernel and it worked. I guess it's because I was using a xen kernel before and the system has configured itself to it, but something broke when I started using non-xen kernels beceuse mono would segfault under them.

              Now, mono works under the new xen-kernel and dri too.