Announcement

Collapse
No announcement yet.

Any World of Warcraft / Wine successes with 8.42.3?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • chrisr
    started a topic Any World of Warcraft / Wine successes with 8.42.3?

    Any World of Warcraft / Wine successes with 8.42.3?

    Previous versions of fglrx ran World of Warcraft's login screens fine, but then crashed when I tried to enter the Realm. However, 8.42.3 just gives me a blank black window and nothing else (apart from music...).

    Does anyone have any Warcraft success stories to share, please?

  • Spydr4590
    replied
    I thought I would bump this with the working guide I made for 7.12 driver install of ATI.

    Leave a comment:


  • teroedni
    replied
    I found some important settings that may help us when it comes to wow crashes

    in the device section put

    Option "Capabilities" "0x00000800"
    Option "UseFastTLS" "off"
    Option "KernelModuleParm" "locked-userpages=0"

    Leave a comment:


  • krnlg
    replied
    Well its not the memory leak issue, because although it does consume more and more memory for me, I think it would probably crash after maybe an hour or so rather than a few minutes or (sometimes) less; it doesn't run for long enough to use all my RAM.

    *sigh* running a 64-bit system can cause so many niggling issues it seems.
    A google search on that error message (well the first part of it) turns up about 5 results, only one of them in english, which was talking about a different application under Wine.

    Hopefully the new version will work but even so, this new driver series is a big improvement performance-wise at least.

    no-one else with any information?

    Leave a comment:


  • oliver
    replied
    64 bit may be your problem then mostlikly. Or your having serious memleak issues, as the 7.11 is known to be leaking memory.

    For me, I can play it hours uppon hours. Though some water parts do make it crash (the little pool with the two fishies before the wailing cavern instance, took me 6 reboots to get out of the water, and then went on again for hours without a hitch.)

    Leave a comment:


  • krnlg
    replied
    I'm using a PCI-E Radeon X1650 on a 64-bit platform and with the new drivers (having tried 7.11 and 8.42.3) Warcraft runs with noticably improved FPS when I disable shaders, however it likes to randomly crash with loads of this error output to the terminal:

    fixme:dbghelp_dwarf:dwarf2_parse_udt_type Unhandled Tag type 0x2e at ctx(0x328b68,L"fglrx_dri.so"), for debug_info(abbrev:0x5bf01b8,symt:0x5c04074)

    before doing a traceback.

    I've tried various other versions of Wine all with the same result.

    The frustrating thing is that I get the nicely improved fps for random periods of time before it crashes, and then I have to go back to the old, slow drivers and cry..
    I've tried both amd64 and i386 wine packages with the same result; is this something specific to these drivers with 64-bit?

    Has anyone else had this problem?

    I should add that I'm running Debian Etch (for the most part) which uses Xorg 7.1.
    Last edited by krnlg; 12-14-2007, 05:47 AM.

    Leave a comment:


  • oliver
    replied
    Originally posted by Tsume View Post
    Same story here and I'm on 7.11

    Lucky I found this post or it would never ever ever run.

    Ubuntu 7.10 (Gutsy) w/ Wine 0.9.50 and Catalyst 7.11
    didn't do any of that shader stuff, only the opengl thing in the registry, but had that for ages. After loging in and stuff successfully it's all fine

    i'm having some graphical glitches on the menuscreen etc (not after a fresh reboot however) lik ehalf the screen being renderd, textures missing, but it's all fine in game. I HAVE noticed that when i lgo in a toon WITHOUT ct_viewport mod (set to something a little smaller, i hide the bottom where the buttons are) it's all fine, but do have the half screen being drawn with the toon though. I blame the addon itself, as i doubt a vanilla addonless game would have that bug, but if you have only half a screen drawn INgame, try gettind ct_viewport mod and change the size of your viewport (you do need ct_core with it to configure it)

    Leave a comment:


  • Tsume
    replied
    Originally posted by chrisr View Post
    So I get a completely black screen if I have

    SET pixelShaders "1"

    and I get a corrupt / incompletely rendered screen if I have

    SET M2UseShaders "1"

    However, I can at least use

    SET M2UsePixelShaders "1"

    The game is also refusing to run for me in D3D mode, and I've needed to disable the GL_ARB_vertex_buffer_objects extension for OpenGL mode via the Wine registry.
    Same story here and I'm on 7.11

    Lucky I found this post or it would never ever ever run.

    Ubuntu 7.10 (Gutsy) w/ Wine 0.9.50 and Catalyst 7.11

    Leave a comment:


  • cjr2k3
    replied
    I tried that. No luck for me, the leak is associated with every frame rendered. I let glxgears running for 10~15min and when I got back I got full ram (1Gb) + swap full (3Gb)

    Waiting for 7.12, but 8.40 is fine anyway.

    Leave a comment:


  • oliver
    replied
    I had the same problem after installing 2.3. I just closed it out (via esc so it would resceive a proper quit) and restarted it and all was fine again.

    You may want to try logging in once via directx (omit the -opengl flag) so the new config settings are saved and then restart using the -opengl flag, works like a charm aswell.

    Leave a comment:

Working...
X