No announcement yet.

gutsy + BigDesktop (+8.42?)

  • Filter
  • Time
  • Show
Clear All
new posts

  • gutsy + BigDesktop (+8.42?)

    Hi folks,

    I must say I'm using fglrx quite a while now, but this is too much for me... A few days ago I reinstalled to gutsy (=2.6.22 kernel, 7.2, and now I can't make my BigDesktop configuration to work again...

    > Sorry for this: dammit! <

    Config: ATI X700 + laptop lcd (1400x1050) + external LCD (1680x1050)
    My wish: working bigdesktop at total resolution 3080x1050...

    What I managed is to get 2800x1050 and 3380x1050...

    Everytime I tried to switch (using KDE display configurator or xrandr) to 3080x1050, the fglrx throws an exception like this:
    0: /usr/bin/X(xf86SigHandler+0x81) [0x80c9581]
    1: [0xffffe420]
    2: /usr/lib/xorg/modules/drivers// [0xb7932e48]
    3: /usr/bin/X [0x8100483]
    4: /usr/bin/X [0x80d1893]
    5: /usr/bin/X(xf86SwitchMode+0xce) [0x80c64de]
    6: /usr/bin/X [0x80e98d2]
    7: /usr/bin/X [0x80e9bca]
    8: /usr/bin/X(RRCrtcSet+0x15c) [0x816f3cc]
    9: /usr/bin/X(ProcRRSetScreenConfig+0x4fa) [0x8173eda]
    10: /usr/bin/X [0x816dc95]
    11: /usr/bin/X [0x815754e]
    12: /usr/bin/X(Dispatch+0x1aa) [0x808f47a]
    13: /usr/bin/X(main+0x495) [0x8076f05]
    14: /lib/tls/i686/cmov/ [0xb7d6e050]
    15: /usr/bin/X(FontFileCompleteXLFD+0x1e1) [0x8076241]

    and game over...

    I'm pretty sure there won't be noone to help me out, though that I post also relevant part of my xorg.conf here:

    Section "ServerLayout"
    Identifier "Default Layout"
    Screen 0 "aticonfig-Screen[0]" 0 0
    InputDevice "Generic Keyboard"
    InputDevice "Configured Mouse"
    InputDevice "Synaptics Touchpad"

    Section "Files"

    Section "Module"
    Load "i2c"
    Load "bitmap"
    Load "ddc"
    Load "extmod"
    Load "freetype"
    Load "int10"
    Load "type1"
    Load "vbe"
    Load "glx"
    Load "dbe"
    Load "v4l"

    Section "Monitor"
    Identifier "Generic Monitor"
    Option "DPMS"

    Section "Monitor"
    Identifier "aticonfig-Monitor[0]"
    Option "VendorName" "ATI Proprietary Driver"
    Option "ModelName" "Generic Autodetecting Monitor"
    Option "DPMS" "true"

    Section "Device"
    Identifier "aticonfig-Device[0]"
    Driver "fglrx"
    Option "DesktopSetup" "horizontal"
    Option "VideoOverlay" "on"
    Option "OpenGLOverlay" "off"
    Option "EnablePrivateBackZ" "yes"
    Option "HSync2" "65"
    Option "VRefresh2" "60"
    Option "Mode2" "1680x1050"
    Option "DesktopSetup" "LVDS,AUTO"
    Option "PairModes" "1400x1050+1680x1050"

    Section "Screen"
    Identifier "aticonfig-Screen[0]"
    Device "aticonfig-Device[0]"
    Monitor "aticonfig-Monitor[0]"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    Modes "1680x1050" "1400x1050"
    Virtual 1680 1050

    Section "Extensions"
    option "Composite" "Disable"

    Section "DRI"
    # Group 0
    Mode 0666

    Without 'Virtual 1680 1050', the resolution is max. 2800x1050... The modes option doesn't affect anything, as far as I can tell...

    The most interesting thing is, that this configuration worked with any problems on Feisty... But I guess I'm not the first one with these problems :-(

    And the most strange thing is that my monitor shows, that it's using 1680x1050 (not 1400x1050 nor 1880x1050) - but maybe that's just shittyness of that monitor :-)

    I don't really give a crap about Compiz or what... I want functional desktop again - working BigDesktop, video playback, some normal opengl performance and suspend... Are ati guys really so damn lousy programmers that they break everything over again after one opengl rewrite? At least I know now, why they don't want to show their sourcecode... )

    And my last question: WHY DON'T THE ATI GUYS PROVIDE SOME DOCUMENTATION OF CONFIGURATION OF FGLRX? How the hell should even experienced user set up something, when all he can do is to do the 'try&mistake'...
    Last edited by andree182; 10-23-2007, 06:53 PM.

  • #2
    Problem solved... Moved to the open driver (ati) - and after a hour of configuring everything is workin' like I wanted - no screen corrupotion, no xserver restarts... bye bye binary world