Announcement

Collapse
No announcement yet.

Catalyst woes [FirePro 2270]

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • entropy
    started a topic Catalyst woes [FirePro 2270]

    Catalyst woes [FirePro 2270]

    I got a new Dell machine at work today which comes with an AMD FirePro 2270 (512 MB version).

    After installation of Catalyst 13.2 Beta 7 the fglrx kernel module loads properly
    but I'm ending up with this message using aticonfig:

    "aticonfig: No supported adapters detected"

    Any ideas?

    Don't tell me this card has already phased out to "legacy"... :/
    Last edited by entropy; 03-01-2013, 10:43 AM.

  • entropy
    replied
    Originally posted by Vim_User View Post
    The RV620 chip on that card is the same as on the HD34xx cards, so yes, AMD considers that to be legacy already.
    You either have to buy a newer card or use an older version of your distribution, since AMD thinks that using newer kernels/Xorg is not something you should do with your hardware.
    The card actually works with Catalyst 13.2 (non-legacy!).
    You simply can't run aticonfig as it exits with "aticonfig: No supported adapters detected".
    It works with Catalyst 13.2 and xserver 1.13 after creating an initial xorg.conf file
    with the aticonfig utility from the firepro drivers gradinaruvasile pointed me to.

    I doubt the ASIC is a HD3xxx but rather one of the lower end HD5xxx ASICs.
    Not sure though.

    Getting rid of the "unsupported watermark" was easy using Kano's script.
    Last edited by entropy; 03-02-2013, 06:51 PM.

    Leave a comment:


  • Vim_User
    replied
    Originally posted by entropy View Post
    Don't tell me this card has already phased out to "legacy"... :/
    The RV620 chip on that card is the same as on the HD34xx cards, so yes, AMD considers that to be legacy already.
    You either have to buy a newer card or use an older version of your distribution, since AMD thinks that using newer kernels/Xorg is not something you should do with your hardware.

    Leave a comment:


  • entropy
    replied
    Thanks!

    But does this page contain something helpful for my case?
    If so, I fail to see it.

    Leave a comment:


  • PeniWize
    replied
    It may be

    See: http://wiki.cchtml.com/index.php/Ubu...talyst.2Ffglrx

    Leave a comment:


  • entropy
    replied
    Originally posted by gradinaruvasile View Post
    Does the fglrx driver install and run?

    If you get the "unsupported hardware" logo, you could try this:

    http://phoronix.com/forums/showthrea...ware-watermark

    Aticonfig may not work correctly here and there for certain hardware, i got mine saying that my A8-5500's GPU runs at -14 C...
    What is important is if you have working opengl and stuff.
    Thank you!

    Catalyst 13.2 beta works fine.
    Only aticonfig refuses to work.
    Why is beyond me.

    Leave a comment:


  • gradinaruvasile
    replied
    Does the fglrx driver install and run?

    If you get the "unsupported hardware" logo, you could try this:

    http://phoronix.com/forums/showthrea...ware-watermark

    Aticonfig may not work correctly here and there for certain hardware, i got mine saying that my A8-5500's GPU runs at -14 C...
    What is important is if you have working opengl and stuff.
    Last edited by gradinaruvasile; 03-01-2013, 12:19 PM.

    Leave a comment:


  • entropy
    replied
    Originally posted by gradinaruvasile View Post
    There is a newer looking driver:

    step 1 -> Workstation Graphics
    step 2 -> FirePro Multiview series
    step 3 -> FirePro 2270
    step 4 -> whatever Linux architecture you have

    Maybe...
    Unfortunately, this driver from late December does definitely not support xserver 1.13.

    https://aur.archlinux.org/packages/catalyst-firepro/

    Leave a comment:


  • gradinaruvasile
    replied
    There is a newer looking driver:

    step 1 -> Workstation Graphics
    step 2 -> FirePro Multiview series
    step 3 -> FirePro 2270
    step 4 -> whatever Linux architecture you have

    Maybe...

    Leave a comment:


  • entropy
    replied
    Oh great, no xorg-server 1.13 support.

    Isn't there a way to run the standard Catalyst on those ASICs?
    I think I can do without the additional FireXXX features.

    Leave a comment:

Working...
X