No announcement yet.

AMD A10-5800K 3D Glitches Hardware or Drivers?

  • Filter
  • Time
  • Show
Clear All
new posts

  • AMD A10-5800K 3D Glitches Hardware or Drivers?

    Having some issues with a new set up. Example

    I tried out LM 14 Mate/KDE In KDE if I installed the Restricted drivers then Open Arena worked good but Nexuiz was still like the video. I tried 12.10/11 13.1 - same results.

    I have the set up listed below. I also have a second set up like this but with a A8-5600K CPU and AMD ram which is working good although it does have one of the glitches explained below.

    76269 AMD A10-5800K APU Quad Core Processor Socket FM2 3.8GHZ 4MB 100W Retail Box

    59977 G.SKILL F3-14900CL9D-8GBSR Sniper SE 8GB 2X4GB DDR3-1866 CL9-10-9-28 1.5V

    65701 Seagate Barracuda 1TB 7200RPM 64MB SATA 6Gbps 3.5in Internal Hard Drive

    66855 Thermaltake TR2 500W Power Supply Cable Management ATX12V V2.3 24PIN With 120mm Fa

    76851 MSI FM2-A75MA-E35 mATX FM2 A75 DDR3 1PCI-E16 2PCI-E1 1PCI SATA3 HDMI DVI USB3.0

    35507 Nmedia HTPC-5000B Desktop Media Centre Case mATX

    I also get white pixels on the screen especially around images or window borders. I have something similar on the A8 system but not too noticeable.

    Any ideas? My only other option is to take this box home and start swaping out parts and see what could be wrong.