Announcement

Collapse
No announcement yet.

AIGLX probs

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • hookooekoo
    started a topic AIGLX probs

    AIGLX probs

    I used the tutorial on the redblog.
    if all went well, on an i386 target there should be ATI-fglrx-8.29.6-1.fc6.i386.rpm, ATI-fglrx-control-panel-8.29.6-1.fc6.i386.rpm, ATI-fglrx-devel-8.29.6-1.fc6.i386.rpm, and kernel-module-ATI-fglrx-KERNEL-VERSION.fc6-8.29.6-1.fc6.i386.rpm in the working directory. These RPMs can then be installed. During the RPM install process it will run aticonfig --initial, but if this is a fresh FC6 install one more step is needed. Ensure that the below segment is found in /etc/X11/xorg.conf, otherwise Mesa will be used when restarting X. If this portion is not found in your X configuration, add it:
    The .rpm's did no download into the working directory. Is there a way to wget these? or other methods?

  • hookooekoo
    replied
    Originally posted by jonastio View Post
    FYI

    rpm -i is for install
    rpm -U is: Install if not already there or Update if a previous version exists.
    rpm -e/--erase will remove a package

    Lol, thx, been a long time since i used rpm commands

    Leave a comment:


  • jonastio
    replied
    Originally posted by hookooekoo View Post
    I installed the Livna packages with the the command

    Code:
    rpm -ivh http://rpm.livna.org/livna-release-6.rpm
    as posted above. Now I can't figure out how to remove it.

    the rpm -Uvh command is not working cause it can't find the package.

    Advice on removal? Thx
    FYI

    rpm -i is for install
    rpm -U is: Install if not already there or Update if a previous version exists.
    rpm -e/--erase will remove a package

    Leave a comment:


  • jonastio
    replied
    Originally posted by hookooekoo View Post
    I installed the Livna packages with the the command

    Code:
    rpm -ivh http://rpm.livna.org/livna-release-6.rpm
    as posted above. Now I can't figure out how to remove it.

    the rpm -Uvh command is not working cause it can't find the package.

    Code:
    [root@dh7c8rb1 ~]# whereis livna
    livna:
    [root@dh7c8rb1 ~]# whereis livna*
    livna*:
    [root@dh7c8rb1 ~]# whereis *livna*
    *livna*:
    [root@dh7c8rb1 ~]# rpm -Uvh rpm.livna-release-6-1
    error: open of rpm.livna-release-6-1 failed: No such file or directory
    [root@dh7c8rb1 ~]# rpm -Uvh rpm.livna-release-6-1.rpm
    error: open of rpm.livna-release-6-1.rpm failed: No such file or directory
    [root@dh7c8rb1 ~]# rpm -Uvh livna-release-6-1.rpm
    error: open of livna-release-6-1.rpm failed: No such file or directory
    [root@dh7c8rb1 ~]#
    Advice on removal? Thx
    rpm -e livna-release-6-1
    or yum erase livna-release*
    or if the rpm-e didn't work
    rpm -qa | grep livna
    and then rpm -e the line that shows up.

    Leave a comment:


  • Michael
    replied
    You can just set enabled=0 in /etc/yum.repos.d/livna.repo to disable.

    Leave a comment:


  • hookooekoo
    replied
    I installed the Livna packages with the the command

    Code:
    rpm -ivh http://rpm.livna.org/livna-release-6.rpm
    as posted above. Now I can't figure out how to remove it.

    the rpm -Uvh command is not working cause it can't find the package.

    Code:
    [root@dh7c8rb1 ~]# whereis livna
    livna:
    [root@dh7c8rb1 ~]# whereis livna*
    livna*:
    [root@dh7c8rb1 ~]# whereis *livna*
    *livna*:
    [root@dh7c8rb1 ~]# rpm -Uvh rpm.livna-release-6-1
    error: open of rpm.livna-release-6-1 failed: No such file or directory
    [root@dh7c8rb1 ~]# rpm -Uvh rpm.livna-release-6-1.rpm
    error: open of rpm.livna-release-6-1.rpm failed: No such file or directory
    [root@dh7c8rb1 ~]# rpm -Uvh livna-release-6-1.rpm
    error: open of livna-release-6-1.rpm failed: No such file or directory
    [root@dh7c8rb1 ~]#
    Advice on removal? Thx

    Leave a comment:


  • jonastio
    replied
    Originally posted by Michael View Post
    Also, if you are using the ATI installer you DO NOT need Livna packages... It defeats the entire purpose.
    They didn't work worth crap for me anyways.

    Leave a comment:


  • Michael
    replied
    Also, if you are using the ATI installer you DO NOT need Livna packages... It defeats the entire purpose.

    Leave a comment:


  • jonastio
    replied
    Originally posted by hookooekoo View Post
    I got tired of missing packages, so I installed all dev-tools.

    I also have linva installed, if this is the correct method.

    rpm -ivh http://rpm.livna.org/livna-release-6.rpm

    I am getting the following errors now.

    Code:
    Processing files: ATI-fglrx-8.30.3-1.fc6
    Provides: atiogl_a_dri.so config(ATI-fglrx) = 8.30.3-1.fc6 fglrx_dri.so fglrx_drv.so libGL.so.1 libfglrx_dm.so.1.0 libfglrx_gamma.so.1 libfglrx_pp.so.1.0 libfglrx_tvout.so.1 libfglrxdrm.so
    Requires(interp): /bin/sh /bin/sh /bin/sh
    Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
    Requires(post): /bin/sh /sbin/chkconfig /sbin/ldconfig
    Requires(preun): /bin/sh /sbin/chkconfig /sbin/service
    Requires(postun): /bin/sh /sbin/ldconfig /sbin/service
    Requires: /bin/bash /bin/sh config(ATI-fglrx) = 8.30.3-1.fc6 kernel-module-ATI-fglrx-2.6.18-1.2798.fc6 = 8.30.3-1.fc6 libGL.so.1 libX11.so.6 libXext.so.6 libXrandr.so.2 libXrender.so.1 libc.so.6 libc.so.6(GLIBC_2.0) libc.so.6(GLIBC_2.1) libc.so.6(GLIBC_2.1.3) libc.so.6(GLIBC_2.2.3) libdl.so.2 libdl.so.2(GLIBC_2.0) libdl.so.2(GLIBC_2.1) libfglrx_dm.so.1.0 libfglrx_gamma.so.1 libfglrx_pp.so.1.0 libfglrx_tvout.so.1 libgcc_s.so.1 libgcc_s.so.1(GCC_3.0) libgcc_s.so.1(GLIBC_2.0) libm.so.6 libm.so.6(GLIBC_2.0) libm.so.6(GLIBC_2.1) libpthread.so.0 libpthread.so.0(GLIBC_2.0) librt.so.1 librt.so.1(GLIBC_2.2) libstdc++.so.5 libstdc++.so.5(CXXABI_1.2) libstdc++.so.5(GLIBCPP_3.2) system-config-display
    Conflicts: fglrx fglrx-glc22 fglrx_4_3_0 fglrx_6_8_0 kernel-module-fglrx ati-fglrx ati-fglrx-devel kmod-fglrx xorg-x11-drv-fglrx xorg-x11-drv-fglrx-devel nvidia-glx nvidia-glx-legacy xorg-x11-drv-nvidia xorg-x11-drv-nvidia-legacy
    Processing files: ATI-fglrx-control-panel-8.30.3-1.fc6
    error: File not found: /tmp/ATI-fglrx-8.30.3-1-3168-root/tmp/ATI-fglrx-8.30.3-1.fc6-root-root/usr/bin/fireglcontrolpanel
    Processing files: ATI-fglrx-devel-8.30.3-1.fc6
    Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
    Requires: /usr/include/GL ATI-fglrx = 8.30.3-1.fc6 libGL.so.1
    Processing files: kernel-module-ATI-fglrx-2.6.18-1.2798.fc6-8.30.3-1.fc6
    Requires(interp): /bin/sh /bin/sh
    Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
    Requires(post): /bin/sh
    Requires(postun): /bin/sh
    Processing files: ATI-fglrx-debuginfo-8.30.3-1.fc6
    Provides: atiogl_a_dri.so.debug fglrx_dri.so.debug fglrx_drv.so.debug libGL.so.1.2.debug libfglrx_dm.so.1.0.debug libfglrx_gamma.so.1.0.debug libfglrx_pp.so.1.0.debug libfglrx_tvout.so.1.0.debug libfglrxdrm.so.debug
    Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
    
    
    RPM build errors:
        File not found: /tmp/ATI-fglrx-8.30.3-1-3168-root/tmp/ATI-fglrx-8.30.3-1.fc6-root-root/usr/bin/fireglcontrolpanel
    Removing temporary directory: fglrx-install
    If you go to thread http://www.phoronix.net/forums/showthread.php?t=318 That should get you somewhere. I had to link up a few libraries to the plain ol .so instead of the .so.1 crap, and show which ones I had to do in that thread. But, end result is that the drivers work, and I get full resolution (1920x1200) but no DRI.

    Leave a comment:


  • hookooekoo
    replied
    I got tired of missing packages, so I installed all dev-tools.

    I also have linva installed, if this is the correct method.

    rpm -ivh http://rpm.livna.org/livna-release-6.rpm

    I am getting the following errors now.

    Code:
    Processing files: ATI-fglrx-8.30.3-1.fc6
    Provides: atiogl_a_dri.so config(ATI-fglrx) = 8.30.3-1.fc6 fglrx_dri.so fglrx_drv.so libGL.so.1 libfglrx_dm.so.1.0 libfglrx_gamma.so.1 libfglrx_pp.so.1.0 libfglrx_tvout.so.1 libfglrxdrm.so
    Requires(interp): /bin/sh /bin/sh /bin/sh
    Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
    Requires(post): /bin/sh /sbin/chkconfig /sbin/ldconfig
    Requires(preun): /bin/sh /sbin/chkconfig /sbin/service
    Requires(postun): /bin/sh /sbin/ldconfig /sbin/service
    Requires: /bin/bash /bin/sh config(ATI-fglrx) = 8.30.3-1.fc6 kernel-module-ATI-fglrx-2.6.18-1.2798.fc6 = 8.30.3-1.fc6 libGL.so.1 libX11.so.6 libXext.so.6 libXrandr.so.2 libXrender.so.1 libc.so.6 libc.so.6(GLIBC_2.0) libc.so.6(GLIBC_2.1) libc.so.6(GLIBC_2.1.3) libc.so.6(GLIBC_2.2.3) libdl.so.2 libdl.so.2(GLIBC_2.0) libdl.so.2(GLIBC_2.1) libfglrx_dm.so.1.0 libfglrx_gamma.so.1 libfglrx_pp.so.1.0 libfglrx_tvout.so.1 libgcc_s.so.1 libgcc_s.so.1(GCC_3.0) libgcc_s.so.1(GLIBC_2.0) libm.so.6 libm.so.6(GLIBC_2.0) libm.so.6(GLIBC_2.1) libpthread.so.0 libpthread.so.0(GLIBC_2.0) librt.so.1 librt.so.1(GLIBC_2.2) libstdc++.so.5 libstdc++.so.5(CXXABI_1.2) libstdc++.so.5(GLIBCPP_3.2) system-config-display
    Conflicts: fglrx fglrx-glc22 fglrx_4_3_0 fglrx_6_8_0 kernel-module-fglrx ati-fglrx ati-fglrx-devel kmod-fglrx xorg-x11-drv-fglrx xorg-x11-drv-fglrx-devel nvidia-glx nvidia-glx-legacy xorg-x11-drv-nvidia xorg-x11-drv-nvidia-legacy
    Processing files: ATI-fglrx-control-panel-8.30.3-1.fc6
    error: File not found: /tmp/ATI-fglrx-8.30.3-1-3168-root/tmp/ATI-fglrx-8.30.3-1.fc6-root-root/usr/bin/fireglcontrolpanel
    Processing files: ATI-fglrx-devel-8.30.3-1.fc6
    Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
    Requires: /usr/include/GL ATI-fglrx = 8.30.3-1.fc6 libGL.so.1
    Processing files: kernel-module-ATI-fglrx-2.6.18-1.2798.fc6-8.30.3-1.fc6
    Requires(interp): /bin/sh /bin/sh
    Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
    Requires(post): /bin/sh
    Requires(postun): /bin/sh
    Processing files: ATI-fglrx-debuginfo-8.30.3-1.fc6
    Provides: atiogl_a_dri.so.debug fglrx_dri.so.debug fglrx_drv.so.debug libGL.so.1.2.debug libfglrx_dm.so.1.0.debug libfglrx_gamma.so.1.0.debug libfglrx_pp.so.1.0.debug libfglrx_tvout.so.1.0.debug libfglrxdrm.so.debug
    Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
    
    
    RPM build errors:
        File not found: /tmp/ATI-fglrx-8.30.3-1-3168-root/tmp/ATI-fglrx-8.30.3-1.fc6-root-root/usr/bin/fireglcontrolpanel
    Removing temporary directory: fglrx-install

    Leave a comment:

Working...
X