Announcement

Collapse
No announcement yet.

Noob question on installing proprietary driver with fedora 7

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Noob question on installing proprietary driver with fedora 7

    Hi guys,

    I apologize for the somewhat remedial nature of this post.

    I have a cheap motherboard with an integrated Xpress 200M graphics chip, I'm using it as a home theater PC. I'm trying to see if it can handle high-resolution video playback before I buy a discreet graphics card.

    I am running Fedora 7 (64 bit).

    I'd like to install some reasonably reliable version of the proprietary driver to see how it works, but when I try with 8.40.4, I get an error when I try to start X that the driver cannot be found.

    Should I be using a different version, or am I doing something wrong?

  • #2
    or am I doing something wrong?
    I'll answer when I know what you were doing.

    Comment


    • #3
      Okay, some more info.

      I'm using kernel 2.6.22.4-65.fc

      I downloaded the 8.40.4 driver.

      I run "sh ./ati-driver-installer-8.40.4-x86.x86_64.run --buildpkg Fedora/F7"

      I use rpm -ivn to install all five rpms that are created. There are no errors.

      I run "aticonfig --initial -f" to create a xorg.conf file that uses the new driver.

      Finally, when I startx, I get dumped back to a text prompt. Here's the last portion of the xorg log

      Code:
      (II) ATI Proprietary Linux Driver Version Identifier:8.40.4
      (II) ATI Proprietary Linux Driver Release Identifier: UNSUPPORTED-8.402                    
      (II) ATI Proprietary Linux Driver Build Date: Jul 31 2007 22:20:56
      (--) Assigning device section with no busID to primary device
      (--) Chipset Supported AMD Graphics Processor (0x5954) found
      (II) AMD Video driver is running on a device belonging to a group targeted for this release
      (II) AMD Video driver is signed
      (II) resource ranges after xf86ClaimFixedResources() call:
      
      <lots of resource ranges trimmed>
      
      Backtrace:
      0: X(xf86SigHandler+0x6d) [0x48b99d]
      1: /lib64/libc.so.6 [0x353e430630]
      2: /usr/lib64/xorg/modules/drivers//fglrx_drv.so(atiddxSave64BitBAR+0x2d) [0x2aaaac7d680d]
      3: /usr/lib64/xorg/modules/drivers//fglrx_drv.so(atiddxProbeMain+0x37f) [0x2aaaac7e19bf]
      4: X(InitOutput+0x6e7) [0x463707]
      5: X(main+0x275) [0x434625]
      6: /lib64/libc.so.6(__libc_start_main+0xf4) [0x353e41dab4]
      7: X(FontFileCompleteXLFD+0x229) [0x433ad9]
      
      Fatal server error:
      Caught signal 11.  Server aborting
      I got the same problem when I removed the rpms and just tried to use the automatic installer.

      I had the same problem when I tried driver 8.39.4.

      I attempted the new 8.41.7, but I couldn't even build the rpm packages.

      Comment


      • #4
        Try applying this to the driver and see if it works:

        Code:
        su -
        cd /usr/lib64/xorg/modules/drivers/
        mv fglrx_drv.so fglrx_drv.so.orig
        cat fglrx_drv.so.orig | sed "s/\xe8\x61\x2c\xfe\xff/\x90\x90\x90\x90\x90/g" > fglrx_drv.so
        diff fglrx_drv.so fglrx_drv.so.orig 
        aticonfig --initial
        Make sure you're using 8.40.4

        Comment


        • #5
          Well, kind of a good news, bad news, thing.

          I followed your tip and I was able to start X windows successfully! However, I still had the old 8.39 kernel modules installed, so my X log complained about the version mismatch, and said no 3d accel would be enabled (that's okay, I'm mainly concerned with 2d video performance).

          I removed the 8.39 kernel headers, and installed the 8.40.4 ones from the rpm package. Unfortunately, then why I try to start X, it just sits there at a black screen. The last section of the log reads like this:

          Code:
          (II) fglrx(0): Kernel Module Version Information:
          (II) fglrx(0):     Name: fglrx
          (II) fglrx(0):     Version: 8.40.4
          (II) fglrx(0):     Date: Jul 31 2007
          (II) fglrx(0):     Desc: ATI FireGL DRM kernel module
          (II) fglrx(0): Kernel Module version matches driver.
          (II) fglrx(0): Kernel Module Build Time Information:
          (II) fglrx(0):     Build-Kernel UTS_RELEASE:        2.6.22.4-65.fc7
          (II) fglrx(0):     Build-Kernel MODVERSIONS:        yes
          (II) fglrx(0):     Build-Kernel __SMP__:            yes
          (II) fglrx(0):     Build-Kernel PAGE_SIZE:          0x1000
          (II) fglrx(0): [drm] register handle = 0x00004000
          (II) fglrx(0): Interrupt handler installed at IRQ 17.
          (II) fglrx(0): Exposed events to the /proc interface
          (II) fglrx(0): [drm] ringbuffer size = 0x00100000 bytes
          (II) fglrx(0): [drm] texture shared area handle = 0x00008000
          (II) fglrx(0): shared FSAAScale=1
          Regardless, performance when I had the proprietary driver working in 2d mode didn't seem any better than using the open source X.org RADEON driver for displaying video on my bigscreen TV. Unless there's a miraculous performance increase I don't know about, I'll probably need to look for another solution.

          Comment


          • #6
            Originally posted by EasyRhino View Post
            Well, kind of a good news, bad news, thing.

            I followed your tip and I was able to start X windows successfully! However, I still had the old 8.39 kernel modules installed, so my X log complained about the version mismatch, and said no 3d accel would be enabled (that's okay, I'm mainly concerned with 2d video performance).

            I removed the 8.39 kernel headers, and installed the 8.40.4 ones from the rpm package. Unfortunately, then why I try to start X, it just sits there at a black screen. The last section of the log reads like this:

            Regardless, performance when I had the proprietary driver working in 2d mode didn't seem any better than using the open source X.org RADEON driver for displaying video on my bigscreen TV. Unless there's a miraculous performance increase I don't know about, I'll probably need to look for another solution.
            So you did my advice with the 8.39 drivers? Thats the cause of the 3d not working then. But I am a little confused, you had the 8.39 kernel headers installed on top of the 8.40.4 driver? Make sure you clean the drivers all out, install the 8.40.4 drivers, reapply the code I gave you and try it again. That tweak up there will need to be applied everytime you install a new driver. And its only for 8.40.4, you will have issues with other drivers with that tweak.

            Also make sure you have composite and AIGLX disabled in your /etc/X11/xorg.conf file, add these at the end if you haven't already:

            Code:
            Section "Extensions"
                  Option "Composite" "Disable"
            EndSection
            
            Section "ServerFlags"
                  Option "AIGLX" "off"
            EndSection
            
            Section "DRI"
            Mode 0666
            EndSection
            If you can't get 8.40.4 working, you can use this code on the 8.39 drivers, its the same thing except the cat part:


            Only For 8.39 Only:

            Code:
            su -
            cd /usr/lib64/xorg/modules/drivers/
            mv fglrx_drv.so fglrx_drv.so.orig
            cat fglrx_drv.so.orig | sed "s/\xe8\xb1\x30\xfe\xff/\x90\x90\x90\x90\x90/g" > fglrx_drv.so
            diff fglrx_drv.so fglrx_drv.so.orig 
            aticonfig --initial
            Heres the one for 8.40.4 only just as a reminder:


            Only For 8.40.4 Only:

            Code:
            su -
            cd /usr/lib64/xorg/modules/drivers/
            mv fglrx_drv.so fglrx_drv.so.orig
            cat fglrx_drv.so.orig | sed "s/\xe8\x61\x2c\xfe\xff/\x90\x90\x90\x90\x90/g" > fglrx_drv.so
            diff fglrx_drv.so fglrx_drv.so.orig 
            aticonfig --initial
            Also, if you haven't rebooted the machine and are switching drivers, after you uninstall the old ones, and go to install the new ones, make sure you aren't running X and unload the fglrx kernel module:

            Code:
            rmmod fglrx
            Either that or your other option is just to reboot.

            I hope that all makes sense hehe. Hope to hear back from you.
            Last edited by Malikith; 09-14-2007, 12:03 PM.

            Comment


            • #7
              thanks for the suggestions.

              I was going back and forth between working on my ATI card and working on my Nvidia card, and it turned out that I was able to get excellent results with the nvidia card first. So I pretty much shelved the ATI efforts.

              Comment

              Working...
              X